路由器工作原理与静态路由配置

      最后更新:1星期前 手机定位技术交流文章

      目录

      一、路由器工作原理

      二、路由表的形成

      三、静态路由和默认路由

      四、配置静态路由

      1、画出拓扑图,标明IP地址,并开启

      2、点击PC设置PC的IP地址及网关

      2.1配置PC1的IP地址与网关

      2.2配置PC2的IP地址与网关

      3、配置静态路由器

      3.1配置路由器R1的IP地址

      3.2配置路由器R2的IP地址

      3.3配置路由器R3的IP地址

      4、配置完IP地址后直接配置静态路由

      4.1配置R1静态路由

      4.2配置R2静态路由

      4.3配置R3静态路由

      5、进行测试

      五、配置默认路由

      1、画出拓扑图,标明IP地址,并开启

      2、点击PC设置PC的IP地址及网关

      2.1配置PC1的IP地址与网关

      2.2配置PC2的IP地址与网关

      3、配置路由器IP地址

      3.1配置路由器R1的IP地址

      3.2配置路由器R2的IP地址

      3.3配置路由器R3的IP地址

      4、配置完IP地址后直接配置默认路由

      4.1配置R1

      4.2配置R2

      4.3配置R3

      5、进行测试

      六、总结

      一、路由器工作原理

      路由的工作原理:根据路由表转发数据

      二、路由表的形成

      路由器中维护的路由条目的集合,路由器根据路由表做路径选择

      • 直连网段:配置IP地址,端口UP状态,形成直连路由
      • 非直连网段: 需要静态路由或动态路由,将网段添加到路由表中

      三、静态路由和默认路由

      1. 静态路由 : 网络管理员手动配置将不知道的网段手动配置进路由表,允许对路由的行为进行精确的控制,静态路由是单向的,并且缺乏灵活性。
      2. 动态路由:路由器会发广播告诉相邻的路由器自己的路由
      3. 默认路由:当路由器在路由表中找不到目标网络的路由目条时,路由器把请求转发到默认路由接口。

      四、配置静态路由

      选择路由、电脑终端、以及设备连线

      1、画出拓扑图,标明IP地址,并开启

      2、点击PC设置PC的IP地址及网关

      2.1配置PC1的IP地址与网关

      (网关为开启下一网段的门,即图中的10.1.1.1)

      2.2配置PC2的IP地址与网关

      (网关为开启下一网段的门,即图中的10.1.4.1)

      3、配置静态路由器

      3.1配置路由器R1的IP地址

      <Huawei>sys//进入系统视图
      [Huawei]sys R1//改路由器名字
      [R1]int g0/0/0//进入g0/0/0 接口
      [R1-GigabitEthernet0/0/0]undo shutdown//开启端口
      [R1-GigabitEthernet0/0/0]ip add 10.1.1.1 24//配置IP地址
      [R1-GigabitEthernet0/0/0]dis this//显示接口信息

      [V200R003C00]

      #
      interface GigabitEthernet0/0/0
      ip address 10.1.1.1 255.255.255.0
      #
      return

      [R1-GigabitEthernet0/0/0]int g0/0/1//进入g0/0/1 接口
      [R1-GigabitEthernet0/0/1]undo shutdown//开启端口
      [R1-GigabitEthernet0/0/1]ip add 10.1.2.1 24//配置IP地址
      [R1-GigabitEthernet0/0/1]dis this//显示接口信息
      [V200R003C00]
      #
      interface GigabitEthernet0/0/1
      ip address 10.1.2.1 255.255.255.0
      #

      return
      [R1-GigabitEthernet0/0/1]q//退出接口
      [R1]display interface brief//查看接口信息
      PHY: Physical
      *down: administratively down
      (l): loopback
      (s): spoofing
      (b): BFD down
      ^down: standby
      (e): ETHOAM down
      (d): Dampening Suppressed
      InUti/OutUti: input utility/output utility
      Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
      GigabitEthernet0/0/0        up    up          0%     0%          0          0
      GigabitEthernet0/0/1        up    up          0%     0%          0          0
      GigabitEthernet0/0/2        down  down        0%     0%          0          0
      NULL0                       up    up(s)       0%     0%          0          0

      [R1]display  ip routing-table//查看路由表命令
      Route Flags: R - relay, D - download to fib
      ------------------------------------------------------------------------------
      Routing Tables: Public
      Destinations : 12       Routes : 12

      Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

      10.1.1.0/24  Direct  0    0           D   10.1.1.1        GigabitEthernet //直连网段
      0/0/0
      10.1.1.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
      0/0/0
      10.1.1.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
      0/0/0
      10.1.2.0/24  Direct  0    0           D   10.1.2.1        GigabitEthernet
      //直连网段
      0/0/1
      10.1.2.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
      0/0/1
      10.1.2.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
      0/0/1
      10.1.3.0/24  Static  60   0          RD   10.1.2.2        GigabitEthernet
      //非直连网段
      0/0/1
      10.1.4.0/24  Static  60   0          RD   10.1.2.2        GigabitEthernet
      //非直连网段
      0/0/1
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
      127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
      255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0

      3.2配置路由器R2的IP地址

      <Huawei>sys//进入系统视图
      [Huawei]sys R2//改路由器名字
      [R2]int g0/0/0//进入g0/0/0 接口
      [R2-GigabitEthernet0/0/0]undo shutdown//开启端口
      [R2-GigabitEthernet0/0/0]ip add 10.1.2.2 24//配置IP地址
      [R2-GigabitEthernet0/0/0]dis this//显示接口信息
      [V200R003C00]
      #
      interface GigabitEthernet0/0/0
      ip address 10.1.2.2 255.255.255.0
      #

      return
      [R2-GigabitEthernet0/0/0]int g0/0/1//进入g0/0/1 接口
      [R2-GigabitEthernet0/0/1]undo shutdown//开启端口
      [R2-GigabitEthernet0/0/1]ip add 10.1.3.2 24//配置IP地址

      3.3配置路由器R3的IP地址

      <Huawei>sys//进入系统视图
      [Huawei]sys R3//改路由器名字
      [R3]int g0/0/0//进入g0/0/0 接口
      [R3-GigabitEthernet0/0/0]undo shutdown//开启端口
      [R3-GigabitEthernet0/0/0]ip add 10.1.3.3 24//配置IP地址
      [R3-GigabitEthernet0/0/0]dis this//显示接口信息
      [V200R003C00]
      #
      interface GigabitEthernet0/0/0
      ip address 10.1.3.3 255.255.255.0
      #

      return
      [R3-GigabitEthernet0/0/0]int g0/0/1//进入g0/0/1 接口
      [R3-GigabitEthernet0/0/1]undo shutdown//开启端口
      [R3-GigabitEthernet0/0/1]ip add 10.1.4.1 24//配置IP地址
      [R3-GigabitEthernet0/0/1]dis this//显示接口信息
      [V200R003C00]
      #
      interface GigabitEthernet0/0/1
      ip address 10.1.4.1 255.255.255.0
      #

      return

      4、配置完IP地址后直接配置静态路由

      4.1配置R1静态路由

      [R1]ip route-static 10.1.3.0 24 10.1.2.2//非直连网段  子网掩码   下一跳地址
      [R1]ip route-static 10.1.4.0 24 10.1.2.2//非直连网段  子网掩码   下一跳地址

      4.2配置R2静态路由

      [R2]ip route-static 10.1.1.0 24 10.1.2.1//非直连网段  子网掩码   下一跳地址
      [R2]ip route-static 10.1.4.0 24 10.1.3.3//非直连网段  子网掩码   下一跳地址

      4.3配置R3静态路由

      [R3]ip route-static 10.1.1.0 24 10.1.3.2//非直连网段  子网掩码   下一跳地址
      [R3]ip route-static 10.1.2.0 24 10.1.3.2//非直连网段  子网掩码   下一跳地址

      5、进行测试

      五、配置默认路由

      1、画出拓扑图,标明IP地址,并开启

      2、点击PC设置PC的IP地址及网关

      2.1配置PC1的IP地址与网关

      (网关为开启下一网段的门,即图中的10.1.1.1)

      2.2配置PC2的IP地址与网关

      (网关为开启下一网段的门,即图中的10.1.4.1)

      3、配置路由器IP地址

      3.1配置路由器R1的IP地址

      <Huawei>sys//进入系统视图
      [Huawei]sys R1//改路由器名字
      [R1]int g0/0/0//进入g0/0/0 接口
      [R1-GigabitEthernet0/0/0]undo shutdown//开启端口
      [R1-GigabitEthernet0/0/0]ip add 10.1.1.1 24//配置IP地址
      [R1-GigabitEthernet0/0/0]dis this//显示接口信息
      [R1-GigabitEthernet0/0/0]int g0/0/1//进入g0/0/1 接口
      [R1-GigabitEthernet0/0/1]undo shutdown//开启端口
      [R1-GigabitEthernet0/0/1]ip add 10.1.2.1 24//配置IP地址

      3.2配置路由器R2的IP地址

      <Huawei>sys//进入系统视图
      [Huawei]sys R2//改路由器名字
      [R2]int g0/0/0//进入g0/0/0 接口
      [R2-GigabitEthernet0/0/0]undo shutdown//开启端口
      [R2-GigabitEthernet0/0/0]ip add 10.1.2.2 24//配置IP地址
      [R2-GigabitEthernet0/0/0]int g0/0/1//进入g0/0/1 接口
      [R2-GigabitEthernet0/0/1]undo shutdown//开启端口
      [R2-GigabitEthernet0/0/1]ip add 10.1.3.2 24//配置IP地址

      3.3配置路由器R3的IP地址

      <Huawei>sys//进入系统视图
      [Huawei]sys R3//改路由器名字
      [R3]int g0/0/0//进入g0/0/0 接口
      [R3-GigabitEthernet0/0/0]undo shutdown//开启端口
      [R3-GigabitEthernet0/0/0]ip add 10.1.3.3 24//配置IP地址
      [R3-GigabitEthernet0/0/0]dis this//显示接口信息
      [R3-GigabitEthernet0/0/0]int g0/0/1//进入g0/0/1 接口
      [R3-GigabitEthernet0/0/1]undo shutdown//开启端口
      [R3-GigabitEthernet0/0/1]ip add 10.1.4.1 24//配置IP地址

      4、配置完IP地址后直接配置默认路由

      只需R1与R3需要配置默认路由

      4.1配置R1

      [R1]ip route-static  0.0.0.0  0.0.0.0 10.1.2.2//任意网段  任意子网掩码   下一跳地址

      4.2配置R2

      [R2]ip route-static 10.1.1.0 24 10.1.2.1//非直连网段  子网掩码   下一跳地址
      [R2]ip route-static 10.1.4.0 24 10.1.3.3//非直连网段  子网掩码   下一跳地址

      4.3配置R3

      [R3]ip route-static 0.0.0.0 0.0.0.0 10.1.3.2//任意网段  任意子网掩码   下一跳地址

      5、进行测试

      六、总结

      <Huawei>sys//进入系统视图
      [Huawei]sys R1//改路由器名字
      [R1]interface g0/0/0//进入g0/0/0 接口
      [R1-GigabitEthernet0/0/0]undo shutdown//开启端口
      [R1-GigabitEthernet0/0/0]ip address 10.1.1.1 24//配置IP地址(IP地址  掩码长度)
      [R1-GigabitEthernet0/0/0]dis this//显示接口信息
      [R2]display interface brief//查看接口信息

      [R1]ip route-static   10.1.3.0         24             10.1.2.2// 配置静态路由

      //非直连网段    子网掩码     下一跳地址

      [R1]undo   ip route-static 10.1.3.0  24         10.1.2.2//撤销之前的命令

      [R1]ip route-static 0.0.0.0       0.0.0.0              10.1.2.2// 配置默认路由

      任意网段   任意子网掩码     下一跳地址
      [R1]display ip routing-table//查看路由表信息

      本文由 在线网速测试 整理编辑,转载请注明出处,原文链接:http://www.wangsu123.cn/news/16509.html

          热门文章

          文章分类