什么是计算机网络?网络协议的作用是什么?
1、计算机网络 计算机网络,是指将地理位置不同的具有独立功能的多台计算机及其外部设备,通过通信线路连接起来,在网络操作系统,网络管理软件及网络通信协议的管理和协调下,实现资源共享和[1]信息传递的计算机系统。2、网络协议网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。例如,网络中一个微机用户和一个大型主机的操作员进行通信,由于这两个数据终端所用字符集不同,因此操作员所输入的命令彼此不认识。为了能进行通信,规定每个终端都要将各自字符集中的字符先变换为标准字符集的字符后,才进入网络传送,到达目的终端之后,再变换为该终端字符集的字符。当然,对于不相容终端,除了需变换字符集字符外还需转换其他特性,如显示格式、行长、行数、屏幕滚动方式等也需作相应的变换。3、常用协议及作用TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。TCP/IP尽管是目前最流行的网络协议,但TCP/IP协议在局域网中的通信效率并不高,使用它在浏览“网上邻居”中的计算机时,经常会出现不能正常浏览的现象。此时安装NetBEUI协议就会解决这个问题。NetBEUI即NetBios Enhanced User Interface ,或NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用,例如Windows for Workgroup、Win 9x系列、WindowsNT等。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。NetBEUI协议是一种短小精悍、通信效率高的广播型协议,安装后不需要进行设置,特别适合于在“网络邻居”传送数据。所以建议除了TCP/IP协议之外,小型局域网的计算机也可以安上NetBEUI协议。另外还有一点要注意,如果一台只装了TCP/IP协议的WINDOWS98机器要想加入到WINNT域,也必须安装NetBEUI协议。IPX/SPX协议本来就是Novell开发的专用于NetWare网络中的协议,但是也非常常用--大部分可以联机的游戏都支持IPX/SPX协议,比如星际争霸,反恐精英等等。虽然这些游戏通过TCP/IP协议也能联机,但显然还是通过IPX /SPX协议更省事,因为根本不需要任何设置。除此之外,IPX/SPX协议在非局域网络中的用途似乎并不是很大.如果确定不在局域网中联机玩游戏,那么这个协议可有可无。
计算机网络是指将有独立功能的多台计算机,通过通信设备线路连接起来,在网络软件的支持下,实现彼此之间资源共享和数据通信的整个系统。 计算机网络协议:网络协议就是计算机之间进行通信的规则。为了使处于不同地点、装有不同操作系统的计算机之间有效地通信,必须有一种为各类计算机都能认可的通信方法,任一方所表达的信息均能被其他各方所认同,这就需要指定一种标准:网络协议。 就象老师在讲课时为了大家都能听懂,就必须使用普通话一样。最常用的协议有TCP/IP协议。

在计算机网络中,网络协议起到什么作用?
不要把问题想复杂了。 其实,网络协议的作用就是两点;一,保证网络中的计算机相互联接;二,保证网络中的计算机正确交换信息。
什么是计算机网络协议,网络工程师通过动画视频,通俗易懂来讲解

计算机网络协议有哪些,具体作用什么
目前网络协议有许多种,但是最基本的协议是TCP/IP协议,许多协议都是它的子协议。下面我们就对TCP/IP协议作一下简单介绍。 1TCP/IP协议基础TCP/IP协议包括两个子协议:一个是TCP协议(Transmission Control Protocol,传输控制协议),另一个是IP协议(Internet Protocol,互联网协议),它起源于20世纪60年代末。在TCP/IP协议中,TCP协议和IP协议各有分工。TCP协议是IP协议的高层协议,TCP在IP之上提供了一个可靠的,连接方式的协议。TCP协议能保证数据包的传输以及正确的传输顺序,并且它可以确认包头和包内数据的准确性。如果在传输期间出现丢包或错包的情况,TCP负责重新传输出错的包,这样的可靠性使得TCP/IP协议在会话式传输中得到充分应用。IP协议为TCP/IP协议集中的其它所有协议提供“包传输”功能,IP协议为计算机上的数据提供一个最有效的无连接传输系统,也就是说IP包不能保证到达目的地,接收方也不能保证按顺序收到IP包,它仅能确认IP包头的完整性。最终确认包是否到达目的地,还要依靠TCP协议,因为TCP协议是有连接服务。在计算机服务中如果按连接方式来分的话,可分为“有连接服务”和“无连接服务”两种。“有连接服务”必须先建立连接才能提供相应服务,而“无连接服务”则不需先建立连接。TCP协议是一种典型的有连接协议,而UDP协议则是典型的无连接服务。TCP/IP协议所包括的协议和工具TCP/IP协议是一组网络协议的集合,它主要包括以下几方面的协议和工具。·TCP/IP协议核心协议这些核心协议除了自身外,还包括用户数据报协议(UDP协议)、地址代理协议(ARP协议)以及网间控制协议(ICMP协议)。这组协议提供了一系列计算机互连和网络互连的标准协议。·应用接口协议这类协议主要包括Windows套接字(Socket,用于开发网络应用程序)、远程调用、NetBIOS协议(用于建立逻辑名和网络上的会话)和网络动态数据交换(Network,用于通过网络共享嵌入在文本中的信息)。·基本的TCP/IP协议互连应用协议主要包括finger、ftp、rep、rsh、telnet、tftp等协议。这些工具协议使得Windows系统用户使用非Microsoft系统计算机上(如UNIX系统计算机)的资源成为可能。·TCP/IP协议诊断工具这些工具包括arp、hostname、ipconfig、nbstat、netstat、ping和route,它们可用来检测并恢复TCP/IP协议网络故障。·有关服务和管理工具这些服务和管理工具包括FTP服务器服务(用于在两个远程计算机之间传输文件,这是远程控制通信中的关键功能)、网际命名服务WINS(用于在一个网际上动态记录和询问计算机的名字)、动态计算机配置协议DHCP(用于在Windows NT计算机上自动配置TCP/IP协议)以及TCP/IP协议打印(主要用于远程打印和网络打印)。·简单网络管理协议代理(SNMP)这个工具允许通过使用管理工具(如“Sun Net Manages” 或“HP Open View”),从远程管理Windows NT计算机。(2)TCP/IP的主要协议简述为了使读者能全面了解一些基本的网络通信协议和服务,本节就对TCP/IP协议所包括的几种主要协议进行简要说明。·远程登录协议(Telnet)Telnet协议是用来登录到远程计算机上,并进行信息访问,通过它可以访问所有的数据库、联机游戏、对话服务以及电子公告牌,如同与被访问的计算机在同一房间中工作一样,但只能进行些字符类操作和会话。·文件传输协议(Ftp)这是文件传输的基本协议,有了FTP协议就可以把的文件进行上传,也可从网上得到许多应用程序和信息(下载),有许多软件站点就是通过FTP协议来为用户提供下载任务的,俗称“FTP服务器”。最初的FTP程序是工作在UNIX系统下的,而目前的许多FTP程序是工作在Windows系统下的。FTP程序除了完成文件的传送之外,还允许用户建立与远程计算机的连接,登录到远程计算机上,并可在远程计算机上的目录间移动。·电子邮件服务(Email)电子邮件服务是目前最常见、应用最广泛的一种到联网服务。通过电子邮件,可以与Internet上的任何人交换信息。电子邮件的快速、高效、方便以及价廉,越来越得到了广泛的应用,目前只要是上过网的网民就肯定用过电子邮件这种服务。目前,全球平均每天约有几千万份电子邮件在网上传输。·WWW服务WWW服务(3W服务)也是目前应用最广的一种基本互联网应用,我们每天上网都要用到这种服务。通过WWW服务,只要用鼠标进行本地操作,就可以到达世界上的任何地方。由于WWW服务使用的是超文本链接(HTML),所以可以很方便的从一个信息页转换到另一个信息页。它不仅能查看文字,还可以欣赏图片、音乐、动画。最流行的WWW服务的程序就是微软的IE浏览器。·简单邮件传输协议(SMTP)SMTP是TCP/IP协议族的一个成员,这种协议认为你的计算机是永久连接在Internet上的,而且认为你在网络上的计算机在任何时候是可以被访问的。它适用于永久连接在Internet的计算机,但无法使用通过SLIP/PPP协议连接的用户接收电子邮件。解决这个问题的办法是在邮件计算机上同时运行SMTP和POP协议的程序,SMTP负责邮件的发送和在邮件计算机上的分拣和存储,POP协议负责将邮件通过SLIP/PPP协议连接传送到用户计算机上。·信息服务(Gopher)Gopher最早出现在1991年,它是第一个操作简便、使用广泛的从Internet服务器上获取信息的客户应用程序。除了操作简便外,它的另一个特点是速度快。Gopher运行时,将显示一个交互式的供用户选择的菜单,菜单中的选项由简单的短句组成,每个短句通常指向另一个菜单,并最终指向有用的文件。Gopher是帮助用户在Internet信息海洋中搜索有用信息的导航器。用户只要关心浏览的内容,而不必关心具体的服务器。·文件检索服务(Archie)它是一个从整个Internet上匿名FTP服务器获取文件的服务。其完全依赖于匿名FTP系统的管理员,他们将站点在全世界的Archie服务器进行了注册,Archie仅通过文件名进行检索。2 IP协议目前正在使用的IP协议是第4版的,称之为“IPv4”,新版本的IP协议正在完善过程中,它就是经常可以在各大IT媒体中见到的IPv6。IPv6所要解决的主要是IPv4协议中IP地址远远不够的现象。IPv4所采用的是32位,而IPv6则是128位,是原来的4倍。IPv6所提供的IP地址数已可算是天文数字了,据专家们分析,这个数字的IP地址可以使全球的每一个人都可拥有10以上的IP地址,这么多的IP地址相信再也不会出现IPv4那样除了美国外,各国都出现IP地址短缺现象,为将来实现移动上网打下了坚实的基础。但这属于较新技术,在此就不作详细介绍,本文仍以目前主流的IPv4协议为基础进行介绍。IP协议的功能是把数据报在互联的网络上传送,通过将数据报在一个个IP协议模块间传送,直到目的模块。网络中每个计算机和网关上都有IP协议模块。数据报在一个个模块间通过路由处理网络地址传送到目的地址,因此搜寻网络地址对于IP协议十分重要的功能。另外,因为各个网络上的数据报大小可能不同,所以数据报的分段也是IP协议的不可或缺的功能,不然对于一些网络带宽较窄的网络,大的数据报就无法正确传输了。下面主要介绍我们初级学者所关心的现行方面问题。(1)IP地址在计算机寻址中经常会遇到“名字”、“地址”和“路由”这三个术语,它们之间是有较大区别的。名字是要找的,就像的人名一样;而地址是用来指出这个名字在什么地方,就像人的住址一样;路由是解决如何到达目的地址的问题,就像已经知道了某个人住在什么地方,现在要考虑走什么路线、采用什么交通工具到达目的地方最为简便。这里所介绍的IP协议主要是解决地址的问题。名字和地址进行解析的工作是由其上层协议--TCP协议完成。IP协议模块将地址和本地网络地址加以映射(就像写信一样,IP协议只负责把收、发信人的地址写上,把信投进邮箱就可不管了),而将本地网络地址和路由进行映射则是低层协议(如路由协议)的任务,所以说IP协议是一个无连接的服务。IP协议要寻找的“地址”是32位长(4个分段的16进制组成),由网络号(网络ID)和主机号(主机ID)两部分构成,按照IP协议规定因特网上的地址共有A、B、C、D、E五类.按照IP协议规定因特网上的地址共有A、B、C、D、E五类·A类IP地址:用前面8位来标识网络号,其中规定最前面一位为“0”,24位标识主机地址,即A类地址的第一段取值(也即网络号)可以是“00000001 ̄01111111”之间任一数字,转换为十进制后即为1~128之间。主机号没有做硬性规定,所以它的IP地址范围为“1.0.0.0-128.255.255.255”。A类地址是为大型政府网络而提供,因为A地址中有10.0.0.0-10.255.255.254和127.0.0.0-127.255.255.254这两段地址有专门用途,所以全世界总共只有126个可能的A类网络。每个A类网络最多可以连接16777214台计算机,这类地址数是最少的,但这类网络所允许连接的计算机是最多的。·B类IP地址:用前面16位来标识网络号,其中最前面两位规定为“10”,16位标识主机号,也就是说B类地址的第一段“10000000 ̄10111111”,转换成十进制后即为128~191之间,第一段和第二段合在一起表示网络地址,它的地址范围为“128.0.0.0-191.255.255.255”。B类地址适用于中等规模的网络,全世界大约有16000个B类网络,每个B类网络最多可以连接65534台计算机。这类IP地址通常为中等规模的网络提供。其中172.16.0.0-172.31.255.254地址段有专门用途。·C类IP地址:用前面24位来标识网络号,其中最前面三位规定为“110”,8位标识主机号。这样C类地址的第一段取值为“11000000 ̄11011111”之间,转换成十进制后即为192~223。第一段、第二段、第三段合在一起表示网络号,最后一段标识网络上的主机号,它的地址范围为“192.0.0.0-223.255.255.255”。C类地址适用于校园网等小型网络,每个C类网络最多可以有254台计算机。这类地址是所有的地址类型中地址数最多的,但这类网络所允许连接的计算机是最少的。这类IP地址可分配给任何有需要的人。其中192.168.0.0-192.168.255.255为企业局域网专用地址段。·D类地址:它用于多重广播组,一个多重广播组可能包括1台或更多主机,或根本没有。D类地址的最高位为1110,第一段八位体为“11100000 ̄11101111”,转换成十进制即为224 ̄239,剩余的位设计客户机参加的特定组,它的地址范围为“224.0.1.1-239.255.255.255”。在多重广播操作中没有网络或主机位,数据包将传送到网络中选定的主机子集中,只有注册了多重广播地址的主机才能接收到数据包。Microsoft支持D类地址,用于应用程序将多重广播数据发送到网络间的主机上,包括WINS和Microsoft NetShow。·E类地址:这是一个通常不用的实验性地址,保留作为以后使用。E类地址的最高位为11110,第一段八位体为“11110000 ̄11110111”,转换成十进制即为240 ̄247。IPv4协议中对首段位为248 ̄254 的地址段暂无规定。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。(2) 子网掩码和域名以上介绍的是网络IP地址,但随着网络的发展,IPv4标准中的IP地址远不够用,为了解决这一矛盾,于是又在IP地址加上子网掩码来进一步识别。在TCP/IP协议中规定,A类网络的子网掩码格式为“255.0.0.0”形式,后面的“0”可以为“0 ̄254”之间任一数字。B类网络的子网掩码格式为“255.255.0.0”,C类网络的子网掩码为格式为“255.255.255.0”,同样其中的“0”可以是“0 ̄254”之间任一数字。如果没有子网,可以为“0”,也可以不配置,如果有子网则一定要配置。前面介绍的IP地址都是以数字形式表示计算机的地址,这种IP地址人们记忆起来是非常困难的。对非计算机和网络的专业人士来说,记住这种地址是很不现实的。因此,Internet还采用域名地址来表示每台计算机。通过为每台计算机建立IP地址与域名地址之间的映射关系,用户可以在网上避开难以记忆的IP地址,而用域名地址来唯一标记网上的计算机。域名地址与IP地址的关系类似于一个人的姓名与身份证号码之间的关系。要把计算机连入Internet,必须获得网上唯一的IP地址与对应的域名地址。域名地址由域名系统(DNS)管理。每个连到Internet的网络中都有至少一个DNS服务器,其中存有该网络中所有计算机的域名和对应的IP地址,通过与其他网络的DNS服务器相连就可以找到其他站点。这也是在TCP/IP协议属性中要进行DNS配置的原因。 域名地址也是分段表示的,每段分别授权给不同的机构管理,各段之间用圆点(.)分隔。与IP地址相反,各段自左至右级别是越来越高。
在Windows系统下,网络属性里面可以看到的,常用的网络协议主要有: 一:NETBEUI二:IPX/SPX三:TCP/IP后台你看不到的,不同的”层“,有不同的协议,简单描述如下:应用层·DHCP(动态主机分配协议)· DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议· NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议· UDP (User Datagram Protocol) 用户数据报协议· DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议· SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议· RTPReal-time Transport Protocol或简写RTP)实时传送协议· RSVP (Resource ReSer Vation Protocol)资源预留协议· PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线参考:百度百科:计算机网络协议http://baike.baidu.com/link?url=DdLG-MueM8f8iaDhTf7SfZtCimzsF521HByuq6CcEioerX-jTE7ZNWi4_RRWsZcR

协议在网络通信中的作用是什么?
摘要网络协议的作用是为了能进行通信,规定每个终端都要将各自字符集中的字符先变换为标准字符集的字符后,才进入网络传送,到达目的终端之后,再变换为该终端字符集的字符。

网络协议作用是什么?
网络协议作用:网络协议是网络上所有设备(网络服务器、计算机及交换机、路由器、防火墙等)之间通信规则的集合,它定义了通信时信息必须采用的格式和这些格式的意义。大多数网络都采用分层的体系结构,每一层都建立在它的下层之上,向它的上一层提供一定的服务,而把如何实现这一服务的细节对上一层加以屏蔽。一台设备上的第n层与另一台设备上的第n层进行通信的规则就是第n层协议。在网络的各层中存在着许多协议,接收方和发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息。网络协议使网络上各种设备能够相互交换信息。网络协议三要素:(1) 语义。语义是解释控制信息每个部分的意义。它规定了需要发出何种控制信息,以及完成的动作与做出什么样的响应。(2) 语法。语法是用户数据与控制信息的结构与格式,以及数据出现的顺序。(3) 时序。时序是对事件发生顺序的详细说明。(也可称为“同步”)。人们形象地把这三个要素描述为:语义表示要做什么,语法表示要怎么做,时序表示做的顺序。

本文由 在线网速测试 整理编辑,转载请注明出处。