BGP是什么?
BGP(Border Gateway Protocol)基本功能在自治系统间自动交换无环路的路由信息,通过交换带有自治区域号(AS)序列属性的路由可达信息,来构造自治区域的拓扑图,从而消除路由环路并实施用户配置的策略。 BGP特点 1、距离矢量协议 2、传输协议:TCP,端口号:179,(重要) 3、支持CIDR(无类别域间选路)(重要) 4、路由更新只发送增量路由;(重要) 5、丰富的路由过滤和路由策略。 BGP经历了4个版本 RFC1105(BGP-1),RFC1163(BGP-2),RFC1267(BGP-3),RFC1771(BGP-4) 自治系统的编号范围 自治系统的编号范围为1~65535,其中1~65411注册的因特网编号,65412~65535专用网络编号。(重要)(重要)(重要) BGP两种邻居IBGP和EBGP,如果EBGP没有物理直连,使用neighbor x.x.x.x ebgp-multihop TTL补救 ,TTL缺省为64,取值范围:1-255 BGP的通告原则 1、多条路径时,BGP SPEAKER只选最优的给自己使用; 2、BGP SPEAKER只把自己使用的路由通告给相邻体; 3、BGP SPEAKER从EBGP获得的路由会向所有BGP相邻体通告(包括IBGP和EBGP) 4、BGP SPEAKER从IBGP获得的路由不向它的IBGP相邻体通告; 5、BGP SPEAKER从IBGP获得的路由是否通告给它的EBGP相邻体要依IGP和BGP的同步情况来决定; 6、连接一建立,BGP SPEAKER将把自己所有BGP路由通告给新相邻体。 成为BGP路由的途径 1、纯动态注入 2、半动态注入 3、静态注入 BGP报文有四种类型1、OPEN(版本、自治系统号、保持时间、BGP标识符) 2、KEEPALIVE(长度:19BIT,间隔60秒) 3、UPDATE(撤销路由信息、可达路由信息) 4、NOTIFICATION UPDATE报文构成 1、不可达路由; 2、 路径属性; 3、 网络可达性信息。 注意:一个UPDATE信息一次通告一个路由(携带多个路径属性),如果一次通告多个路由(必须路径属性相同),同时可以列出多个被撤销的路由。 BGP协议的6个状态 1、IDLE 2、CONNECT 3、ACTIVE 4、OPENSENT 5、OPENCONFIRM 6、ESTABLISHED BGP的路由属性共有16种,可以扩展到256种,常见为以下6种,并从属于4个范畴: 类型代码属性名必遵/可选过渡/非过渡 1Origin必遵过渡 2As-path必遵过渡 3Next-hop必遵过渡 4MED可选非过渡 5Local-preference可选非过渡 8Community可选过渡起点(Origin)属性 1、IGP,通过network命令注入BGP路由表的,值为0,; 2、EGP,通过其他EGP得到的路由的起点类型,值为1; 3、Incomplete,通过纯动态注入BGP路由表的,值为2。通常其他因素相同时,按照以上顺序选择路由。 团体(Community)属性 1、no-export 2、no-advertise 3、local-as 4、internet BGP路由选择过程 1、如果此路由下一跳不可达,则忽略该路由; 2、选择本地优先级大的路由; 3、如果本地优先级相同,选择本地路由器始发的路由; 4、选择AS路径短的路由; 5、一次选择起点类型为IGP,EGP,INCOMPLETE类型路由; 6、选择MED 小的路由; 7、选择ROUTER ID小的路由。 取自" http://wiki.ccw.com.cn/BGP "

bgp分发模式什么意思
BGP(Border Gateway Protocol,边界网关协议),是一种距离矢量路由协议,严格的说应该叫路径矢量路由协议,主要用于在AS之间传递路由信息,适用于大规模的网络环境。Internet的骨干网络正是得益于BGP才能承载如此大批量的路由前缀。总的来说,无论是内部网关路由协议,或者外部网关路由协议,最终的目的都是为了实现路由的互通,从而最终实现数据的互通。BGP的协议特征。BGP在传输层使用TCP以确保可靠传输,所使用的TCP目的端口号为179。BGP会在需要交换路由的路由器之间建立TCP连接,这些路由器被称为BGP对等体,也叫BGP邻居。有两种BGP邻居关系:EBGP邻居关系,以及IBGP邻居关系。BGP的邻居关系可以跨路由器建立,而不像OSPF及RIP那样,必须要求直连。BGP对等体在邻居关系建立时交换整个BGP路由表。在邻居关系建立完成后,BGP路由器只发送增量更新或触发更新(不会周期性更新)。BGP具有丰富的路径属性和强大的策略工具。BGP能够承载大批量的路由前缀,用于大规模的网络中。

BGP对等体之间建立连接所使用的端口号?路由属性分为哪几类。常用的有哪几种?(至少四种)
BGP对等体(neighbor)之间通过TCP建立连接,端口号为TCP179。 路由属性是指什么,PA(path attribute)吗?CCNP里提到比较重要的有next hop,local preference,AS_Path,Origin,MED(multiple exit discriminator),即CCNP书中讲的N WLLA OMNI中的第一个N,第一个L,A和O 常用的,是指最经常用来影响BGP路由选择的三个,即local preference,AS_Path,MED。你问4种是不是把weight也包含进去。Weight不是标准PA,是cisco私有的,在路由器本地影响出口路由的选择,但不能通过BGP update在BGP对等体之间传播。

BGP使用端口179,是不是协议号就是6呢?
BGP数据封装在传输层之后,所以没有协议号,TCP协议号是6,UDP是7,BGP只有端口号。

哪些路由协议属于IGP,哪些属于BGP
路由协议分为IGP,EGP(内部网关协议,外部网关协议)。IGP 内部网关协议常见的有rip ospf is-is eigrp。BGP是一个EGP(外部网关协议),是一个具体的协议,不是一个分类。和IGP相对的是EGP,EGP叫做外bai部网关协议,EGP包括EGP和BGP,而du现在没有人用EGP了,所以实际上外部网关协议只有BGP一种了。注意,前面的EGP是分类,后面的那个EGP是具体的路由协议,不要混淆这两个概念。IGP:IGP(International GroupProgram)是世界上最大的专门为跨国公司提供员工福利计划的国际共保组织。迄今为止,IGP已经为660多个跨国公司的4400多个分支机构提供员工福利保障,位居世界500强的公司中有2/3都是IGP的客户。
路由协议分为IGP,EGP(内部网关协议,外部网关协议)IGP 内部网关协议,常见的有rip ospf is-is eigrp。BGP是一个EGP(外部网关协议),是一个具体的协议,不是一个分类。和IGP相对的是EGP,EGP叫做外bai部网关协议,EGP包括EGP和BGP,而du现在没有人用EGP了,所以实际上外部网关协议只有BGP一种了。注意,前面的EGP是分类,后面的那个EGP是具体的路由协议,不要混淆这两个概念。扩展资料:BGP连接:在各个AS的BGP发言人之间有一个BGP会话进程,通过会话沟通路由,经过声明的AS到达某目标网络。本文档中,我们对构成BGP连接的BGP发言人加以额外限制:他们必须是自己直接共享数据链路子网。因此,相邻AS间的BGP会话无需AS内或AS间的路由。超出本文范围的案例可能与该限制不符。因此,在每个连接中,每个AS拥有一个以上的BGP发言人和边界网关路由器,这些BGP发言人和边界网关路由器分布在共享数据链路子网上。注意到, BGP发言人不一定是边界网关路由器,反之亦然。一条连接上一个AS的BGP发言人声明的路径可以被同一个共享子网上其他AS的边界网关路由器使用,也就是非直接的邻居是允许的。参考资料来源:百度百科-BGP路由协议
RIP、OSPF和IS-IS协议属于IGP,Internet协议属于BGP。如果通过人工指定转发策略,将会给网络管理员带来巨大的工作量,并且在管理、维护路由表上也变得十分困难。为了解决这个问题,动态路由协议应运而生。动态路由协议可以让路由器自动学习到其他路由器的网络,并且网络拓扑发生改变后自动更新路由表。网络管理员只需要配置动态路由协议即可,相比人工指定转发策略,工作量大大减少。相关作用:对于大型网络,采用链路状态算法的IS-IS和OSPF较为有效,并且得到了广泛的应用。IS-IS与OSPF在质量和性能上的差别并不大,但OSPF更适用于IP,较IS-IS更具有活力。IETF始终在致力于OSPF的改进工作,其修改节奏要比IS-IS快得多。这使得OSPF正在成为应用广泛的一种路由协议。不论是传统的路由器设计,还是即将成为标准的MPLS(多协议标记交换),均将OSPF视为必不可少的路由协议。外部网关协议最初采用的是EGP。EGP是为一个简单的树形拓扑结构设计的,随着越来越多的用户和网络加入Internet,给EGP带来了很多的局限性。为了摆脱EGP的局限性,IETF边界网关协议工作组制定了标准的边界网关协议--BGP。以上内容参考:百度百科-路由协议
路由协议分为IGP,EGP。一、IGPIGP是在内部网络上使用的路由协议,它可以通过不断的交换信息让路由器动态的适应网络连接的变化,这些信息包括每个路由器可以到达哪些网络,这些网络有多远等。 IGP是应用层协议,并使用UDP作为传输协议,使用端口号为520。RIP使用跳数(HopCount)来衡量到达目的地址的距离,称为度量值。在RIP中,缺省情况下,路由器到与它直接相连网络的跳数为0,通过一个路由器可达的网络的跳数为1,其余依此类推。也就是说,度量值等于从本网络到达目的网络间的路由器数量。为限制收敛时间,RIP规定度量值取0~15之间的整数,大于或等于16的跳数被定义为无穷大,即目的网络或主机不可达。由于这个限制,使得RIP不可能在大型网络中得到应用。二、BGP(边界网关协议)BGP是运行于 TCP 上的一种自治系统的路由协议。 BGP 是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。 BGP 构建在 EGP 的经验之上。BGP 系统的主要功能是和其他的 BGP 系统交换网络可达信息。网络可达信息包括列出的自治系统(AS)的信息。这些信息有效地构造了 AS 互联的拓朴图并由此清除了路由环路,同时在 AS 级别上可实施策略决策。BGP属于外部网关路由协议,可以实现自治系统间无环路的域间路由。BGP是沟通Internet广域网的主用路由协议,例如不同省份、不同国家之间的路由大多要依靠BGP协议。BGP可分为IBGP(Internal BGP)和EBGP(External BGP)。BGP的邻居关系(或称通信对端/对等实体)是通过人工配置实现的,对等实体之间通过TCP(端口179)会话交互数据。BGP路由器会周期地发送19字节的保持存活keep-alive消息来维护连接(默认周期为30秒)。在路由协议中,只有BGP使用TCP作为传输层协议。协议作用:路由协议主要运行于路由器上,路由协议是用来确定到达路径的,它包括RIP,IGRP(Cisco私有协议),EIGRP(Cisco私有协议),OSPF,IS-IS,BGP。起到一个地图导航,负责找路的作用。它工作在网络层。路由选择协议主要是运行在路由器上的协议,主要用来进行路径选择。路由协议作为TCP/IP协议族中重要成员之一,其选路过程实现的好坏会影响整个Internet网络的效率。按应用范围的不同,路由协议分为两类:在一个AS(Autonomous System,自治系统,指一个互连网络,就是把整个Internet划分为许多较小的网络单位,这些小的网络有权自主地决定在本系统中应采用何种路由协议)内的路由协议称为内部网关协议(interior gateway protocol),AS之间的路由协议称为外部网关协议。这里网关是路由器的旧称。正在使用的内部网关路由协议有以下几种:RIP-1,RIP-2,IGRP,EIGRP,IS-IS和OSPF。其中前3种路由协议采用的是距离向量算法,IS-IS和OSPF采用的是链路状态算法,EIGRP是结合了链路状态和距离矢量型路由选择协议的Cisco私有路由协议。对于小型网络,采用基于距离向量算法的路由协议易于配置和管理,且应用较为广泛,但在面对大型网络时,不但其固有的环路问题变得更难解决,所占用的带宽也迅速增长,以至于网络无法承受。因此对于大型网络,采用链路状态算法的IS-IS和OSPF较为有效,并且得到了广泛的应用。IS-IS与OSPF在质量和性能上的差别并不大,但OSPF更适用于IP,较IS-IS更具有活力。IETF始终在致力于OSPF的改进工作,其修改节奏要比IS-IS快得多。这使得OSPF正在成为应用广泛的一种路由协议。不论是传统的路由器设计,还是即将成为标准的MPLS(多协议标记交换),均将OSPF视为必不可少的路由协议。
RIP、OSPF和IS-IS协议属于IGP,Internet协议属于BGP。1、IGP主要是内部网关协议在同一个自治系统内交换路由信息,IGP的主要目的是发现和计算自治域内的路由信息。2、Internet工程任务组制定的加强的、完善的、可伸缩的协议。BGP4支持CIDR寻址方案,该方案增加了Internet上的可用IP地址数量。为取代最初的外部网关协议EGP设计的。它也被认为是路径矢量协议。协议原理路由协议通过在路由器之间共享路由信息来支持可路由协议。路由信息在相邻路由器之间传递,确保所有路由器知道到其它路由器的路径。总之路由协议创建了路由表,描述了网络拓扑结构,路由协议与路由器协同工作,执行路由选择和数据包转发功能。路由协议主要运行于路由器上,路由协议是用来确定到达路径的,它包括RIP,IGRP(Cisco私有协议),EIGRP(Cisco私有协议),OSPF,IS-IS,BGP。起到一个地图导航,负责找路的作用。它工作在网络层。以上内容参考:百度百科——路由协议

本文由 在线网速测试 整理编辑,转载请注明出处。