三种通信协议(三种通信协议类)

      最后更新:2023-08-04 21:32

      常用的通信协议是那几种

      是常用的 还有IPX SPX TCP IP VISTA常用的三个网络协议网络中不同的工作站,服务器之间能传输数据,源于协议的存在。随着网络的发展,不同的开发商开发了不同的通信方式。为了使通信成功可靠,网络中的所有主机都必须使用同一语言,不能带有方言。因而必须开发严格的标准定义主机之间的每个包中每个字中的每一位。这些标准来自于多个组织的努力,约定好通用的通信方式,即协议。这些都使通信更容易。已经开发了许多协议,但是只有少数被保留了下来。那些协议的淘汰有多中原因---设计不好、实现不好或缺乏支持。而那些保留下来的协议经历了时间的考验并成为有效的通信方法。当今局域网中最常见的三个协议是MICROSOFT的NETBEUI、NOVELL的IPX/SPX和交叉平台TCP/IP。一:NETBEUINETBEUI是为IBM开发的非路由协议,用于携带NETBIOS通信。NETBEUI缺乏路由和网络层寻址功能,既是其最大的优点,也是其最大的缺点。因为它不需要附加的网络地址和网络层头尾,所以很快并很有效且适用于只有单个网络或整个环境都桥接起来的小工作组环境。因为不支持路由,所以NETBEUI永远不会成为企业网络的主要协议。NETBEUI帧中唯一的地址是数据链路层媒体访问控制(MAC)地址,该地址标识了网卡但没有标识网络。路由器靠网络地址将帧转发到最终目的地,而NETBEUI帧完全缺乏该信息。网桥负责按照数据链路层地址在网络之间转发通信,但是有很多缺点。因为所有的广播通信都必须转发到每个网络中,所以网桥的扩展性不好。NETBEUI特别包括了广播通信的记数并依赖它解决命名冲突。一般而言,桥接NETBEUI网络很少超过100台主机。近年来依赖于第二层交换器的网络变得更为普遍。完全的转换环境降低了网络的利用率,尽管广播仍然转发到网络中的每台主机。事实上,联合使用100-BASE-T Ethernet,允许转换NetBIOS网络扩展到350台主机,才能避免广播通信成为严重的问题。二:IPX/SPXIPX是NOVELL用于NETWARE客户端/服务器的协议群组,避免了NETBEUI的弱点。但是,带来了新的不同弱点。IPX具有完全的路由能力,可用于大型企业网。它包括32位网络地址,在单个环境中允许有许多路由网络。IPX的可扩展性受到其高层广播通信和高开销的限制。服务广告协议(Service Advertising Protocol,SAP)将路由网络中的主机数限制为几千。尽管SAP的局限性已经被智能路由器和服务器配置所克服,但是,大规模IPX网络的管理员仍是非常困难的工作。三:TCP/IP每种网络协议都有自己的优点,但是只有TCP/IP允许与Internet完全的连接。TCP/IP是在60年代由麻省理工学院和一些商业组织为美国国防部开发的,即便遭到核攻击而破坏了大部分网络,TCP/IP仍然能够维持有效的通信。ARPANET就是由基于协议开发的,并发展成为作为科学家和工程师交流媒体的Internet。TCP/IP同时具备了可扩展性和可靠性的需求。不幸的是牺牲了速度和效率(可是:TCP/IP的开发受到了政府的资助)。Internet公用化以后,人们开始发现全球网的强大功能。Internet的普遍性是TCP/IP至今仍然使用的原因。常常在没有意识到的情况下,用户就在自己的PC上安装了TCP/IP栈,从而使该网络协议在全球应用最广。TCP/IP的32位寻址功能方案不足以支持即将加入Internet的主机和网络数。因而可能 代替当前实现的标准是IPv6。
      常用的通信协议是那几种

      网络协议有哪些?

      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议。 TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层, 几个常用协议如下:1、Telnet(Remote Login):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(File Transfer Protocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(Simple Mail transfer Protocol):简单邮政传输协议,用于传输电子邮件。4、NFS(Network File Server):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(User Datagram Protocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。HTTP协议简介HTTP是一个属于应用层的面向对象的协议,由于其简捷、快速的方式,适用于分布式超媒体信息系统。它于1990年提出,经过几年的使用与发展,得到不断地完善和扩展。目前在WWW中使用的是HTTP/1.0的第六版,HTTP/1.1的规范化工作正在进行之中,而且HTTP-NG(Next Generation of HTTP)的建议已经提出。HTTP协议的主要特点可概括如下:1.支持客户/服务器模式。2.简单快速:客户向服务器请求服务时,只需传送请求方法和路径。请求方法常用的有GET、HEAD、POST。每种方法规定了客户与服务器联系的类型不同。由于HTTP协议简单,使得HTTP服务器的程序规模小,因而通信速度很快。3.灵活:HTTP允许传输任意类型的数据对象。正在传输的类型由Content-Type加以标记。4.无连接:无连接的含义是限制每次连接只处理一个请求。服务器处理完客户的请求,并收到客户的应答后,即断开连接。采用这种方式可以节省传输时间。 5.无状态:HTTP协议是无状态协议。无状态是指协议对于事务处理没有记忆能力。缺少状态意味着如果后续处理需要前面的信息,则它必须重传,这样可能导致每次连接传送的数据量增大。另一方面,在服务器不需要先前信息时它的应答就较快。
      常用的协议有TCP/IP协议、NetBEUI协议和IPX/SPX协议。TCP/IP协议作为互联网的基础协议毫无疑问是这三大协议中最重要的一个,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层, 几个常用协议如下:1、Telnet(Remote Login):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(File Transfer Protocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(Simple Mail transfer Protocol):简单邮政传输协议,用于传输电子邮件。4、NFS(Network File Server):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(User Datagram Protocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。
      介绍IT互联网基础知识TCP/IP四层协议模型

      网络协议有哪些?

      HART modbus profibus 这三种协议有什么区别?这几种协议都是干什么用的?

      这是三种不同的通信协议。HART是结合模拟与数据信号的混合协议来表现控制系统的信息。通过使用HART,传统的4-20 mA(模拟)信号被用来代表过程变量或控制输出信号。次要的变量,设备状态和设备配置数据都在该4-20 mA信号上通过使用HART数据协议得以传输。modbus和profibus 都是应用是工业现场的总线协议,主站控制系统合现场设备用的都比较多, HART在过程控制中用的比较多,比如一些流量计,变送器,传感器等,要把它们的数据采集到主控系统中就需要用的一些转换产品。比如上位机是modbus协议的DCS或者PLC之类,就要用到HART转modbus的网关模块转换协议采集数据,上海泗博自动化有一款是可以满足这个需求的 型号是 HTM-611 ,当需要连接profibus主站的时候,就要用到另一个转换模块。HPM-610 上海泗博HART转modbus 和 HART转profibus网关,都可以连接多个HART,将多台HART仪表的数据集中采集上传的上位机。一、本质类别不同:1、HART是结合模拟与数据信号的混合协议来表现控制系统的信息。通过使用HART,传统的4-20 mA(模拟)信号被用来代表过程变量或控制输出信号,HART不是真正的现场总线。2、Modbus 是一个请求/应答协议。3、PROFIBUS是一个用在自动化技术的现场总线标准。二、用法不同:1、HART次要的变量,设备状态和设备配置数据都在该4-20 mA信号上通过使用HART数据协议得以传输。2、若上位机是modbus协议的DCS或者PLC之类,就要用到HART转modbus的网关模块转换协议采集数据。3、modbus更多的具有开放式。三、传输方式不同:1、HART通信采用的是半双工的通信方式,属于模拟系统向数字系统转变过程中过渡性产品,因而在当前的过渡时期具有较强的市场竞争能力,得到了较快发展。2、PROFIBUS依据EIA-485规范的电气传输方式会使用阻抗150欧姆的双绞线,比特率范围可以从9.6 kbit/s到12 Mbit/s。两台中继器之间的网络线长也有限制,随比特率的不同,上限从100米到1200米。这种传输方式主要配合PROFIBUS DP使用。3、Modbus已经成为工业领域通信协议的业界标准(De facto),并且现在是工业电子设备之间常用的连接方式。PROFIBUS是一个用在自动化技术的现场总线标准。HART在过程控制中用的比较多,比如一些流量计,变送器,传感器等,要把它们的数据采集到主控系统中就需要用的一些转换产品。若上位机是modbus协议的DCS或者PLC之类,就要用到HART转modbus的网关模块转换协议采集数据,上海泗博自动化有一款是可以满足这个需求的 型号是 HTM-611,当需要连接profibus主站的时候,就要用到另一个转换模块, HPM-610。支持1个HART通道,多点模式下使用网关内置电阻支持连接13台仪表,使用外部电阻(250Ω)支持连接15台仪表。HART侧可配置为第一主站或第二主站,支持突发模式,支持长短帧格式,支持所有HART命令,HART输入数据缓冲区达1600byte,输出数据缓冲区达1000byte,每通道最多可配置128条命令。modbus和profibus 都是应用是工业现场的总线协议,主站控制系统合现场设备用的都比较多。后来在1993年提出了架构较简单,速度也提升许多的PROFIBUS DP(DP代表Decentralized Peripherals)。PROFIBUS FMS是用在PROFIBUS主站之间的非确定性通信。PROFIBUS DP主要是用在PROFIBUS主站和其远程从站之间的确定性通信,但仍允许主站及主站之间的通信。扩展资料:PROFIBUS的历史可追溯到1987年联邦德国开始的一个合作计划,此计划有十四家公司及五个研究机构参与,目标是要推动一种串列现场总线,可满足现场设备接口的基本需求。为了这个目的,参与的成员同意支持有关工厂生产及程序自动化的共通技术研究。PROFIBUS中最早提出的是PROFIBUS FMS(FMS代表Field bus Message Specification),是一个复杂的通信协议,为要求严苛的通信任务所设计,适用在车间级通用性通信任务。后来在1993年提出了架构较简单,速度也提升许多的PROFIBUS DP(DP代表Decentralized Peripherals)。PROFIBUS FMS是用在PROFIBUS主站之间的非确定性通信。PROFIBUS DP主要是用在PROFIBUS主站和其远程从站之间的确定性通信,但仍允许主站及主站之间的通信。Modbus协议目前存在用于串口、以太网以及其他支持互联网协议的网络的版本。大多数Modbus设备通信通过串口EIA-485物理层进行。对于串行连接,存在两个变种,它们在数值数据表示不同和协议细节上略有不同。Modbus RTU是一种紧凑的,采用二进制表示数据的方式,Modbus ASCII是一种人类可读的,冗长的表示方式。这两个变种都使用串行通信(serial communication)方式。RTU格式后续的命令/数据带有循环冗余校验的校验和,而ASCII格式采用纵向冗余校验的校验和。被配置为RTU变种的节点不会和设置为ASCII变种的节点通信,反之亦然。对于通过TCP/IP(例如以太网)的连接,存在多个Modbus/TCP变种,这种方式不需要校验和计算。对于所有的这三种通信协议在数据模型和功能调用上都是相同的,只有封装方式是不同的。Modbus有一个扩展版本Modbus Plus(Modbus+或者MB+),不过此协议是Modicon专有的,和Modbus不同。它需要一个专门的协处理器来处理类似HDLC的高速令牌旋转。它使用1Mbit/s的双绞线,并且每个节点都有转换隔离装置,是一种采用转换/边缘触发而不是电压/水平触发的装置。连接Modbus Plus到计算机需要特别的接口,通常是支持ISA(SA85),PCI或者PCMCIA总线的板卡。HART(Highway Addressable Remote Transducer),可寻址远程传感器高速通道的开放通信协议,是美国ROSEMOUNT公司于1985年推出的一种用于现场智能仪表和控制室设备之间的通信协议。HART装置提供具有相对低的带宽,适度响应时间的通信,经过10多年的发展,HART技术在国外已经十分成熟,并已成为全球智能仪表的工业标准。参考资料来源:百度百科-PROFIBUS百度百科-Modbus通讯协议百度百科-HART协议
      一、定义及作用:1、HART(Highway Addressable Remote Transducer),可寻址远程传感器高速通道的开放通信协议,是美国ROSEMOUNT公司于1985年推出的一种用于现场智能仪表和控制室设备之间的通信协议。2、PROFIBUS是一个用在自动化技术的现场总线标准,在1987年由德国西门子公司等十四家公司及五个研究机构所推动,PROFIBUS是程序总线网络(PROcess FIeld BUS)的简称。PROFIBUS和用在工业以太网的PROFINET是二种不同的通信协议。3、Modbus 协议是应用于电子控制器上的一种通用语言。通过此协议,控制器相互之间、控制器经由网络(例如以太网)和其它设备之间可以通信。二、应用场景:odbus和profibus 都是应用是工业现场的总线协议,主站控制系统合现场设备用的都比较多。HART在过程控制中用的比较多,比如一些流量计,变送器,传感器等,要把它们的数据采集到主控系统中就需要用的一些转换产品。三、传输方式不同;1、HART通信采用的是半双工的通信方式,属于模拟系统向数字系统转变过程中过渡性产品。2、PROFIBUS依据EIA-485规范的电气传输方式会使用阻抗150欧姆的双绞线,比特率范围可以从9.6 kbit/s到12 Mbit/s。3、Modbus已经成为工业领域通信协议的业界标准(De facto),并且现在是工业电子设备之间常用的连接方式。扩展资料:PROFIBUS协议及其网络组成:1、Profibus协议的三个主要部分:Profibus  DP(Distributed I/Os):在主站和从站之间采用轮循的通讯方式,主要应用于制造业自动化系统中单元级和现场级通信。PROFIBUS  PA(Process Automation):电源和通信数据通过总线并行传输,主要用于面向过程自动化系统中单元级和现场级通讯。PROFIBUS  FMS(Fieldbus Message Specification):定义主站和主站之间的通讯模型,主要用于自动化系统中系统级和车间级的过程数据交换。2、Profibus网络由主站,从站,网络部件等构成:主站也被称做主动节点。包括SIMATIC PLC,SIMATICWinAC控制器,支持主站功能的通讯处理器,IE/PB链路模块以及ET200S/ET200X的主站模块典型的从站为传感器,执行器以及变频器。从站不会拥有总线访问的授权。Profibus的传输速度为9.6/19.2/93.75/187.5/500/1500Kbit/s以及3/6/12Mbit/s。最大节点数127(地址0-126)。参考资料来源一:百度百科——HART协议参考资料来源二:百度百科——MODBUS协议参考资料来源三:百度百科--PROFIBUS
      一、本质类别不同:1、HART是结合模拟与数据信号的混合协议来表现控制系统的信息。通过使用HART,传统的4-20 mA(模拟)信号被用来代表过程变量或控制输出信号,HART不是真正的现场总线。2、Modbus 是一个请求/应答协议。3、PROFIBUS是一个用在自动化技术的现场总线标准。二、用法不同:1、HART次要的变量,设备状态和设备配置数据都在该4-20 mA信号上通过使用HART数据协议得以传输。2、若上位机是modbus协议的DCS或者PLC之类,就要用到HART转modbus的网关模块转换协议采集数据3、modbus更多的具有开放式;三、传输方式不同;1、HART通信采用的是半双工的通信方式,属于模拟系统向数字系统转变过程中过渡性产品,因而在当前的过渡时期具有较强的市场竞争能力,得到了较快发展。2、PROFIBUS依据EIA-485规范的电气传输方式会使用阻抗150欧姆的双绞线,比特率范围可以从9.6 kbit/s到12 Mbit/s。两台中继器之间的网络线长也有限制,随比特率的不同,上限从100米到1200米。这种传输方式主要配合PROFIBUS DP使用。3、Modbus已经成为工业领域通信协议的业界标准(De facto),并且现在是工业电子设备之间常用的连接方式。PROFIBUS是一个用在自动化技术的现场总线标准。HART在过程控制中用的比较多,比如一些流量计,变送器,传感器等,要把它们的数据采集到主控系统中就需要用的一些转换产品。若上位机是modbus协议的DCS或者PLC之类,就要用到HART转modbus的网关模块转换协议采集数据,上海泗博自动化有一款是可以满足这个需求的 型号是 HTM-611,当需要连接profibus主站的时候,就要用到另一个转换模块, HPM-610。支持1个HART通道,多点模式下使用网关内置电阻支持连接13台仪表,使用外部电阻(250Ω)支持连接15台仪表。HART侧可配置为第一主站或第二主站,支持突发模式,支持长短帧格式,支持所有HART命令;HART输入数据缓冲区达1600byte,输出数据缓冲区达1000byte,每通道最多可配置128条命令。modbus和profibus 都是应用是工业现场的总线协议,主站控制系统合现场设备用的都比较多。后来在1993年提出了架构较简单,速度也提升许多的PROFIBUS DP(DP代表Decentralized Peripherals)。PROFIBUS FMS是用在PROFIBUS主站之间的非确定性通信。PROFIBUS DP主要是用在PROFIBUS主站和其远程从站之间的确定性通信,但仍允许主站及主站之间的通信。扩展资料:HART,可寻址远程传感器高速通道的开放通信协议,是美国ROSEMOUNT公司于1985年推出的一种用于现场智能仪表和控制室设备之间的通信协议。HART装置提供具有相对低的带宽,适度响应时间的通信,经过10多年的发展,HART技术在国外已经十分成熟,并已成为全球智能仪表的工业标准。Modbus 协议是应用于电子控制器上的一种通用语言。通过此协议,控制器相互之间、控制器经由网络(例如以太网)和其它设备之间可以通信。Modbus 协议定义了一个控制器能认识使用的消息结构,而不管它们是经过何种网络进行通信的。它描述了一控制器请求访问其它设备的过程,如何回应来自其它设备的请求,以及怎样侦测错误并记录。它制定了消息域格局和内容的公共格式。PROFIBUS的历史可追溯到1987年联邦德国开始的一个合作计划,此计划有十四家公司及五个研究机构参与,目标是要推动一种串列现场总线,可满足现场设备接口的基本需求。PROFIBUS中最早提出的是PROFIBUS FMS(FMS代表Field bus Message Specification),是一个复杂的通信协议,为要求严苛的通信任务所设计,适用在车间级通用性通信任务。参考资料来源:百度百科——HART协议参考资料来源:百度百科——MODBUS协议参考资料来源:百度百科——PROFIBUS
      这是三种不同的通信协议, HART不是真正的现场总线,HART是结合模拟与数据信号的混合协议来表现控制系统的信息。通过使用HART,传统的4-20 mA(模拟)信号被用来代表过程变量或控制输出信号。次要的变量,设备状态和设备配置数据都在该4-20 mA信号上通过使用HART数据协议得以传输。modbus和profibus 都是应用是工业现场的总线协议,主站控制系统合现场设备用的都比较多,HART在过程控制中用的比较多,比如一些流量计,变送器,传感器等,要把它们的数据采集到主控系统中就需要用的一些转换产品。比如上位机是modbus协议的DCS或者PLC之类,就要用到HART转modbus的网关模块转换协议采集数据,上海泗博自动化有一款是可以满足这个需求的 型号是 HTM-611 ,当需要连接profibus主站的时候,就要用到另一个转换模块, HPM-610上海泗博HART转modbus 和 HART转profibus网关,都可以连接多个HART,将多台HART仪表的数据集中采集上传的上位机,以下是上海泗博HART/modbus网关HTM-611,HART/profibus网关HPM-610 产品信息:支持1个HART通道,多点模式下使用网关内置电阻支持连接13台仪表,使用外部电阻(250Ω)支持连接15台仪表;HART侧可配置为第一主站或第二主站,支持突发模式,支持长短帧格式,支持所有HART命令;HART输入数据缓冲区达1600byte,输出数据缓冲区达1000byte,每通道最多可配置128条命令,每条命令可配置为4种输出方式:轮询输出、逢变输出、初始化输出、不输出;HART输入数据缓冲区达1600byte,输出数据缓冲区达1000byte,每通道最多可配置128条命令,每条命令可配置为4种输出方式:轮询输出、逢变输出、初始化输出、不输出;可选择使用内部或外部采样电阻;串口侧可配置为Modbus从站或通用模式,接口是RS232、RS485、RS422可选,波特率:300、600、1200、2400、9600、19.2K、38.4K、57.6K、115.2Kbps可选支持Profibus-DP从站,波特率自适应,最大波特率12M;支持Profibus-DP输入数据多误清零或者保持功能;防护等级:IP20;;通过配合配置软件HT-123可实现HART命令的监控和调试等功能; Modbus支持RTU模式和ASCII模式;
      只知道两者都是通讯协议,用来规定数据传输的方式。 ModbusModbus协议最初由Modicon公司开发出来,在1979年末该公司成为施耐德自动化(Schneider Automation)部门的一部分,现在Modbus已经是工业领域全球最流行的协议。此协议支持传统的RS-232、RS-422、RS-485和以太网设备。许多工业设备,包括PLC,DCS,智能仪表等都在使用Modbus协议作为他们之间的通讯标准。不同的接口有不同的速率。PROFIBUSPROFIBUS协议及其网络组成1、Profibus协议的三个主要部分:ProfibusDP(Distributed I/Os):在主站和从站之间采用轮循的通讯方式,主要应用于制造业自动化系统中单元级和现场级通信。PROFIBUSPA(Process Automation):电源和通信数据通过总线并行传输,主要用于面向过程自动化系统中单元级和现场级通讯。PROFIBUSFMS(Fieldbus Message Specification):定义主站和主站之间的通讯模型,主要用于自动化系统中系统级和车间级的过程数据交换。2、Profibus网络由主站,从站,网络部件等构成:主站也被称做主动节点。包括SIMATIC PLC,SIMATICWinAC控制器,支持主站功能的通讯处理器,IE/PB链路模块以及ET200S/ET200X的主站模块典型的从站为传感器,执行器以及变频器。从站不会拥有总线访问的授权。Profibus的传输速度为9.6/19.2/93.75/187.5/500/1500Kbit/s以及3/6/12Mbit/s。最大节点数127(地址0-126)。Profibus的传输速度为9.6/19.2/93.75/187.5/500/1500Kbit/s以及3/6/12Mbit/s。但是不同的通讯速率,它传输距离不一样,速率越高,传输的距离越短;modbus通讯协议RS-422、RS-485传输距离理论为1200米modbus通讯协议RS-232传输距离理论为12米 ,如果觉得有帮助的话就给点分吧。
      HART modbus profibus 这三种协议有什么区别?这几种协议都是干什么用的?

      计算机网络协议有哪些

      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议。TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层,几个常用协议如下:1、Telnet(RemoteLogin):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(FileTransferProtocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(SimpleMailtransferProtocol):简单邮政传输协议,用于传输电子邮件。4、NFS(NetworkFileServer):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(UserDatagramProtocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。HTTP协议简介HTTP是一个属于应用层的面向对象的协议,由于其简捷、快速的方式,适用于分布式超媒体信息系统。它于1990年提出,经过几年的使用与发展,得到不断地完善和扩展。目前在WWW中使用的是HTTP/1.0的第六版,HTTP/1.1的规范化工作正在进行之中,而且HTTP-NG(NextGenerationofHTTP)的建议已经提出。HTTP协议的主要特点可概括如下:1.支持客户/服务器模式。2.简单快速:客户向服务器请求服务时,只需传送请求方法和路径。请求方法常用的有GET、HEAD、POST。每种方法规定了客户与服务器联系的类型不同。由于HTTP协议简单,使得HTTP服务器的程序规模小,因而通信速度很快。3.灵活:HTTP允许传输任意类型的数据对象。正在传输的类型由Content-Type加以标记。4.无连接:无连接的含义是限制每次连接只处理一个请求。服务器处理完客户的请求,并收到客户的应答后,即断开连接。采用这种方式可以节省传输时间。 5.无状态:HTTP协议是无状态协议。无状态是指协议对于事务处理没有记忆能力。缺少状态意味着如果后续处理需要前面的信息,则它必须重传,这样可能导致每次连接传送的数据量增大。另一方面,在服务器不需要先前信息时它的应答就较快。
      应用层 ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   · RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
      应用层 ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   · RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
      ·DHCP(动态主机分配协议) · DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议
      TCOP/IP DNSDHCPTELNETHTTPSMTPTFTPSNMPTCPUDPIPARPRAPPICMPIGMPPPP X.25
      计算机网络协议有哪些

      局域网中以太网采用的通信协议是什么?

      局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议
      局域网中以太网采用的通信协议是什么?

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类