计算机网络各种协议汇总(计算机网络中的协议)

      最后更新:2023-08-09 21:32

      计算机协议有哪些

      1、物理层:以太网 · 调制解调器 · 电力线通信(PLC) · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线等。2、数据链路层:Wi-Fi(IEEE 802.11) · WiMAX(IEEE 802.16) ·ATM · DTM · 令牌环 · 以太网 ·FDDI · 帧中继 · GPRS · EVDO ·HSPA · HDLC · PPP · L2TP ·PPTP · ISDN·STP · CSMA/CD等。3、网络层协议:IP (IPv4 · IPv6) · ICMP· ICMPv6·IGMP ·IS-IS · IPsec · ARP · RARP · RIP等。4、传输层协议:TCP · UDP · TLS · DCCP · SCTP · RSVP · OSPF 等。5、应用层协议:DHCP ·DNS · FTP · Gopher · HTTP· IMAP4 · IRC · NNTP · XMPP ·POP3 · SIP · SMTP ·SNMP · SSH ·TELNET · RPC · RTCP · RTP ·RTSP· SDP · SOAP · GTP · STUN · NTP· SSDP · BGP 等。参考资料来源:百度百科-网络协议
      目前网络协议有许多种,但是最基本的协议是TCP/IP协议,许多协议都是它的子协议。下面我们就对TCP/IP协议作一下简单介绍。 1TCP/IP协议基础TCP/IP协议包括两个子协议:一个是TCP协议(Transmission Control Protocol,传输控制协议),另一个是IP协议(Internet Protocol,互联网协议),它起源于20世纪60年代末。在TCP/IP协议中,TCP协议和IP协议各有分工。TCP协议是IP协议的高层协议,TCP在IP之上提供了一个可靠的,连接方式的协议。TCP协议能保证数据包的传输以及正确的传输顺序,并且它可以确认包头和包内数据的准确性。如果在传输期间出现丢包或错包的情况,TCP负责重新传输出错的包,这样的可靠性使得TCP/IP协议在会话式传输中得到充分应用。IP协议为TCP/IP协议集中的其它所有协议提供“包传输”功能,IP协议为计算机上的数据提供一个最有效的无连接传输系统,也就是说IP包不能保证到达目的地,接收方也不能保证按顺序收到IP包,它仅能确认IP包头的完整性。最终确认包是否到达目的地,还要依靠TCP协议,因为TCP协议是有连接服务。在计算机服务中如果按连接方式来分的话,可分为“有连接服务”和“无连接服务”两种。“有连接服务”必须先建立连接才能提供相应服务,而“无连接服务”则不需先建立连接。TCP协议是一种典型的有连接协议,而UDP协议则是典型的无连接服务。TCP/IP协议所包括的协议和工具 TCP/IP协议是一组网络协议的集合,它主要包括以下几方面的协议和工具。
      目前网络协议有许多种,但是最基本的协议是TCP/IP协议,许多协议都是它的子协议。下面我们就对TCP/IP协议作一下简单介绍。 1TCP/IP协议基础TCP/IP协议包括两个子协议:一个是TCP协议(Transmission Control Protocol,传输控制协议),另一个是IP协议(Internet Protocol,互联网协议),它起源于20世纪60年代末。在TCP/IP协议中,TCP协议和IP协议各有分工。TCP协议是IP协议的高层协议,TCP在IP之上提供了一个可靠的,连接方式的协议。TCP协议能保证数据包的传输以及正确的传输顺序,并且它可以确认包头和包内数据的准确性。如果在传输期间出现丢包或错包的情况,TCP负责重新传输出错的包,这样的可靠性使得TCP/IP协议在会话式传输中得到充分应用。IP协议为TCP/IP协议集中的其它所有协议提供“包传输”功能,IP协议为计算机上的数据提供一个最有效的无连接传输系统,也就是说IP包不能保证到达目的地,接收方也不能保证按顺序收到IP包,它仅能确认IP包头的完整性。最终确认包是否到达目的地,还要依靠TCP协议,因为TCP协议是有连接服务。在计算机服务中如果按连接方式来分的话,可分为“有连接服务”和“无连接服务”两种。“有连接服务”必须先建立连接才能提供相应服务,而“无连接服务”则不需先建立连接。TCP协议是一种典型的有连接协议,而UDP协议则是典型的无连接服务。TCP/IP协议所包括的协议和工具TCP/IP协议是一组网络协议的集合,它主要包括以下几方面的协议和工具。·TCP/IP协议核心协议这些核心协议除了自身外,还包括用户数据报协议(UDP协议)、地址代理协议(ARP协议)以及网间控制协议(ICMP协议)。这组协议提供了一系列计算机互连和网络互连的标准协议。·应用接口协议这类协议主要包括Windows套接字(Socket,用于开发网络应用程序)、远程调用、NetBIOS协议(用于建立逻辑名和网络上的会话)和网络动态数据交换(Network,用于通过网络共享嵌入在文本中的信息)。·基本的TCP/IP协议互连应用协议主要包括finger、ftp、rep、rsh、telnet、tftp等协议。这些工具协议使得Windows系统用户使用非Microsoft系统计算机上(如UNIX系统计算机)的资源成为可能。·TCP/IP协议诊断工具这些工具包括arp、hostname、ipconfig、nbstat、netstat、ping和route,它们可用来检测并恢复TCP/IP协议网络故障。·有关服务和管理工具这些服务和管理工具包括FTP服务器服务(用于在两个远程计算机之间传输文件,这是远程控制通信中的关键功能)、网际命名服务WINS(用于在一个网际上动态记录和询问计算机的名字)、动态计算机配置协议DHCP(用于在Windows NT计算机上自动配置TCP/IP协议)以及TCP/IP协议打印(主要用于远程打印和网络打印)。·简单网络管理协议代理(SNMP)这个工具允许通过使用管理工具(如“Sun Net Manages” 或“HP Open View”),从远程管理Windows NT计算机。(2)TCP/IP的主要协议简述为了使读者能全面了解一些基本的网络通信协议和服务,本节就对TCP/IP协议所包括的几种主要协议进行简要说明。·远程登录协议(Telnet)Telnet协议是用来登录到远程计算机上,并进行信息访问,通过它可以访问所有的数据库、联机游戏、对话服务以及电子公告牌,如同与被访问的计算机在同一房间中工作一样,但只能进行些字符类操作和会话。·文件传输协议(Ftp)这是文件传输的基本协议,有了FTP协议就可以把的文件进行上传,也可从网上得到许多应用程序和信息(下载),有许多软件站点就是通过FTP协议来为用户提供下载任务的,俗称“FTP服务器”。最初的FTP程序是工作在UNIX系统下的,而目前的许多FTP程序是工作在Windows系统下的。FTP程序除了完成文件的传送之外,还允许用户建立与远程计算机的连接,登录到远程计算机上,并可在远程计算机上的目录间移动。·电子邮件服务(Email)电子邮件服务是目前最常见、应用最广泛的一种到联网服务。通过电子邮件,可以与Internet上的任何人交换信息。电子邮件的快速、高效、方便以及价廉,越来越得到了广泛的应用,目前只要是上过网的网民就肯定用过电子邮件这种服务。目前,全球平均每天约有几千万份电子邮件在网上传输。·WWW服务WWW服务(3W服务)也是目前应用最广的一种基本互联网应用,我们每天上网都要用到这种服务。通过WWW服务,只要用鼠标进行本地操作,就可以到达世界上的任何地方。由于WWW服务使用的是超文本链接(HTML),所以可以很方便的从一个信息页转换到另一个信息页。它不仅能查看文字,还可以欣赏图片、音乐、动画。最流行的WWW服务的程序就是微软的IE浏览器。·简单邮件传输协议(SMTP)SMTP是TCP/IP协议族的一个成员,这种协议认为你的计算机是永久连接在Internet上的,而且认为你在网络上的计算机在任何时候是可以被访问的。它适用于永久连接在Internet的计算机,但无法使用通过SLIP/PPP协议连接的用户接收电子邮件。解决这个问题的办法是在邮件计算机上同时运行SMTP和POP协议的程序,SMTP负责邮件的发送和在邮件计算机上的分拣和存储,POP协议负责将邮件通过SLIP/PPP协议连接传送到用户计算机上。·信息服务(Gopher)Gopher最早出现在1991年,它是第一个操作简便、使用广泛的从Internet服务器上获取信息的客户应用程序。除了操作简便外,它的另一个特点是速度快。Gopher运行时,将显示一个交互式的供用户选择的菜单,菜单中的选项由简单的短句组成,每个短句通常指向另一个菜单,并最终指向有用的文件。Gopher是帮助用户在Internet信息海洋中搜索有用信息的导航器。用户只要关心浏览的内容,而不必关心具体的服务器。·文件检索服务(Archie)它是一个从整个Internet上匿名FTP服务器获取文件的服务。其完全依赖于匿名FTP系统的管理员,他们将站点在全世界的Archie服务器进行了注册,Archie仅通过文件名进行检索。2 IP协议目前正在使用的IP协议是第4版的,称之为“IPv4”,新版本的IP协议正在完善过程中,它就是经常可以在各大IT媒体中见到的IPv6。IPv6所要解决的主要是IPv4协议中IP地址远远不够的现象。IPv4所采用的是32位,而IPv6则是128位,是原来的4倍。IPv6所提供的IP地址数已可算是天文数字了,据专家们分析,这个数字的IP地址可以使全球的每一个人都可拥有10以上的IP地址,这么多的IP地址相信再也不会出现IPv4那样除了美国外,各国都出现IP地址短缺现象,为将来实现移动上网打下了坚实的基础。但这属于较新技术,在此就不作详细介绍,本文仍以目前主流的IPv4协议为基础进行介绍。IP协议的功能是把数据报在互联的网络上传送,通过将数据报在一个个IP协议模块间传送,直到目的模块。网络中每个计算机和网关上都有IP协议模块。数据报在一个个模块间通过路由处理网络地址传送到目的地址,因此搜寻网络地址对于IP协议十分重要的功能。另外,因为各个网络上的数据报大小可能不同,所以数据报的分段也是IP协议的不可或缺的功能,不然对于一些网络带宽较窄的网络,大的数据报就无法正确传输了。下面主要介绍我们初级学者所关心的现行方面问题。(1)IP地址在计算机寻址中经常会遇到“名字”、“地址”和“路由”这三个术语,它们之间是有较大区别的。名字是要找的,就像的人名一样;而地址是用来指出这个名字在什么地方,就像人的住址一样;路由是解决如何到达目的地址的问题,就像已经知道了某个人住在什么地方,现在要考虑走什么路线、采用什么交通工具到达目的地方最为简便。这里所介绍的IP协议主要是解决地址的问题。名字和地址进行解析的工作是由其上层协议--TCP协议完成。IP协议模块将地址和本地网络地址加以映射(就像写信一样,IP协议只负责把收、发信人的地址写上,把信投进邮箱就可不管了),而将本地网络地址和路由进行映射则是低层协议(如路由协议)的任务,所以说IP协议是一个无连接的服务。IP协议要寻找的“地址”是32位长(4个分段的16进制组成),由网络号(网络ID)和主机号(主机ID)两部分构成,按照IP协议规定因特网上的地址共有A、B、C、D、E五类.按照IP协议规定因特网上的地址共有A、B、C、D、E五类·A类IP地址:用前面8位来标识网络号,其中规定最前面一位为“0”,24位标识主机地址,即A类地址的第一段取值(也即网络号)可以是“00000001 ̄01111111”之间任一数字,转换为十进制后即为1~128之间。主机号没有做硬性规定,所以它的IP地址范围为“1.0.0.0-128.255.255.255”。A类地址是为大型政府网络而提供,因为A地址中有10.0.0.0-10.255.255.254和127.0.0.0-127.255.255.254这两段地址有专门用途,所以全世界总共只有126个可能的A类网络。每个A类网络最多可以连接16777214台计算机,这类地址数是最少的,但这类网络所允许连接的计算机是最多的。·B类IP地址:用前面16位来标识网络号,其中最前面两位规定为“10”,16位标识主机号,也就是说B类地址的第一段“10000000 ̄10111111”,转换成十进制后即为128~191之间,第一段和第二段合在一起表示网络地址,它的地址范围为“128.0.0.0-191.255.255.255”。B类地址适用于中等规模的网络,全世界大约有16000个B类网络,每个B类网络最多可以连接65534台计算机。这类IP地址通常为中等规模的网络提供。其中172.16.0.0-172.31.255.254地址段有专门用途。·C类IP地址:用前面24位来标识网络号,其中最前面三位规定为“110”,8位标识主机号。这样C类地址的第一段取值为“11000000 ̄11011111”之间,转换成十进制后即为192~223。第一段、第二段、第三段合在一起表示网络号,最后一段标识网络上的主机号,它的地址范围为“192.0.0.0-223.255.255.255”。C类地址适用于校园网等小型网络,每个C类网络最多可以有254台计算机。这类地址是所有的地址类型中地址数最多的,但这类网络所允许连接的计算机是最少的。这类IP地址可分配给任何有需要的人。其中192.168.0.0-192.168.255.255为企业局域网专用地址段。·D类地址:它用于多重广播组,一个多重广播组可能包括1台或更多主机,或根本没有。D类地址的最高位为1110,第一段八位体为“11100000 ̄11101111”,转换成十进制即为224 ̄239,剩余的位设计客户机参加的特定组,它的地址范围为“224.0.1.1-239.255.255.255”。在多重广播操作中没有网络或主机位,数据包将传送到网络中选定的主机子集中,只有注册了多重广播地址的主机才能接收到数据包。Microsoft支持D类地址,用于应用程序将多重广播数据发送到网络间的主机上,包括WINS和Microsoft NetShow。·E类地址:这是一个通常不用的实验性地址,保留作为以后使用。E类地址的最高位为11110,第一段八位体为“11110000 ̄11110111”,转换成十进制即为240 ̄247。IPv4协议中对首段位为248 ̄254 的地址段暂无规定。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。(2) 子网掩码和域名以上介绍的是网络IP地址,但随着网络的发展,IPv4标准中的IP地址远不够用,为了解决这一矛盾,于是又在IP地址加上子网掩码来进一步识别。在TCP/IP协议中规定,A类网络的子网掩码格式为“255.0.0.0”形式,后面的“0”可以为“0 ̄254”之间任一数字。B类网络的子网掩码格式为“255.255.0.0”,C类网络的子网掩码为格式为“255.255.255.0”,同样其中的“0”可以是“0 ̄254”之间任一数字。如果没有子网,可以为“0”,也可以不配置,如果有子网则一定要配置。前面介绍的IP地址都是以数字形式表示计算机的地址,这种IP地址人们记忆起来是非常困难的。对非计算机和网络的专业人士来说,记住这种地址是很不现实的。因此,Internet还采用域名地址来表示每台计算机。通过为每台计算机建立IP地址与域名地址之间的映射关系,用户可以在网上避开难以记忆的IP地址,而用域名地址来唯一标记网上的计算机。域名地址与IP地址的关系类似于一个人的姓名与身份证号码之间的关系。要把计算机连入Internet,必须获得网上唯一的IP地址与对应的域名地址。域名地址由域名系统(DNS)管理。每个连到Internet的网络中都有至少一个DNS服务器,其中存有该网络中所有计算机的域名和对应的IP地址,通过与其他网络的DNS服务器相连就可以找到其他站点。这也是在TCP/IP协议属性中要进行DNS配置的原因。 域名地址也是分段表示的,每段分别授权给不同的机构管理,各段之间用圆点(.)分隔。与IP地址相反,各段自左至右级别是越来越高。
      “协议”简单来说就是一种规则, 网络上的计算机在相互通信的过程中必须遵守统一的规则,否则通信将无法进行,这些规则我们称之计算机协议, 例如常见的: 在网络上通信的计算必须遵守TCP/IP协议,在网络的高层应用中,网文件的传输要遵守FTP协议等。网络中的计算机协议根据其应用的类别有多种。 TCP/IP(Transmission Control Protocol/Internet Protocol)传输控制协议/互联网协议 开放系统互联协议中最早的协议之一,它为连接不同操作系统和不同硬件体系结构的互联网络提供通信支持,是一种网络通用语言。TCP/IP协议定义了在互联网络中如何传递、管理信息(文件传送、收发电子邮件、远程登录等),并制定了在出错时必须遵循的规则。 IPX/SPX(Internet Packet eXchange/Sequenced Packet eXchange)互联网信息交换包/顺序信息交换包 IPX和SPX是Novell NetWare协议栈的一部分,用于网络服务器和工作站之间传输数据;IPX和SPX两层协议造就了Novell网络的特色,几乎成了Novell网的代名词。 NetBIOS(Network Basic Input/Output System)网络基本输入/输出系统 网络会话层协议,管理数据交换和网络访问。它向API(Application Program Interface,应用程序接口)提供一组协调性命令,利用下一层网络服务将信息逐个节点地进行传送,从而把应用程序与下层的网络操作系统加以隔离。 NetBEUI(NetBIOS Extended User Interface)NetBIOS用户扩展接口 用于LAN Manager、LAN Server、Windows for Workgroups和Windows NT等的NetBIOS增强版本,它确定了传送帧格式并增加了许多功能。
      TCP/IP 协议组 IPX/SPX 协议组NetBEUICSMA/CD 等等很多
      计算机协议有哪些

      计算机网络协议有哪些

      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议。TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层,几个常用协议如下:1、Telnet(RemoteLogin):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(FileTransferProtocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(SimpleMailtransferProtocol):简单邮政传输协议,用于传输电子邮件。4、NFS(NetworkFileServer):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(UserDatagramProtocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。HTTP协议简介HTTP是一个属于应用层的面向对象的协议,由于其简捷、快速的方式,适用于分布式超媒体信息系统。它于1990年提出,经过几年的使用与发展,得到不断地完善和扩展。目前在WWW中使用的是HTTP/1.0的第六版,HTTP/1.1的规范化工作正在进行之中,而且HTTP-NG(NextGenerationofHTTP)的建议已经提出。HTTP协议的主要特点可概括如下:1.支持客户/服务器模式。2.简单快速:客户向服务器请求服务时,只需传送请求方法和路径。请求方法常用的有GET、HEAD、POST。每种方法规定了客户与服务器联系的类型不同。由于HTTP协议简单,使得HTTP服务器的程序规模小,因而通信速度很快。3.灵活:HTTP允许传输任意类型的数据对象。正在传输的类型由Content-Type加以标记。4.无连接:无连接的含义是限制每次连接只处理一个请求。服务器处理完客户的请求,并收到客户的应答后,即断开连接。采用这种方式可以节省传输时间。 5.无状态:HTTP协议是无状态协议。无状态是指协议对于事务处理没有记忆能力。缺少状态意味着如果后续处理需要前面的信息,则它必须重传,这样可能导致每次连接传送的数据量增大。另一方面,在服务器不需要先前信息时它的应答就较快。
      应用层 ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   · RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
      应用层 ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   · RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
      ·DHCP(动态主机分配协议) · DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议
      TCOP/IP DNSDHCPTELNETHTTPSMTPTFTPSNMPTCPUDPIPARPRAPPICMPIGMPPPP X.25
      计算机网络协议有哪些

      什么是网络协议?请简要说明之。请写出五种常用的网络协议。

      网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。划分1、物理层:以太网、调制解调器、电力线通信(PLC)、SONET/SDH、G.709、光导纤维、同轴电缆、双绞线等。2、数据链路层:Wi-Fi(IEEE 802.11)、WiMAX(IEEE 802.16)、ATM、DTM、令牌环、以太网、FDDI、帧中继、GPRS、EVDO、HSPA、HDLC、PPP、L2TP、PPTP、ISDN、STP、CSMA/CD等。3、网络层协议:IP (IPv4、IPv6)、ICMP、ICMPv6、IGMP、IS-IS、IPsec、ARP、RARP、RIP等。4、传输层协议:TCP、UDP、TLS、DCCP、SCTP、RSVP、OSPF等。5、应用层协议:DHCP、DNS、FTP、Gopher、HTTP、IMAP4、IRC、NNTP、XMPP、POP3、SIP、SMTP、SNMP、SSH、TELNET、RPC、RTCP、RTP、RTSP、SDP、SOAP、GTP、STUN、NTP、SSDP、BGP 等。扩展资料网络协议通常由语法,语义和定时关系3部分组成。网络传输协议或简称为传送协议(Communications Protocol),计算机通信的共同语言。最普及的计算机通信为网络通信,所以“传送协议”一般都指计算机通信的传送协议,如:TCP/IP、NetBEUI等。然而,传送协议也存在于计算机的其他形式通信,例如:面向对象编程里面对象之间的通信;操作系统内不同程序之间的消息,都需要有一个传送协议,以确保传信双方能够沟通无间。参考资料来源:百度百科-协议参考资料来源:百度百科-网络协议
      网络协议是网络上所有设备(网络服务器、计算机及交换机、路由器、防火墙等)之间通信规则的集合,它规定了通信时信息必须采用的格式和这些格式的意义。大多数网络都采用分层的体系结构,每一层都建立在它的下层之上,向它的上一层提供一定的服务,而把如何实现这一服务的细节对上一层加以屏蔽。一台设备上的第 n层与另一台设备上的第n层进行通信的规则就是第n层协议。在网络的各层中存在着许多协议,接收方和发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息。网络协议使网络上各种设备能够相互交换信息。常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议等。在局域网中用得的比较多的是IPX/SPX.。用户如果访问Internet,则必须在网络协议中添加TCP/IP协议。 http://baike.baidu.com/view/16603.html?wtp=tt 这里讲的全是网络协议

      你好 网络协议你可以理解成网络规矩所有的设备厂商都遵守这个规矩那么数据就能通信了最常见的比如IPtcpudpicmpipv6ospfrip谢谢 如能帮到你请采纳!
      什么是网络协议?请简要说明之。请写出五种常用的网络协议。

      计算机网络中的协议有哪些

      常用的网络协议有: IP/IPv4:网际协议TCP:传输控制协议IGMP:Internet 组管理协议ICMP/ICMPv6:Internet控制信息协议SNMP:简单网络管理协议 DNS:域名系统(服务)协议
      TCP/IP , UDP , APR/RAPR, DSN, ATM,X2.5,SNMP,CMIP/CMIS,等等 太多了…………………………
      TCP UDP IP APR DNS……
      计算机网络中的协议有哪些

      常见的网络协议有哪几种,分别是如何定义的?

      常见的网络协议有TCP/IP协议、NetBEUI、IPX/SPX协议。1、TCP/IP协议,是这三大协议中最重要的一个,是互联网的基础协议,任何和互联网有关的操作都离不开TCP/IP协议。但TCP/IP协议在局域网中的通信效率不高,使用它在浏览“网上邻居”中的计算机时,会出现不能正常浏览的现象。2、NetBEUI,即NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。NetBEUI协议是一种短小精悍、通信效率高的广播型协议。3,、IPX/SPX协议,是Novell开发的专用于NetWare网络中的协议,但大部分可以联机的游戏都支持IPX/SPX协议。虽然这些游戏通过TCP/IP协议也能联机,但显然还是通过IPX/SPX协议更省事,因为根本不需要任何设置。扩展资料:由于网络节点之间联系的复杂性,在制定协议时,通常把复杂成分分解成一些简单成分,然后再将它们复合起来。网络协议的层次结构如下:1、结构中的每一层都规定有明确的服务及接口标准。2、把用户的应用程序作为最高层3、除了最高层外,中间的每一层都向上一层提供服务,同时又是下一层的用户。参考资料来源:百度百科-网络协议
      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 常用的三个网络协议网络中不同的工作站,服务器之间能传输数据,源于协议的存在。随着网络的发展,不同的开发商开发了不同的通信方式。为了使通信成功可靠,网络中的所有主机都必须使用同一语言,不能带有方言。因而必须开发严格的标准定义主机之间的每个包中每个字中的每一位。这些标准来自于多个组织的努力,约定好通用的通信方式,即协议。这些都使通信更容易。已经开发了许多协议,但是只有少数被保留了下来。那些协议的淘汰有多中原因---设计不好、实现不好或缺乏支持。而那些保留下来的协议经历了时间的考验并成为有效的通信方法。当今局域网中最常见的三个协议是MICROSOFT的NETBEUI、NOVELL的IPX/SPX和交叉平台TCP/IP。一:NETBEUINETBEUI是为IBM开发的非路由协议,用于携带NETBIOS通信。NETBEUI缺乏路由和网络层寻址功能,既是其最大的优点,也是其最大的缺点。因为它不需要附加的网络地址和网络层头尾,所以很快并很有效且适用于只有单个网络或整个环境都桥接起来的小工作组环境。因为不支持路由,所以NETBEUI永远不会成为企业网络的主要协议。NETBEUI帧中唯一的地址是数据链路层媒体访问控制(MAC)地址,该地址标识了网卡但没有标识网络。路由器靠网络地址将帧转发到最终目的地,而NETBEUI帧完全缺乏该信息。网桥负责按照数据链路层地址在网络之间转发通信,但是有很多缺点。因为所有的广播通信都必须转发到每个网络中,所以网桥的扩展性不好。NETBEUI特别包括了广播通信的记数并依赖它解决命名冲突。一般而言,桥接NETBEUI网络很少超过100台主机。近年来依赖于第二层交换器的网络变得更为普遍。完全的转换环境降低了网络的利用率,尽管广播仍然转发到网络中的每台主机。事实上,联合使用100-BASE-T Ethernet,允许转换NetBIOS网络扩展到350台主机,才能避免广播通信成为严重的问题。二:IPX/SPXIPX是NOVELL用于NETWARE客户端/服务器的协议群组,避免了NETBEUI的弱点。但是,带来了新的不同弱点。IPX具有完全的路由能力,可用于大型企业网。它包括32位网络地址,在单个环境中允许有许多路由网络。IPX的可扩展性受到其高层广播通信和高开销的限制。服务广告协议(Service Advertising Protocol,SAP)将路由网络中的主机数限制为几千。尽管SAP的局限性已经被智能路由器和服务器配置所克服,但是,大规模IPX网络的管理员仍是非常困难的工作。三:TCP/IP每种网络协议都有自己的优点,但是只有TCP/IP允许与Internet完全的连接。TCP/IP是在60年代由麻省理工学院和一些商业组织为美国国防部开发的,即便遭到核攻击而破坏了大部分网络,TCP/IP仍然能够维持有效的通信。ARPANET就是由基于协议开发的,并发展成为作为科学家和工程师交流媒体的Internet。TCP/IP同时具备了可扩展性和可靠性的需求。不幸的是牺牲了速度和效率(可是:TCP/IP的开发受到了政府的资助)。Internet公用化以后,人们开始发现全球网的强大功能。Internet的普遍性是TCP/IP至今仍然使用的原因。常常在没有意识到的情况下,用户就在自己的PC上安装了TCP/IP栈,从而使该网络协议在全球应用最广。TCP/IP的32位寻址功能方案不足以支持即将加入Internet的主机和网络数。因而可能 代替当前实现的标准是IPv6。
      常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议
      常见的网络协议有哪几种,分别是如何定义的?

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类