路由器的重要性(路由器的重要性 知乎)

      最后更新:2023-08-16 16:19

      路由器是干吗的

      标准的路由器是指:工作在OSI参考模型第三层——网络层的数据包转发设备。路由器通过转发数据包来实现网络互连。虽然路由器可以支持多种协议(如TCP/IP、IPX/SPX、AppleTalk等协议),但是在我国绝大多数路由器运行TCP/IP协议。路由器通常连接两个或多个由IP子网或点到点协议标识的逻辑端口,至少拥有1个物理端口。路由器根据收到数据包中的网络层地址以及路由器内部维护的路由表决定输出端口以及下一跳地址,并且重写链路层数据包头实现转发数据包。路由器通过动态维护路由表来反映当前的网络拓扑,并通过与网络上其他路由器交换路由和链路信息来维护路由表。 但你可能是说现在家里用来共享上网的宽带路由器,严格来说这东西不算是路由器,只能算是一个带NAT转换几台PC用于共享上网的小交换机。PS:帖一个更详细的说明路由器的定义、分类与标准简介由于当前社会信息化的不断推进,人们对数据通信的需求日益增加。自TCP/IP协议簇于七十年代中期推出以来,现已发展成为网络层通信协议的事实标准,基于TCP/IP的互联网络也成为了最大、最重要的网络。路由器作为IP网络的核心设备已经得到空前广泛的应用。路由器作为IP网的核心设备,其技术已成为当前信息产业的关键技术,其设备本身在数据通信中起到越来越重要的作用。同时由于路由器设备功能强大,且技术复杂,各厂家对路由器的实现有太多的选择性。路由器作为公众网络的核心设备,必须通过设备规范来提出最低要求。所以对路由器设备作出规范有其重要性和必要性。关于路由器设备已发布的标准如下所示:YD/T1156-2001《路由器测试规范-高端路由器》;YD/T1098-2001《路由器测试规范-低端路由器》。一、路由器定义路由器是工作在OSI参考模型第三层——网络层的数据包转发设备。路由器通过转发数据包来实现网络互连。虽然路由器可以支持多种协议(如TCP/IP、IPX/SPX、AppleTalk等协议),但是在我国绝大多数路由器运行TCP/IP协议。路由器通常连接两个或多个由IP子网或点到点协议标识的逻辑端口,至少拥有1个物理端口。路由器根据收到数据包中的网络层地址以及路由器内部维护的路由表决定输出端口以及下一跳地址,并且重写链路层数据包头实现转发数据包。路由器通过动态维护路由表来反映当前的网络拓扑,并通过与网络上其他路由器交换路由和链路信息来维护路由表。二、路由器分类当前路由器分类方法各异,各种分类方法有一定的关联,但是并不完全一致。从结构上分,路由器可分为模块化结构与非模块化结构,通常中高端路由器为模块化结构,低端路由器为非模块化结构。从网络位置划分,路由器可分为核心路由器与接入路由器。核心路由器位于网络中心,通常使用高端路由器,要求快速的包交换能力与高速的网络接口,通常是模块化结构;接入路由器位于网络边缘,通常使用中低端路由器,要求相对低速的端口以及较强的接入控制能力。从功能上划分,路由器可分为通用路由器与专用路由器。一般所说的路由器为通用路由器。专用路由器通常为实现某种特定功能对路由器接口、硬件等作专门优化,例如接入路由器用作接入拨号用户,增强PSTN接口以及信令能力;VPN路由器增强隧道处理能力以及硬件加密;宽带接入路由器强调宽带接口数量及种类。从性能上分,路由器可分为线速路由器以及非线速路由器。通常线速路由器是高端路由器,能以媒体速率转发数据包;中低端路由器是非线速路由器,但是一些新的宽带接入路由器也有线速转发能力。在标准的制定中,路由器从能力上区分可分为:高端路由器和低端路由器等类别,背板交换能力大于20Gbit/s,包交换能力大于20Mbit/s的路由器称为高端路由器;包交换能力小于1Mbit/s的路由器称为低端路由器。以市场占有率最大的Cisco公司为例,12000系列为高端路由器,7500以下系列路由器为低端路由器。显然上述划分存在空档:包交换能力1Mbit/s以上20Mbit/s以下的路由器没有参照标准。按照标准系列,应当有中档路由器规范。但是由于中档路由器没有特殊性,可以参照低端路由器或高端路由器,所以不再单独另立标准。三、标准制定依据路由器标准主要依据RFC文档。由于路由器技术复杂,相关RFC文档较多,大约上百个。除此之外还有大量路由协议、网管协议以及接口标准等文档也是非常重要,这里就不再一一罗列。与路由器相关最紧密的RFC文档是RFC1812,即IPv4路由器技术要求,路由器设备技术规范只要参照RFC1812,同时参照公用电信网络设备标准即可加以增删。虽然路由器标准主要依据RFC文档,但决不是简单翻译,在性能指标方面主要依据对路由器测试的结果。由于路由器牵涉大量的技术,标准无法包含所有相关协议的内容,所有协议的具体内容参见相关协议标准或RFC文档。但是简单地翻译或罗列相关RFC文档号和协议名称是不恰当的。这是因为:(1)在协议的要求中有一些比较重要,有一些是任选的;(2)某些要求在路由器的应用中非常关键,对于其他应用或设备或缺无关紧要;(3)某些厂商会因特定原因选择不同的特性。另外,在标准制定中,指定路由器必须实现的协议不会重复应用协议的内容,只规定协议中必须实现的内容、可选的内容、不需实现的内容来对同类协议作选择。路由器标准主要依据当前互联网技术以及当前版本的协议及RFC文档,随着这些技术领域的更新以及相关协议或RFC文档版本的更新,路由器标准应作相应更新或补充。四、标准范围路由器可以支持多种协议(如TCP/IP、IPX/SPX、AppleTalk等协议),即使TCP/IP协议也有版本4和版本6之分。但是由于当前TCP/IP已成为事实标准,IPv4在网络中占绝对优势,所以路由器标准着重规范支持IPv4的设备。由于IPv6有其固有的优越性,有可能在将来广泛应用,所以标准中建议路由器支持IPv6,但不作规范。路由器除标准中所描述的路由器外还有内嵌路由器和透明路由器。内嵌路由器指除提供路由功能外还提供操作系统功能的计算机系统。由于其固有的缺陷,在标准中建议不使用。透明路由器又称共享地址路由器,在标准中虽不作规范,但不排斥使用。路由器标准是工作在复杂多样的互联网中的路由器必须遵守的规范。尽管当前路由器不能完全符合标准,但是逐步符合路由器标准是努力的方向。由于互联网的复杂性以及现实情况的多样性,目前的路由器标准应作为建议标准。五、路由器标准的主要内容低端路由器标准与高端路由器标准内容有一定差异,差别主要体现在路由器接口类型、性能要求、可靠性要求等方面。一般来说高端路由器对性能要求高,接口速率要求高,可靠性要求高,它主要用作高速转发;低端路由器要求功能较多,除企业网应用外,公网中一般用它来作接入。上述两类路由器在基本功能方面差异不大。所以下文以低端路由器为例介绍路由器标准的主要内容。第一部分指明标准应用的范围,规定了路由器的技术要求,包括功能、指标、通信接口、通信协议、环境要求等。第二部分罗列出路由器标准所引用的标准与规范。如上文所述,有近百个文档。第三部分列举在标准中使用的所有定义、术语和缩写,主要定义路由器以及低端路由器。第四部分指出路由器的功能划分以及实现方法,他们分别如下。(1)接口功能:用作将路由器连接到网络。可以分为局域网接口及广域网接口两种。局域网接口主要包括以太网、令牌环、令牌总线、FDDI等网络接口。广域网主要包括E1/T1、E3/T3、DS3、通用串行口(可转换成X.21DTE/DCE、V.35DTE/DCE、RS232DTE/DCE、RS449DTE/DCE、EIA530DTE)等网络接口。(2)通信协议功能:该功能负责处理通信协议,可以包括TCP/IP 、PPP、X.25、帧中继等协议。(3)数据包转发功能:该功能主要负责按照路由表内容在各端口(包括逻辑端口)间转发数据包并且改写链路层数据包头信息。(4)路由信息维护功能:该功能负责运行路由协议并维护路由表。路由协议可包括RIP、OSPF、BGP等协议。(5)管理控制功能:路由器管理控制功能包括五个功能,他们是SNMP代理功能、Telnet服务器功能、本地管理、远端监控和RMON功能。通过五种不同的途径对路由器进行控制管理,并且允许纪录日志。(6)安全功能:该功能用于完成数据包过滤、地址转换、访问控制、数据加密、防火墙以及地址分配等。还有在第四部分中指出的路由器必须实现的基本功能。第五部分规定路由器接口物理层规范,其中包含E1接口、ISDN接口、以太网接口、串行同步口、FDDI接口以及其他接口。上述接口规范都引用现成标准,没有详细描述。第六部分主要通过引用其他标准规范的方式规定路由器接口的链路层规范,包括串行线路链路层协议、帧中继端口链路层协议、X.25链路层协议、ISDN链路层协议等内容。除此之外还包含路由器对链路层的附加要求:地址解析协议-ARP、关于Ethernet与802.3共存、最大传输单元-MTU、点到点协议-PPP以及接口测试等内容。第七部分规定路由器Internet层协议,其中包括IP协议、ICMP协议和IGMP协议。路由器对上述协议的实现并不是简单引用或翻译,而是针对路由器设备对上述3个协议各选项所作的特殊规定,是路由器标准中重要内容之一。第八部分对路由器的基本功能和转发做了规定。其中包转发过程具体规定符合互联网层协议(STD5 RFC791、STD5 RFC950、STD5 RFC792、RFC1016)。该部分内容主要参照RFC1812,综合上述几个RFC文档对路由器转发做了要求,这是路由器标准中重要内容之一。第九部分规定传输层协议,包括TCP协议与UDP协议。路由器工作在IP层,本来没有必要实现传输层协议,但是由于运行维护需要(Telnet)以及路由协议需要,路由器通常实现上述传输层协议。TCP和UDP协议描述主要简单应用,只对其中少量选项作定义。第十部分通过引用其他协议的方式规定路由器中运行的最复杂的协议:路由协议。其中包含两部分,内部路由与外部路由。内部网关协议用作在AS内部分发路由信息(即AS内部路由)。外部网关协议用作在AS间交换路由信息(即AS间路由)。第十一部分指出路由器网管方面规定。要求路由器必须支持RFC1902至RFC1906中规定的SNMP v2以及相应的标准MIB。第十二部分规定其他应用协议。对路由器实现的所有其它应用层协议,路由器必须符合STD3、RFC1123中相关要求。第十三部分指出路由器运行维护方面的规定。主要制定路由器运行和维护的内容、路由器初始化、运行和维护具体规定、路由器安全性考虑等内容。 第十四部分规定路由器主要技术指标。主要包含路由器的丢包率、路由器吞吐量、路由器的时延、路由器认证技术指标、路由表容量、背靠背帧数以及其计费、同步、可靠性指标等内容。最后规定了支持AppleTalk与Novell协议路由器,还规定了路由器环境要求以及电源和接地要求。
      路由器是一种连接多个网络或网段的网络设备,它能将不同网络或网段之间的数据信息进行“翻译”,以使它们能够相互“读”懂对方的数据,从而构成一个更大的网络。 要解释路由器的概念,首先得知道什么是路由。所谓“路由”,是指把数据从一个地方传送到另一个地方的行为和动作,而路由器,正是执行这种行为动作的机器,它的英文名称为Router,是一种连接多个网络或网段的网络设备,它能将不同网络或网段之间的数据信息进行“翻译”,以使它们能够相互“读懂”对方的数据,从而构成一个更大的网络。简单的讲,路由器主要有以下几种功能:网络互连,路由器支持各种局域网和广域网接口,主要用于互连局域网和广域网,实现不同网络互相通信;数据处理,提供包括分组过滤、分组转发、优先级、复用、加密、压缩和防火墙等功能;网络管理,路由器提供包括配置管理、性能管理、容错管理和流量控制等功能。[编辑]路由器的功能路由器有两大典型功能,即数据通道功能和控制功能。数据通道功能包括转发决定、背板转发以及输出链路调度等,一般由特定的硬件来完成;控制功能一般用软件来实现,包括与相邻路由器之间的信息交换、系统配置、系统管理等。路由器的一个作用是连通不同的网络,另一个作用是选择信息传送的线路。选择通畅快捷的近路,能大大提高通信速度,减轻网络系统通信负荷,节约网络系统资源,提高网络系统畅通率,从而让网络系统发挥出更大的效益来。从过滤网络流量的角度来看,路由器的作用与交换机和网桥非常相似。但是与工作在网络物理层,从物理上划分网段的交换机不同,路由器使用专门的软件协议从逻辑上对整个网络进行划分。例如,一台支持IP协议的路由器可以把网络划分成多个子网段,只有指向特殊IP地址的网络流量才可以通过路由器。对于每一个接收到的数据包,路由器都会重新计算其校验值,并写入新的物理地址。因此,使用路由器转发和过滤数据的速度往往要比只查看数据包物理地址的交换机慢。但是,对于那些结构复杂的网络,使用路由器可以提高网络的整体效率。路由器的另外一个明显优势就是可以自动过滤网络广播。从总体上说,在网络中添加路由器的整个安装过程要比即插即用的交换机复杂很多。 一般说来,异种网络互联与多个子网互联都应采用路由器来完成。路由器的主要工作就是为经过路由器的每个数据帧寻找一条最佳传输路径,并将该数据有效地传送到目的站点。由此可见,选择最佳路径的策略即路由算法是路由器的关键所在。为了完成这项工作,在路由器中保存着各种传输路径的相关数据--路径表(Routing Table),供路由选择时使用。路径表中保存着子网的标志信息、网上路由器的个数和下一个路由器的名字等内容。路径表可以是由系统管理员固定设置好的,也可以由系统动态修改,可以由路由器自动调整,也可以由主机控制。
      路由器就像过河要用的桥或是船,就是说你家有几台电脑或是你隔壁的人有电脑然后可以用路由器联起来就可以上网了,再可以省钱,不过就是不能一起看有些在线电影
      简单点说,如果两个或者两个以上的人想共享一条网线上网的话就要使用路由器了。
      一个拨号转用硬件. 可以共享上网.无需电脑拨号就能上网的东东
      路由器是干吗的

      路由与交换技术的重要性

      如果您是在学网络管理,考网络认证,不管是网络安全,视频,云计算,存储,语音,监控,视频会议,无线等方面的认证,路由和交换是您考这些认证之前的必要的基础 数据如何从网络的一端,经过交换机,路由器到达另外一端的路由器,交换机,最终到达最终用户,完成相应的操作,中间经过的1-7层数据封装,数据包处理,路由您是必须要会的学会了这个,您才能更好的学习和理解网络安全,云计算,存储,视频语音,监控,无线等其他方面的课程 用做厨师做个比喻:做厨师学各大菜系之前,颠勺,切墩这些基本功是必须要学的,而路由和交换就相当于做大厨之前必须要学的颠勺和切墩
      路由与交换技术的重要性

      无线路由器高级设置的方法

      路由器长久以来一直是计算机网络的核心设备,其重要性不可低估。随着数字家庭,远程控制,快速布线等需求的增加,无线路由器的重要性日益凸显。下面是我为大家整理的关于无线路由器高级设置的方法,一起来看看吧!无线路由器高级设置的方法在这里,建议大家依据需要对“信道”和“频段带宽”进行调整。现在大多数无线设备都是使用2.4GHz无线频段在进行工作,而该频段一般被分为11或13个信道。可是有很多用户都在使用的无线设备的默认信道“1”,那么当有多个无线设备相“遇”时冲突和干扰就在所难免,影响无线传输质量。调整“信道”如果你的无线路由器支持智能的“自动”信道还好,不然还是建议挑选一个与周围无线源不同的信道使用,以避开干扰和冲突,获得最佳无线传输效果。频段带宽是发送无线信号频率的标准,频率越高越容易失真,其中20MHz在11n的情况下能达到144Mbps带宽,它穿透性较好,传输距离远(约100米左右);40MHz在11n的情况下能达到300Mbps带宽,穿透性稍差,传输距离近(约50米左右)。调节“频段带宽”因此如果为了获得更大的传输速度,可以选用40MHz,但是在应用环境中,无线源较多的话,则不建议选择40MHz了,不然任意使用1到6信道的无线信号都会干扰40MHz频宽的通讯。现在多数的无线路由器都可以开启20/40MHz混合模式,建议用户使用,或选择像我们实验路由器中的“自动”模式即可。不知道大家是不是遇到过隔墙如隔山的“囧”况呢?又或是担心无线功率过大而不利身体健康呢?这时你就需要对无线路由器的无线“传输功率”进行调节了。设定“传输功率”而现在大多的无线路由器产品都已支持“传输功率”的调节功能,像这款实验无线路由器就支持高、中、低三档的功率调节,用户可根据组网需要进行调整。
      无线路由器高级设置的方法

      路由器是什么东西呀?它有什么作用?我是新手,不好意思!呵呵!

      路由器是一种连接多个网络或网段的网络设备,它能将不同网络或网段之间的数据信息进行“翻译”,以使它们能够相互“读”懂对方的数据,从而构成一个更大的网络。 路由器有两大典型功能,即数据通道功能和控制功能。数据通道功能包括转发决定、背板转发以及输出链路调度等,一般由特定的硬件来完成;控制功能一般用软件来实现,包括与相邻路由器之间的信息交换、系统配置、系统管理等。 多少年来,路由器的发展有起有伏。90年代中期,传统路由器成为制约因特网发展的瓶颈。ATM交换机取而代之,成为IP骨干网的核心,路由器变成了配角。进入90年代末期,Internet规模进一步扩大,流量每半年翻一番,ATM网又成为瓶颈,路由器东山再起,Gbps路由交换机在1997年面世后,人们又开始以Gbps路由交换机取代ATM交换机,架构以路由器为核心的骨干网。
      楼上的朋友解释这么多太复杂了,简单点说吧陆游就是在一个宽带上用他使多个电脑并行分享数据,同时使用那个宽带上网,比如家里有2个电脑,但是只有1个ADSL,用了陆游的话2个就能同时上网拉! 家用的路由一般是4口的,就是可以接4个电脑,路由个人使用感觉有以下几个好处:1,几台电脑能同时共享一个宽带数据接口,而且2,3台电脑使用的时候速度几乎没影响2,设定好路由信息后可以让他控制猫自动拨号(要是包月的才好哦?如果是记时或计流量的那可就亏大了!)3,内建防火墙,可以防止一般的网络攻击 以上是我自己使用陆游的一点体会 个人意见,只供参考
      路由是整个网吧里面看数据流量大小的!起很大重要性
      路由器是什么东西呀?它有什么作用?我是新手,不好意思!呵呵!

      家里装两个路由器有什么实际意义?是可以增强稳定性呢?还是可以增大覆盖面呢?谢谢 。????

      家里装两个路由器,多路由器桥接使用,只会减低网络稳定性,但会增加无线网络WIFI覆盖范围;欢迎追问~!
      我用的是联通家庭4M宽带,打算在网上买一个无线路由器回来搞一个家庭wifi,现在用着的路由器是联通原配的路由器(路由器和ADSL调制解调器是同一个机器,所以路由器和ADSL调制解调器不可分),用这个路由器不用登陆,开机就能上网,那么,新买的无线路由器应该怎样接入?(PS:说明书有说接好路由器之后需要打开浏览器输入192.168.1.1设置一些东西,那么?无线路由器接好后打开浏览器输入192.168.1.1还能打开关于无线路由器的设置吗?打开的还是关于联通原配的路由器的设置?) 主要是在后面一个卧室信号太弱了。 YBy
      增加路由器只是增加网络覆盖面积,网络的强弱看路由器的内部的发射频率之类的,一般的路由器基本满足信号需求,如要穿墙等,那就要买信号增强的。
      可以增大覆盖面。
      增大覆盖面
      家里装两个路由器有什么实际意义?是可以增强稳定性呢?还是可以增大覆盖面呢?谢谢 。????

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类