扫描到ftp是什么意思(计算机中FTP是什么意思)

      最后更新:2023-08-21 08:35

      扫描结果:***.**.**.***: PORT : FTP是什么意思?

      前面是IP,端口开的是FTP
      扫描结果:***.**.**.***: PORT : FTP是什么意思?

      FTP是什么的缩写,到底指什么意思

      FTP 是File Transfer Protocol(文件传输协议)的英文简称,而中文简称为“文传协议”。用于Internet上的控制文件的双向传输。同时,它也是一个应用程序(Application)。 FTP是一个8位的客户端-服务器协议,能操作任何类型的文件而不需要进一步处理,就像MIME或Unicode一样。但是,FTP有着极高的延时,这意味着,从开始请求到第一次接收需求数据之间的时间,会非常长;并且不时的必须执行一些冗长的登录进程。文件传输协议的原始规范于1971年4月16日发布为RFC114。直到1980年,FTP运行在TCP/ IP的前身NCP上。该协议后来被TCP / IP版本,RFC 765(1980年6月)和RFC 959(1985年10月)(当前规范)所取代。RFC 959提出了若干标准修改,例如RFC 1579(1994年2月)启用防火墙FTP(被动模式),RFC 2228(1997年6月)提出安全扩展,RFC 2428(1998年9月)增加了对IPv6的支持,并定义了一种新型的被动模式。扩展资料与大多数Internet服务一样,FTP也是一个客户机/服务器系统。用户通过一个支持FTP协议的客户机程序,连接到在远程主机上的FTP服务器程序。用户通过客户机程序向服务器程序发出命令,服务器程序执行用户所发出的命令,并将执行的结果返回到客户机。比如说,用户发出一条命令,要求服务器向用户传送某一个文件的一份拷贝,服务器会响应这条命令,将指定文件送至用户的机器上。客户机程序代表用户接收到这个文件,将其存放在用户目录中。大多数最新的网页浏览器和文件管理器都能和FTP服务器创建连接。这使得在FTP上通过一个接口就可以操控远程文件,如同操控本地文件一样。 这个功能通过给定一个FTP的URL实现,形如ftp://<服务器地址>(例如,ftp://ftp.gimp.org )。是否提供密码是可选择的,如果有密码,则形如ftp://:@。大部分网页浏览器要求使用被动FTP模式,然而并不是所有的FTP服务器都支持被动模式。
      全程:File Transfer Protocol,是一种文件传输协议.iis7服务器管理工具可批量管理ftp站点.免费的,可以使用看看.实践得知真理,嘻嘻这款工具的强大之处在于它还能批量管理win/linux系统服务器,同时也是vnc的客户端,操作起来也很容易.

      FTP是什么的缩写,到底指什么意思

      ftp是什么意思呢

      FTP是File Transfer Protocol(文件传输协议)的英文简称,而中文简称为“文传协议”。用于Internet上的控制文件的双向传输。同时,它也是一个应用程序(Application)。FTP是一个8位的客户端-服务器协议,能操作任何类型的文件而不需要进一步处理,就像MIME或Unicode一样。但是,FTP有着极高的延时,这意味着,从开始请求到第一次接收需求数据之间的时间,会非常长;并且不时的必须执行一些冗长的登录进程。与大多数Internet服务一样,FTP也是一个客户机/服务器系统。用户通过一个支持FTP协议的客户机程序,连接到在远程主机上的FTP服务器程序。用户通过客户机程序向服务器程序发出命令,服务器程序执行用户所发出的命令,并将执行的结果返回到客户机。比如说,用户发出一条命令,要求服务器向用户传送某一个文件的一份拷贝,服务器会响应这条命令,将指定文件送至用户的机器上。客户机程序代表用户接收到这个文件,将其存放在用户目录中。大多数最新的网页浏览器和文件管理器都能和FTP服务器创建连接。这使得在FTP上通过一个接口就可以操控远程文件,如同操控本地文件一样。
      ftp是什么意思呢

      设置扫描器的ftp中的路径是什么啊

      扫描路径就是你扫描后扫描文件存储的位置。FTP路径就是如果你扫描文件是存在ftp上,就要把这个FTP的访问路径写到这个地方,然后扫描文件就会存到FTP上了。
      设置扫描器的ftp中的路径是什么啊

      FTP是做什么用的?怎么使用?

      FTP说简单一点就是可以进行网络文件共享,可以将你电脑上的资料(一般指的是较大的文件)通过FTP的方式进行公开,也就是将你的电脑设为简单的服务器,并且你自己可以设置访问用户名和密码,只要你的电脑是开机的,不管在哪个地方的人都可以通过网络来访问并下载你共享的文件,前提是要知道你的用户名和密码以及访问的FTP地址说得很简单了,不知明白没有,上面只是关于FTP的理解,要实际使用,则可以通过专业软件完成,如何你安装完软件,应该你不知道的也就知道了,如FTP的地址是什么,FTP的用户和密码怎么设置,需要共享的文件怎么选择等等...实际方法,说一下简单的方法吧,自己做过的1、下载一个Serv-U FTP Server V8的专业FTP软件,下载地址baidu搜一下,一大堆2、查一下它的使用说明,网络也很多,没有的话,直接安装软件,中文版的,里面都有使用说明,你仔细研究一下也就了解了PS:总的来说,感觉要学习的东西较多,实际上你只要安装软件,问题就都可以解决了,这个软件我自己也用过,很好用,发一张操作界面让你KK吧,打字好多字噢,希望对你有所帮助!
      FTP基础知识 您是否正准备搭建自己的FTP网站?您知道FTP协议的工作机制吗?您知道什么是PORT方式?什么是PASV方式吗?如果您不知道,或没有完全掌握,请您坐下来,花一点点时间,细心读完这篇文章。所谓磨刀不误砍柴功,掌握这些基础知识,会令您事半功倍。否则,很可能折腾几天,最后一事无成。FTP基础知识FTP是File Transfer Protocol(文件传输协议)的缩写,用来在两台计算机之间互相传送文件。相比于HTTP,FTP协议要复杂得多。复杂的原因,是因为FTP协议要用到两个TCP连接,一个是命令链路,用来在FTP客户端与服务器之间传递命令;另一个是数据链路,用来上传或下载数据。FTP协议有两种工作方式:PORT方式和PASV方式,中文意思为主动式和被动式。PORT(主动)方式的连接过程是:客户端向服务器的FTP端口(默认是21)发送连接请求,服务器接受连接,建立一条命令链路。当需要传送数据时,客户端在命令链路上用 PORT命令告诉服务器:“我打开了****端口,你过来连接我”。于是服务器从20端口向客户端的****端口发送连接请求,建立一条数据链路来传送数据。PASV(被动)方式的连接过程是:客户端向服务器的FTP端口(默认是21)发送连接请求,服务器接受连接,建立一条命令链路。当需要传送数据时,服务器在命令链路上用 PASV命令告诉客户端:“我打开了****端口,你过来连接我”。于是客户端向服务器的****端口发送连接请求,建立一条数据链路来传送数据。从上面可以看出,两种方式的命令链路连接方法是一样的,而数据链路的建立方法就完全不同。而FTP的复杂性就在于此。FTP服务器端的注意事项一、FTP服务器是公网IP,用公网动态域名;或是内网IP,用内网专业版TrueHost1、服务器如果安装了防火墙,请记住要在防火墙上打开FTP端口(默认是21)。2、所有FTP服务器软件都支持PORT方式。至于PASV方式,大部分FTP服务器软件都支持。支持PASV方式的FTP服务器软件,也可以设置为只工作在PORT方式上。3、为了PASV方式能正常工作,需要在FTP服务器软件上为PASV方式指定可用的端口范围(设置方法)。此外,还要在服务器的防火墙上打开这些端口。当客户端以PASV方式连接服务器的时候,服务器就会在这个端口范围里挑选一个端口出来,给客户端连接。二、FTP服务器是内网IP,用内网动态域名标准版cm*natpro*y这种情况下,FTP服务器不需要做特殊设置,只要支持PASV方式就可以了。大部分FTP服务器软件都支持PASV方式。FTP客户端的注意事项请注意:选择用PASV方式还是PORT方式登录FTP服务器,选择权在FTP客户端,而不是在FTP服务器。一、客户端只有内网IP,没有公网IP从上面的FTP基础知识可知,如果用PORT方式,因为客户端没有公网IP,FTP将无法连接客户端建立数据链路。因此,在这种情况下,客户端必须要用PASV方式,才能连接FTP服务器。大部分FTP站长发现自己的服务器有人能登录上,有人登录不上,典型的错误原因就是因为客户端没有公网IP,但用了IE作为FTP客户端来登录(IE默认使用PORT方式)。作为FTP站长,有必要掌握FTP的基础知识,然后指导您的朋友如何正确登录您的FTP。二、客户端有公网IP,但安装了防火墙如果用PASV方式登录FTP服务器,因为建立数据链路的时候,是由客户端向服务器发送连接请求,没有问题。反过来,如果用PORT方式登录FTP服务器,因为建立数据链路的时候,是由服务器向客户端发送连接请求,此时连接请求会被防火墙拦截。如果要用PORT方式登录FTP服务器,请在防火墙上打开 1024以上的高端端口。三、连接用内网标准版cm*natpro*y搭建的FTP服务,必须要用PASV方式。连接任何公网FTP服务器、或用内网专业版TrueHost搭建的FTP服务器,PORT方式和PASV方式都可以使用。当然,使用PORT方式的时候,还要满足上面的两个条件。四、常见的FTP客户端软件PORT方式与PASV方式的切换方法。大部分FTP客户端默认使用PASV方式。IE默认使用PORT方式。在大部分FTP客户端的设置里,常见到的字眼都是“PASV”或“被动模式”,极少见到“PORT”或“主动模式”等字眼。因为FTP的登录方式只有两种:PORT和PASV,取消PASV方式,就意味着使用PORT方式。IE:工具 -> Internet选项 -> 高级 -> “使用被动FTP”(需要IE6.0以上才支持)。CuteFTP:Edit -> Setting -> Connection -> Firewall -> “PASV Mode”或File -> Site Manager,在左边选中站点 -> Edit -> “Use PASV mode”FlashGet:工具 -> 选项 -> 代理服务器 -> 直接连接 -> 编辑 -> “PASV模式”FlashFTP:选项 -> 参数选择 -> 代理/防火墙/标识 -> “使用被动模式”或站点管理 -> 对应站点 -> 选项 -> “使用被动模式”或快速连接 -> 切换 -> “使用被动模式”LeechFTP:Option -> Firewall -> Do not Use五、请尽量不要用IE作为FTP客户端IE只是个很粗糙的FTP客户端工具。首先,IE6.0以下的版本不支持PASV方式;其次,IE在登录FTP的时候,看不到登录信息。在登录出错的时候,无法找到错误的原因。在测试自己的FTP网站的时候,强烈建议不要使用IE。FTP建站的详细配置过程请参考这个网页的说明来配置:使用Serv-U建立FTP网站高级话题一、为什么没有公网IP,也能使用PORT方式登录FTP?NAT 网关的工作方式是在TCP/IP数据包的包头里找局域网的源地址和源端口,替换成网关的地址和端口。对数据包里的内容,是不会改变的。而使用PORT方式登录FTP的时候,IP地址与端口信息是在数据包里面的,而不是在包头。因此,没有公网IP,使用PORT方式是无法从internet上的ftp服务器下载数据的。但是,极少数的NAT网关也支持PORT方式。这些NAT网关连数据包里面的内容都扫描,扫描到 PORT指令后会替换PORT方式的IP和端口。在这种NAT网关下面,用PORT方式就没问题了。不过,这些网关也只扫描21端口的数据包,如果FTP 服务器不是用默认的21端口,也无法使用PORT方式。二、内网可以用PORT访问其他FTP,为什么不能用PORT访问自己的TrueHost FTP?下面要讨论的问题,只是为了说明一些原理,是不影响实际使用的。如果您没有兴趣深究这些原理,不必花时间看。内网用户通过支持PORT方式的NAT网关,访问自己本机利用TrueHost建立的FTP服务器,FTP命令链路的建立过程如下:FTP客户端10.10.0.1端口*** <==> ISP NAT网关61.144.1.2端口**** <==> TH服务器*.*.*.*端口21 <==> TH客户端 <==> 用户FTP服务器10.10.0.1端口21FTP客户端通过ISP的NAT网关、科迈TrueHost服务器、TrueHost客户端,连接用户本机的FTP服务器的21端口。当需要下载数据的时候,FTP客户端通过这条命令链路,向FTP服务器发送PORT命令。假设命令为:PORT 10,10,0,1,30,4 (即IP=10.10.0.1 端口=30*256+4=7684)当命令通过ISP的NAT网关的时候,NAT网关判断目的端口是21,并且是PORT命令,于是,修改命令里的IP和端口,替换为自己的IP和端口,比如:PORT 61,144,1,2,50,6 (即IP=61.144.1.2 端口=50*256+6=12806)用户的FTP服务器最终收到的是上面这个PORT命令。于是,FTP服务器向这个IP和端口发送连接请求,建立数据链路。用户FTP服务器10.10.0.1端口20 <==> ISP NAT网关61.144.1.2端口12806 <==> FTP客户端10.10.0.1端口7684但是,因为NAT网关的公网IP只能接收外来的连接请求。就是说,61.144.1.2:12806只能接收其他公网IP的连接请求,对于从NAT内部(10.10.0.1:20)发起的连接请求,是无法建立连接的。为什么?原因很简单,因为内网IP要访问外网,必须要通过NAT建立映射。于是FTP数据链路无法建立。于是,用户无法在自己的机器上通过21端口访问自己的TrueHost FTP。我们再来看看,如果FTP端口不是21,比如是22,会发生什么情况呢?在FTP客户端发送PORT命令的时候,NAT网关检测到目标端口是22,因为支持PORT的 NAT网关只监视目的端口是21的数据包,发现目的端口是22的数据包,不做任何处理,完全放行。于是FTP服务器收到的PORT命令依然是PORT 10,10,0,1,30,4。于是FTP服务器向这个IP和端口发送连接请求。用户FTP服务器10.10.0.1端口20 <==> FTP客户端10.10.0.1端口7684这种情况下命令链路就可以建立起来了。而且是等于本机连接本机,速度飞快。综上所述,内网用户无法用PORT方式通过21端口访问自己的TrueHost FTP服务器。如果FTP端口不是21,则可以访问,而且实际上是本机连接本机。 上面的文字,仅仅是为了说明一些原理,不影响实际使用。如果本机访问本机,还要通过FTP的话,就有画蛇添足之嫌了。
      FTP 文件传输协议 我觉得从名字就完全可以理解其用途了。 最简单的应用就是IE,IE也支持FTP协议,可以直接连接FTP服务器上传或者下载文件。
      FTP是文件传输协议。 网络出项的FTP就是文件服务器! 一般用来存放文件的服务器。
      FTP是文件传输协议 用于Internet上的控制文件的双向传输。同时,它也是一个应用程序(Application)。用户可以通过它把自己的PC机与世界各地所有运行FTP协议的服务器相连,访问服务器上的大量程序和信息。 就是让用户连接上一个远程计算机(这些计算机上运行着FTP服务器程序)察看远程计算机有哪些文件,然后把文件从远程计算机上拷到本地计算机,或把本地计算机的文件送到远程计算机去。 就是这样了 你想建立FTP 么
      FTP是做什么用的?怎么使用?

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类