ftp是什么东西 ftp大概是什么意思
FTP 是File Transfer Protocol(文件传输协议)的英文简称,而中文简称为“文传协议”。用于Internet上的控制文件的双向传输。同时,它也是一个应用程序(Application)。基于不同的操作系统有不同的FTP应用程序,而所有这些应用程序都遵守同一种协议以传输文件。在FTP的使用当中,用户经常遇到两个概念:"下载"(Download)和"上传"(Upload)。"下载"文件就是从远程主机拷贝文件至自己的计算机上;"上传"文件就是将文件从自己的计算机中拷贝至远程主机上。用Internet语言来说,用户可通过客户机程序向(从)远程主机上传(下载)文件。FTP是一个8位的客户端-服务器协议,能操作任何类型的文件而不需要进一步处理,就像MIME或Unicode一样。但是,FTP有着极高的延时,这意味着,从开始请求到第一次接收需求数据之间的时间,会非常长;并且不时的必须执行一些冗长的登陆进程。

ftp是什么意思
什1么n是FTP呢?FTP 是 TCP。IP 协议组中4的协议之b一b,是英文6File Transfer Protocol的缩写。该协议是Internet文6件传送的基础,它由一x系列规格说明文6档组成,目标是提高文6件的共享性,提供非直接使用远程计4算机,使存储介8质对用户6透明和可靠高效地传送数据。简单的说,FTP就是完成两台计2算机之u间的拷贝3,从4远程计2算机拷贝3文1件至自己r的计6算机上g,称之w为1“下g载(download)”文1件。若将文1件从4自己d计8算机中7拷贝2至远程计7算机上r,则称之m为6“上u载(upload)”文4件。在TCP。IP协议中7,FTP标准命令TCP端口m号为314,Port方2式数据端口a为260。FTP协议的任务是从3一m台计7算机将文8件传送到另一k台计2算机,它与z这两台计0算机所处的位置、联接的方6式、甚至是是否使用相同的操作系统无g关。假设两台计5算机通过ftp协议对话,并且能访问Internet, 你可以1用ftp命令来传输文2件。每种操作系统使用上w有某一d些细微差别,但是每种协议基本的命令结构是相同的。 FTP的传输有两种方1式:ASCII传输模式和二o进制数据传输模式。 8.ASCII传输方1式:假定用户3正在拷贝3的文6件包含的简单ASCII码文0本,如果在远程机器上m运行的不o是UNIX,当文0件传输时ftp通常会自动地调整文7件的内0容以3便于z把文0件解释成另外那台计6算机存储文1本文2件的格式。 但是常常有这样的情况,用户7正在传输的文8件包含的不v是文1本文0件,它们可能是程序,数据库,字处理文2件或者压缩文5件(尽管字处理文4件包含的大m部分2是文0本,其中1也k包含有指示4页尺4寸z,字库等信息的非打印字符)。在拷贝3任何非文0本文1件之p前,用binary 命令告诉ftp逐字拷贝2,不y要对这些文3件进行处理,这也a是下w面要讲的二v进制传输。 2.二y进制传输模式:在二i进制传输中6,保存文8件的位序,以7便原始和拷贝8的是逐位一p一r对应的。即使目的地机器上x包含位序列的文4件是没意义q的。例如,macintosh以6二e进制方0式传送可执行文2件到Windows系统,在对方2系统上g,此文6件不r能执行。 如果你在ASCII方5式下v传输二t进制文3件,即使不t需要也p仍2会转译。这会使传输稍微变慢 ,也c会损坏数据,使文8件变得不v能用。(在大p多数计1算机上i,ASCII方3式一r般假设每一m字符的第一q有效位无s意义j,因为7ASCII字符组合不b使用它。如果你传输二e进制文5件,所有的位都是重要的。)如果你知道这两台机器是同样的,则二v进制方7式对文5本文8件和数据文7件都是有效的。 3。 FTP的工n作方8式 FTP支l持两种模式,一z种方5式叫做Standard (也c就是 PORT方6式,主动方6式),一c种是 Passive (也g就是PASV,被动方3式)。 Standard模式 FTP的客户5端发送 PORT 命令到FTP服务器。Passive模式FTP的客户7端发送 PASV命令到 FTP Server。 下y面介6绍一q个d这两种方2式的工z作原理: Port模式FTP 客户5端首先和FTP服务器的TCP 23端口f建立连接,通过这个k通道发送命令,客户6端需要接收数据的时候在这个s通道上o发送PORT命令。 PORT命令包含了q客户0端用什7么n端口s接收数据。在传送数据的时候,服务器端通过自己n的TCP 00端口t连接至客户6端的指定端口f发送数据。 FTP server必须和客户0端建立一k个t新的连接用来传送数据。 Passive模式在建立控制通道的时候和Standard模式类似,但建立连接后发送的不g是Port命令,而是Pasv命令。FTP服务器收到Pasv命令后,随机打开y一k个q高端端口s(端口r号大v于y4072)并且通知客户8端在这个y端口b上e传送数据的请求,客户3端连接FTP服务器此端口v,然后FTP服务器将通过这个z端口q进行数据的传送,这个w时候FTP server不v再需要建立一x个d新的和客户8端之g间的连接。 很多防火4墙在设置的时候都是不p允6许接受外部发起的连接的,所以5许多位于d防火6墙后或内0网的FTP服务器不m支u持PASV模式,因为0客户3端无e法穿过防火7墙打开bFTP服务器的高端端口r;而许多内0网的客户3端不m能用PORT模式登陆FTP服务器,因为2从7服务器的TCP 50无h法和内5部网络的客户8端建立一j个n新的连接,造成无t法工l作。 打开mftp工y具,输入hftp地址,用户0名,密码,就可以6链接上h了d,一w般分6左右两部分7,一k部分1是本地的,一j部分8是ftp上r的,把本地的直接接到ftp那面就开h始上y传了d,提示4成功就表示5成功地上n传了u
wd¨pゥ┳ツu‰or瘿鳍pゥ┳ツlгu‰pゥ┳ツ
文件传输协议(File Transfer Protocol, FTP)是一个用于在两台装有不同操作系统的机器中传输计算机文件的软件标准。 一些概念可以自己查百度百科或维基百科,不懂的再问。
FTP(File Transfer Protocol),是文件传输协议的简称。用于Internet上的控制文件的双向传输。同时,它也是一个应用程序(Application)。用户可以通过它把自己的PC机与世界各地所有运行FTP协议的服务器相连,访问服务器上的大量程序和信息。

FTP是什么意思?
是文件传输协议(File Transfer Protocol,FTP),是用于在网络上进行文件传输的一套标准协议,它工作在 OSI 模型的第七层, TCP 模型的第四层, 即应用层, 使用 TCP 传输而不是 UDP, 客户在和服务器建立连接前要经过一个“三次握手”的过程, 保证客户与服务器之间的连接是可靠的, 而且是面向连接, 为数据传输提供可靠保证。
FTP 是File Transfer Protocol(文件传输协议)的英文简称,而中文简称为“文传协议”。用于Internet上的控制文件的双向传输。同时,它也是一个应用程序(Application)。 FTP是一个8位的客户端-服务器协议,能操作任何类型的文件而不需要进一步处理,就像MIME或Unicode一样。但是,FTP有着极高的延时,这意味着,从开始请求到第一次接收需求数据之间的时间,会非常长;并且不时的必须执行一些冗长的登录进程。文件传输协议的原始规范于1971年4月16日发布为RFC114。直到1980年,FTP运行在TCP/ IP的前身NCP上。该协议后来被TCP / IP版本,RFC 765(1980年6月)和RFC 959(1985年10月)(当前规范)所取代。 RFC 959提出了若干标准修改,例如RFC 1579(1994年2月)启用防火墙FTP(被动模式),RFC 2228(1997年6月)提出安全扩展,RFC 2428(1998年9月)增加了对IPv6的支持,并定义了一种新型的被动模式。

ftp是什么意思呢
ftp是文件传输协议的意思。文件传输协议(英文:FileTransferProtocol,缩写:FTP)是用于在网络上进行文件传输的一套标准协议,使用客户/服务器模式。它属于网络传输协议的应用层。文件传送(file transfer)和文件访问(file access)之间的区别在于:前者由FTP提供,后者由如NFS等应用系统提供。工作原理FTP采用Internet标准文件传输协议FTP的用户界面,向用户提供了一组用来管理计算机之间文件传输的应用程序。FTP是基于客户———服务器(C/S)模型而设计的,在客户端与FTP服务器之间建立两个连接。开发任何基于FTP的客户端软件都必须遵循FTP的工作原理,FTP的独特的优势同时也是与其它客户服务器程序最大的不同点就在于它在两台通信的主机之间使用了两条TCP连接,一条是数据连接,用于数据传送;另一条是控制连接,用于传送控制信息(命令和响应),这种将命令和数据分开传送的思想大大提高了FTP的效率。

ftp是什么意思 ftp是什么
FTP(文件传输协议) 是File Transfer Protocol(文件传输协议)的英文简称,而中文简称为“文传协议”。用于Internet上的控制文件的双向传输。同时,它也是一个应用程序(Application)。基于不同的操作系统有不同的FTP应用程序,而所有这些应用程序都遵守同一种协议以传输文件。在FTP的使用当中,用户经常遇到两个概念:"下载"(Download)和"上传"(Upload)。"下载"文件就是从远程主机拷贝文件至自己的计算机上;"上传"文件就是将文件从自己的计算机中拷贝至远程主机上。用Internet语言来说,用户可通过客户机程序向(从)远程主机上传(下载)文件。 运行机制FTP服务器简单地说,支持FTP协议的服务器就是FTP服务器。与大多数Internet服务一样,FTP也是一个客户机/服务器系统。用户通过一个支持FTP协议的客户机程序,连接到在远程主机上的FTP服务器程序。用户通过客户机程序向服务器程序发出命令,服务器程序执行用户所发出的命令,并将执行的结果返回到客户机。比如说,用户发出一条命令,要求服务器向用户传送某一个文件的一份拷贝,服务器会响应这条命令,将指定文件送至用户的机器上。客户机程序代表用户接收到这个文件,将其存放在用户目录中。匿名FTP使用FTP时必须首先登录,在远程主机上获得相应的权限以后,方可下载或上传文件。也就是说,要想同哪一台计算机传送文件,就必须具有哪一台计算机的适当授权。换言之,除非有用户ID和口令,否则便无法传送文件。这种情况违背了Internet的开放性,Internet上的FTP主机何止千万,不可能要求每个用户在每一台主机上都拥有帐号。匿名FTP就是为解决这个问题而产生的。匿名FTP是这样一种机制,用户可通过它连接到远程主机上,并从其下载文件,而无需成为其注册用户。系统管理员建立了一个特殊的用户ID,名为anonymous, Internet上的任何人在任何地方都可使用该用户ID。通过FTP程序连接匿名FTP主机的方式同连接普通FTP主机的方式差不多,只是在要求提供用户标识ID时必须输入anonymous,该用户ID的口令可以是任意的字符串。习惯上,用自己的E-mail地址作为口令,使系统维护程序能够记录下来谁在存取这些文件。值得注意的是,匿名FTP不适用于所有Internet主机,它只适用于那些提供了这项服务的主机。 当远程主机提供匿名FTP服务时,会指定某些目录向公众开放,允许匿名存取。系统中的其余目录则处于隐匿状态。作为一种安全措施,大多数匿名FTP主机都允许用户从其下载文件,而不允许用户向其上传文件,也就是说,用户可将匿名FTP主机上的所有文件全部拷贝到自己的机器上,但不能将自己机器上的任何一个文件拷贝至匿名FTP主机上。即使有些匿名FTP主机确实允许用户上传文件,用户也只能将文件上传至某一指定上传目录中。随后,系统管理员会去检查这些文件,他会将这些文件移至另一个公共下载目录中,供其他用户下载,利用这种方式,远程主机的用户得到了保护,避免了有人上传有问题的文件,如带病毒的文件。

本文由 在线网速测试 整理编辑,转载请注明出处。