关于网络协议(关于网络协议说法正确的是)

      最后更新:2023-10-07 13:08

      常用的网络协议有哪些?

      常用的网络协议有TCP/IP协议、HTTP协议、FTP协议、Telnet协议、FTP协议、SMTP协议、NFS协议、UDP协议等。网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。网络协议是由三个要素组成:1、语义语义是解释控制信息每个部分的意义。它规定了需要发出何种控制信息,以及完成的动作与做出什么样的响应。2、语法语法是用户数据与控制信息的结构与格式,以及数据出现的顺序。3、时序时序是对事件发生顺序的详细说明。网络协议的层次结构如下:1、结构中的每一层都规定有明确的服务及接口标准。2、把用户的应用程序作为最高层3、除了最高层外,中间的每一层都向上一层提供服务,同时又是下一层的用户。4、把物理通信线路作为最低层,它使用从最高层传送来的参数,是提供服务的基础。
      1.ARP(Address Resolution Protocol):地址解析协议,将IP解析成MAC地址地址解析协议,即ARP(Address Resolution Protocol),是根据IP地址获取物理地址的协议。主机发送信息时将包含目标IP地址的ARP请求广播到网络上的所有主机,并接收返回消息,以此确定目标的物理地址;收到返回消息后将该IP地址和物理地址存入本机ARP缓存中并保留一定时间,下次请求时直接查询ARP缓存以节约资源。地址解析协议是建立在网络中各个主机互相信任的基础上的,网络上的主机可以自主发送ARP应答消息,其他主机收到应答报文时不会检测该报文的真实性就会将其记入本机ARP缓存;由此攻击者就可以向某一主机发送伪ARP应答报文,使其发送的信息无法到达预期的主机或到达错误的主机,这就构成了一个ARP欺骗(网络执法官软件的工作原理就是arp欺骗)。2.DNS:域名解析协议 www.baidu.com3.SNMP(Simple Network Management Protocol)简单网络管理协议4.DHCP(Dynamic Host Configuration Protocol)动态主机配置协议,它是在TCP/IP网络上使客户机获得配置信息的协议5.FTP(File Transfer Protocol)文件传输协议,它是一个标准协议,是在计算机和网络之间交换文件的最简单的方法。6.HTTP(Hypertext Transfer Protocol ):超文本传输协议7.HTTPS(Secure Hypertext Transfer Protocol):安全超文本传输协议,它是由Netscape开发并内置于其浏览器中,用于对数据进行压缩和解压操作.8.ICMP(Internet Control Message Protocol):Internet控制信息协议,互联网控制报文协议ping  ip定义消息类型有:TTL超时、地址的请求与应答、信息的请求与应答、目的地不可到达9.SMTP(Simple Mail Transfer Protocol):简单邮件传送协议10.TELNET Protocol:虚拟终端协议11.TFTP(Trivial File Transfer Protocol):小文件传输协议12.UDP(User Datagram Protocol):用户数据报协议,它是定义用来在互连网络环境中提供包交换的计算机通信的协议13.TCP(Transmission Control Protocol): 传输控制协议,是一种面向连接的、可靠的、基于字节流的传输层通信协议  log转发:开启一个协议:tcp(三次握手和四次挥手)

      常用的网络协议有哪些?

      什么是网络协议,在internet上通用的协议是什么?

      网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。在Internet上通用的协议是TCP/IP协议。网络协议是由三个要素组成:1、语义。语义是解释控制信息每个部分的意义。它规定了需要发出何种控制信息,以及完成的动作与做出什么样的响应。2、语法。语法是用户数据与控制信息的结构与格式,以及数据出现的顺序。3、时序。时序是对事件发生顺序的详细说明。(也可称为“同步”)。人们形象地把这三个要素描述为:语义表示要做什么,语法表示要怎么做,时序表示做的顺序。扩展资料:网络协议的方式:网络协议是网络上所有设备(网络服务器、计算机及交换机、路由器、防火墙等)之间通信规则的集合,它规定了通信时信息必须采用的格式和这些格式的意义。大多数网络都采用分层的体系结构,每一层都建立在它的下层之上,向它的上一层提供一定的服务,而把如何实现这一服务的细节对上一层加以屏蔽。一台设备上的第 n层与另一台设备上的第n层进行通信的规则就是第n层协议。在网络的各层中存在着许多协议,接收方和发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息。网络协议使网络上各种设备能够相互交换信息。常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议等。TCP/IP协议的主要特点:1、TCP/IP协议不依赖于任何特定的计算机硬件或操作系统,提供开放的协议标准,即使不考虑Internet,TCP/IP协议也获得了广泛的支持。所以TCP/IP协议成为一种联合各种硬件和软件的实用系统。2、TCP/IP协议并不依赖于特定的网络传输硬件,所以TCP/IP协议能够集成各种各样的网络。用户能够使用以太网(Ethernet)、令牌环网(Token Ring Network)、拨号线路(Dial-up line)、X.25网以及所有的网络传输硬件。3、统一的网络地址分配方案,使得整个TCP/IP设备在网中都具有惟一的地址4、标准化的高层协议,可以提供多种可靠的用户服务。参考资料来源:百度百科--网络协议参考资料来源:百度百科--TCP/IP协议
      网络协议即网络中(包括互联网)传递、管理信息的一些规范。如同人与人之间相互交流是需要遵循一定的规矩一样,计算机之间的相互通信需要共同遵守一定的规则,这些规则就称为网络协议。 一台计算机只有在遵守网络协议的前提下,才能在网络上与其他计算机进行正常的通信。网络协议通常被分为几个层次,每层完成自己单独的功能。通信双方只有在共同的层次间才能相互联系。常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议等。在局域网中用得的比较多的是IPX/SPX.。用户如果访问Internet,则必须在网络协议中添加TCP/IP协议。TCP/IP是“transmission Control Protocol/Internet Protocol”的简写,中文译名为传输控制协议/互联网络协议)协议, TCP/IP(传输控制协议/网间协议)是一种网络通信协议,它规范了网络上的所有通信设备,尤其是一个主机与另一个主机之间的数据往来格式以及传送方式。TCP/IP是INTERNET的基础协议,也是一种电脑数据打包和寻址的标准方法。在数据传送中,可以形象地理解为有两个信封,TCP和IP就像是信封,要传递的信息被划分成若干段,每一段塞入一个TCP信封,并在该信封面上记录有分段号的信息,再将TCP信封塞入IP大信封,发送上网。在接受端,一个TCP软件包收集信封,抽出数据,按发送前的顺序还原,并加以校验,若发现差错,TCP将会要求重发。因此,TCP/IP在INTERNET中几乎可以无差错地传送数据。 对普通用户来说,并不需要了解网络协议的整个结构,仅需了解IP的地址格式,即可与世界各地进行网络通信。IPX/SPX是基于施乐的XEROX’S Network System(XNS)协议,而SPX是基于施乐的XEROX’S SPP(Sequenced Packet Protocol:顺序包协议)协议,它们都是由novell公司开发出来应用于局域网的一种高速协议。它和TCP/IP的一个显著不同就是它不使用ip地址,而是使用网卡的物理地址即(MAC)地址。在实际使用中,它基本不需要什么设置,装上就可以使用了。由于其在网络普及初期发挥了巨大的作用,所以得到了很多厂商的支持,包括microsoft等,到现在很多软件和硬件也均支持这种协议。 NetBEUI即NetBios Enhanced User Interface ,或NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用,例如Windows for Workgroup、Win 9x系列、Windows NT等。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。总之NetBEUI协议是一种短小精悍、通信效率高的广播型协议,安装后不需要进行设置,特别适合于在“网络邻居”传送数据。所以建议除了TCP/IP协议之外,局域网的计算机最好也安上NetBEUI协议。另外还有一点要注意,如果一台只装了TCP/IP协议的WINDOWS98机器要想加入到WINNT域,也必须安装NetBEUI协议。
      网络协议即网络中(包括互联网)传递、管理信息的一些规范。如同人与人之间相互交流是需要遵循一定的规矩一样,计算机之间的相互通信需要共同遵守一定的规则,这些规则就称为网络协议。 一台计算机只有在遵守网络协议的前提下,才能在网络上与其他计算机进行正常的通信。网络协议通常被分为几个层次,每层完成自己单独的功能。通信双方只有在共同的层次间才能相互联系。常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议等。在局域网中用得的比较多的是IPX/SPX.。用户如果访问Internet,则必须在网络协议中添加TCP/IP协议。

      协议的安装上去请你把windows安装盘防入光区 点控制面版 删除添加程序在点windows组件选择网络双击打开选择协议安装就可以了
      什么是网络协议,在internet上通用的协议是什么?

      计算机网络协议有哪些

      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议。TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层,几个常用协议如下:1、Telnet(RemoteLogin):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(FileTransferProtocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(SimpleMailtransferProtocol):简单邮政传输协议,用于传输电子邮件。4、NFS(NetworkFileServer):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(UserDatagramProtocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。HTTP协议简介HTTP是一个属于应用层的面向对象的协议,由于其简捷、快速的方式,适用于分布式超媒体信息系统。它于1990年提出,经过几年的使用与发展,得到不断地完善和扩展。目前在WWW中使用的是HTTP/1.0的第六版,HTTP/1.1的规范化工作正在进行之中,而且HTTP-NG(NextGenerationofHTTP)的建议已经提出。HTTP协议的主要特点可概括如下:1.支持客户/服务器模式。2.简单快速:客户向服务器请求服务时,只需传送请求方法和路径。请求方法常用的有GET、HEAD、POST。每种方法规定了客户与服务器联系的类型不同。由于HTTP协议简单,使得HTTP服务器的程序规模小,因而通信速度很快。3.灵活:HTTP允许传输任意类型的数据对象。正在传输的类型由Content-Type加以标记。4.无连接:无连接的含义是限制每次连接只处理一个请求。服务器处理完客户的请求,并收到客户的应答后,即断开连接。采用这种方式可以节省传输时间。 5.无状态:HTTP协议是无状态协议。无状态是指协议对于事务处理没有记忆能力。缺少状态意味着如果后续处理需要前面的信息,则它必须重传,这样可能导致每次连接传送的数据量增大。另一方面,在服务器不需要先前信息时它的应答就较快。
      应用层 ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   · RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
      应用层 ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   · RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
      ·DHCP(动态主机分配协议) · DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议
      TCOP/IP DNSDHCPTELNETHTTPSMTPTFTPSNMPTCPUDPIPARPRAPPICMPIGMPPPP X.25
      计算机网络协议有哪些

      常见的网络协议有哪几种,分别是如何定义的?

      常见的网络协议有TCP/IP协议、NetBEUI、IPX/SPX协议。1、TCP/IP协议,是这三大协议中最重要的一个,是互联网的基础协议,任何和互联网有关的操作都离不开TCP/IP协议。但TCP/IP协议在局域网中的通信效率不高,使用它在浏览“网上邻居”中的计算机时,会出现不能正常浏览的现象。2、NetBEUI,即NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。NetBEUI协议是一种短小精悍、通信效率高的广播型协议。3,、IPX/SPX协议,是Novell开发的专用于NetWare网络中的协议,但大部分可以联机的游戏都支持IPX/SPX协议。虽然这些游戏通过TCP/IP协议也能联机,但显然还是通过IPX/SPX协议更省事,因为根本不需要任何设置。扩展资料:由于网络节点之间联系的复杂性,在制定协议时,通常把复杂成分分解成一些简单成分,然后再将它们复合起来。网络协议的层次结构如下:1、结构中的每一层都规定有明确的服务及接口标准。2、把用户的应用程序作为最高层3、除了最高层外,中间的每一层都向上一层提供服务,同时又是下一层的用户。参考资料来源:百度百科-网络协议
      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 常用的三个网络协议网络中不同的工作站,服务器之间能传输数据,源于协议的存在。随着网络的发展,不同的开发商开发了不同的通信方式。为了使通信成功可靠,网络中的所有主机都必须使用同一语言,不能带有方言。因而必须开发严格的标准定义主机之间的每个包中每个字中的每一位。这些标准来自于多个组织的努力,约定好通用的通信方式,即协议。这些都使通信更容易。已经开发了许多协议,但是只有少数被保留了下来。那些协议的淘汰有多中原因---设计不好、实现不好或缺乏支持。而那些保留下来的协议经历了时间的考验并成为有效的通信方法。当今局域网中最常见的三个协议是MICROSOFT的NETBEUI、NOVELL的IPX/SPX和交叉平台TCP/IP。一:NETBEUINETBEUI是为IBM开发的非路由协议,用于携带NETBIOS通信。NETBEUI缺乏路由和网络层寻址功能,既是其最大的优点,也是其最大的缺点。因为它不需要附加的网络地址和网络层头尾,所以很快并很有效且适用于只有单个网络或整个环境都桥接起来的小工作组环境。因为不支持路由,所以NETBEUI永远不会成为企业网络的主要协议。NETBEUI帧中唯一的地址是数据链路层媒体访问控制(MAC)地址,该地址标识了网卡但没有标识网络。路由器靠网络地址将帧转发到最终目的地,而NETBEUI帧完全缺乏该信息。网桥负责按照数据链路层地址在网络之间转发通信,但是有很多缺点。因为所有的广播通信都必须转发到每个网络中,所以网桥的扩展性不好。NETBEUI特别包括了广播通信的记数并依赖它解决命名冲突。一般而言,桥接NETBEUI网络很少超过100台主机。近年来依赖于第二层交换器的网络变得更为普遍。完全的转换环境降低了网络的利用率,尽管广播仍然转发到网络中的每台主机。事实上,联合使用100-BASE-T Ethernet,允许转换NetBIOS网络扩展到350台主机,才能避免广播通信成为严重的问题。二:IPX/SPXIPX是NOVELL用于NETWARE客户端/服务器的协议群组,避免了NETBEUI的弱点。但是,带来了新的不同弱点。IPX具有完全的路由能力,可用于大型企业网。它包括32位网络地址,在单个环境中允许有许多路由网络。IPX的可扩展性受到其高层广播通信和高开销的限制。服务广告协议(Service Advertising Protocol,SAP)将路由网络中的主机数限制为几千。尽管SAP的局限性已经被智能路由器和服务器配置所克服,但是,大规模IPX网络的管理员仍是非常困难的工作。三:TCP/IP每种网络协议都有自己的优点,但是只有TCP/IP允许与Internet完全的连接。TCP/IP是在60年代由麻省理工学院和一些商业组织为美国国防部开发的,即便遭到核攻击而破坏了大部分网络,TCP/IP仍然能够维持有效的通信。ARPANET就是由基于协议开发的,并发展成为作为科学家和工程师交流媒体的Internet。TCP/IP同时具备了可扩展性和可靠性的需求。不幸的是牺牲了速度和效率(可是:TCP/IP的开发受到了政府的资助)。Internet公用化以后,人们开始发现全球网的强大功能。Internet的普遍性是TCP/IP至今仍然使用的原因。常常在没有意识到的情况下,用户就在自己的PC上安装了TCP/IP栈,从而使该网络协议在全球应用最广。TCP/IP的32位寻址功能方案不足以支持即将加入Internet的主机和网络数。因而可能 代替当前实现的标准是IPv6。
      常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议
      常见的网络协议有哪几种,分别是如何定义的?

      如何定义网络协议?网络协议有哪些意义

      网络协议是计算机网络中进行数据交换而建立的规则、标准或约定的集合。例如,网络中一个微机用户和一个大型主机的操作员进行通信,由于这两个数据终端所用字符集不同,因此操作员所输入的命令彼此不认识。为了能进行通信,规定每个终端都要将各自字符集中的字符先变换为标准字符集的字符后,才进入网络传送,到达目的终端之后,再变换为该终端字符集的字符。当然,对于不相容终端,除了需变换字符集字符外还需转换其他特性,如显示格式、行长、行数、屏幕滚动方式等也需作相应的变换。对等实体通常是指计算机网络体系结构中处于相同层次的信息单元。一般系统网络协议包括五个部分:通信环境,传输服务,词汇表,信息的编码格式,时序、规则和过程。网络协议是由三个要素组成:(1) 语义。语义是解释控制信息每个部分的意义。它规定了需要发出何种控制信息,以及完成的动作与做出什么样的响应。(2) 语法。语法是用户数据与控制信息的结构与格式,以及数据出现的顺序。(3) 时序。时序是对事件发生顺序的详细说明。(也可称为“同步”)。人们形象地把这三个要素描述为:语义表示要做什么,语法表示要怎么做,时序表示做的顺序。
      网络是一个相互联结的大群体,因此要想加入到这个群体中来,就不能随心所欲,任由兴之所发。就好象一个国家或一个种族拥有自己的语言,大家都必须通晓并凭借这种语言来对话一样,相互联结的网络中各个节点也需要拥有共同的“语言”,依据它所定义的规则来控制数据的传递,这种语言便是大家经常听说的 “协议”。 协议是对网络中设备以何种方式交换信息的一系列规定的组合,它对信息交换的速率、传输代码、代码结构、传输控制步骤、出错控制等许多参数作出定义。对网络始入门者来说,纷繁复杂的协议常常让人头痛不已—这些协议各起什么作用?它们之间又有什么联系?为什么有了A协议还需要补充B协议?这些问题搞不清楚,往往成为进一步学习的障碍。其实这个问题应该这样理解:是先有了各种不同语言的民族,后来随着社会的发展,才有了不同民族间交流的需求。网络也是这样,最初人们在小范围内建立网络,只需要自己作一些简单的约定,保证这一有限范围内的用户遵守就可以了;到后来网络规模越来越大,才考虑到制定更严格的规章制度即协议;而为了实现多个不同网络的互联,又会增加不少新协议作为补充,或成长为统一的新标准。数据在网络中由源传输到目的地,需要一系列的加工处理,为了便于理解,我们这里不妨打个比喻。如果我们把数据比做巧克力:我们可以把加工巧克力的设备作为源,而把消费者的手作为目的来看看会有什么样的传输过程。巧克力厂通常会为每块巧克力外边加上一层包装,然后还会将若干巧克力装入一个巧克力盒,再把几个巧克力盒一起装入一个外包装,运输公司还会把许多箱巧克力装入一个集装箱,到达消费者所在的城市后,又会由运输商、批发商、零售商、消费者打开不同的包装层。不同层次的包装、解包装需要不同的规范和设备,计算机网络也同样有不同的封装、传输层面,为此国际标准化组织ISO于1978 年提出“开放系统互连参考模型”,即著名的OSI(OpenSystem Interconnection)七层模型,它将是我们后续篇幅中要介绍的内容,这里先不展开论述。 网络的协议就是用作这些不同的网络层的行为规范的。网络在发展过程中形成了很多不同的协议族,每一协议族都在网络的各层对应有相应的协议,其中作为Internet规范的是ICP/IP协议族,这也是我们今天要讲的。TCP/IP协议的定义以及层次、功能什么是TCP/IP协议,划为几层,各有什么功能?TCP/IP协议族包含了很多功能各异的子协议。为此我们也利用上文所述的分层的方式来剖析它的结构。TCP/IP层次模型共分为四层:应用层、传输层、网络层、数据链路层。TCP/IP网络协议 TCP/IP(Transmission Control Protocol/Internet Protocol,传输控制协议/网间网协议)是目前世界上应用最为广泛的协议,它的流行与Internet的迅猛发展密切相关—TCP/IP最初是为互联网的原型ARPANET所设计的,目的是提供一整套方便实用、能应用于多种网络上的协议,事实证明TCP/IP做到了这一点,它使网络互联变得容易起来,并且使越来越多的网络加入其中,成为Internet的事实标准。
      如何定义网络协议?网络协议有哪些意义

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类