重复服务器响应请求(请求超时服务器未响应)

      最后更新:2023-10-09 22:09

      服务器工作原理是什么

      服务器的工作原理如下:整个服务器系统就像一个人,处理器就是服务器的大脑,而各种总线就像是分布于全身肌肉中的神经,芯片组就像是骨架,而I/O设备就像是通过神经系统支配的人的手、眼睛、耳朵和嘴;而电源系统就像是血液循环系统,它将能量输送到身体的所有地方。在信息系统中,服务器主要应用于数据库和Web服务,而PC主要应用于桌面计算和网络终端,设计根本出发点的差异决定了服务器应该具备比PC更可靠的持续运行能力、更强大的存储能力和网络通信能力、更快捷的故障恢复功能和更广阔的扩展空间。同时,对数据相当敏感的应用还要求服务器提供数据备份功能。而PC机在设计上则更加重视人机接口的易用性、图像和3D处理能力及其他多媒体性能。扩展资料:服务器的构成:因为服务器作为提供计算服务的设备,所以服务器需要响应服务请求,并进行处理,因此一般来说服务器应具备承担服务并且保障服务的能力。服务器的构成包括处理器、硬盘、内存、系统总线等,和通用的计算机架构类似,但是由于需要提供高可靠的服务,因此在处理能力、稳定性、可靠性、安全性、可扩展性、可管理性等方面要求较高。在网络环境下,根据服务器提供的服务类型不同,分为文件服务器、数据库服务器、应用程序服务器、WEB服务器等。参考资料来源:百度百科-服务器
      服务器的工作原理就是通过网络对服务器进行连接,从连接过程、请求过程、应答过程以及关闭连接,这四个方面来达到数据连接、页面访问、权限管理等操作。扩展资料:服务器访问过程1、连接过程服务器和其浏览器之间所建立起来的一种连接。查看连接过程是否实现,用户可以找到和打开socket这个虚拟文件,这个文件的建立意味着连接过程这一步骤已经成功建立。2、请求过程浏览器运用socket这个文件向其服务器而提出各种请求。3、应答过程运用HTTP协议把在请求过程中所提出来的请求传输到服务器,进而实施任务处理,然后运用HTTP协议把任务处理的结果传输到浏览器,同时在浏览器上面展示上述所请求之界面。4、关闭连接就是当上一个步骤--应答过程完成以后,服务器和其浏览器之间断开连接之过程。服务器上述4个过程环环相扣、紧密相联,逻辑性比较强,可以支持多个进程、多个线程以及多个进程与多个线程相混合的技术。参考资料来源:百度百科--服务器参考资料来源:百度百科--WEB服务器
      服务器是做服务用的,放置在公共网络状态的环境里,全球任何一台连入互联网的终端机就可以连接到服务器,与服务器交互信息,也可以单方向的从服务器上获取信息,典型的服务就是IIS,服务器里安装IIS服务,就可以将网站的内容放入服务器里,使全球的任何人只要打开这个网站的网址就可以打开这个网站,浏览、下载这个服务器上的网站信息。
      虽然说现在我们能够利用到的软件和工具变得越来越多,这些东西的出现给我们的生活和工作带来了极大的帮助,而且我们还能够利用这些工具来帮助自己挣钱。服务器就是其中的一种,提到服务器可能有些人并不是非常的清楚,但是如果你所从事的工作或者是平常大家有据了解相关的信息的话,大家就能够清楚的知道它是什么,它对于我们自己的帮助是非常大的,那如果你想要更好的去发挥服务器的功能和效果的话,我们首先就应该要清楚的了解到这个服务器它的运行原理究竟是怎样的?接下来56云小编在这里就给大家详细的介绍,关于这个服务器它的运行原理希望能够给你带来一定的帮助。 其实服务器它是一项服务器虚拟化和自动化的技术,也就是说我们的这个服务器,它采用到的是操作系统虚拟化,通过提前制作好流程,然后就能够自动的去运行一个项目或者是自动的进行账号的操作,操作系统虚拟化的概念,它是基于共用操作系统的内核。在利用服务器这个软件的时候,我们就可以在一台物理服务器上面实现更多的一个虚拟化的服务器,而这些也是vps服务器最大的一个效率的共享硬件。以上这些介绍可能会偏向于专业化,如果你平常对于网络技术了解的不是非常多的话,大家听到这样的解释也并不是非常的清楚,但其实用一个简单的话来说就是我们的这个服务器,他将原本必须要进行实际操作的一些流程和项目,进行了一个虚拟化的处理,把虚拟化和自动化相结合之后,那么我们就可以直接打开软件,然后就能够进行重复的一个动作或者是重复的项目的操作了。 这个其实和我们平常见到的自动化机器有着异曲同工之妙,只不过那些自动化的机械设备,他还是需要人工进行操作,但是我们的服务器他根本就不需要进行人工操作,你只需要将自己的账号跟密码输入进去,然后点击开始它就会重复的去进行我们原先设定好的工作,比如说你想要挂机游戏的话,我们也只需要将自己的游戏账号和密码输入进去,那么它就可以挂机了,而且使用这个软件来进行挂机,他所得到的效果是翻倍的,这也是为什么现在有这么多的人会比较喜欢使用服务器的最主要的原因,因为它能够帮助我们节省很多的时间,毕竟如果没有服务器,我们想要让自己的游戏账号等级升级的话,还是需要自己花大量的时间去进行操作的,有时候即使你花很多钱,都没有办法让自己的游戏账号等级升上来,可是有了服务器之后这些问题都迎刃而解了。希望小编再介绍了这个软件的运行原理之后,能够给大家今后的实际操作带来一定的帮助,如果你并不是非常清楚的话,我们也可以进入到专门的网站当中进行了解。
      服务器的功能 • 提供服务- IP 地址• 将一种资源共享给多个请求者- 数据库• 将一种设备共享给多个请求者- 打印机• 为其他系统开放网关- Web• 提供处理能力- 数字• 存储内容- 数据 工作原因就是计算机语言 "0 1"了吧!
      服务器工作原理是什么

      11.WEB通讯

      长轮询,WebSockets和服务器发送事件是Web浏览器和Web服务器之类的客户端之间的常用通信协议。 首先,让我们开始了解标准HTTP Web请求的样子。 以下是常规HTTP请求的一系列事件: 客户端打开连接并从服务器请求数据。服务器计算响应。服务器在打开的请求上将响应发送回客户端。轮询是绝大多数AJAX应用程序使用的标准技术。 基本思想是客户端反复轮询(或请求)服务器以获取数据。 客户端发出请求并等待服务器响应数据。 如果没有可用数据,则返回空响应。客户端使用常规HTTP打开连接并从服务器请求数据。所请求的网页以规则的间隔(例如,0.5秒)向服务器发送请求。服务器计算响应并将其发回,就像常规HTTP流量一样。客户端定期重复上述三个步骤以从服务器获取更新。轮询问题是客户端必须不断向服务器询问任何新数据。 结果,许多响应都是空的,从而产生HTTP开销。长轮训是传统轮询技术的一种变体,允许服务器在数据可用时将信息推送到客户端。使用长轮询,客户端从正常轮询中请求来自服务器的信息,但期望服务器可能不会立即响应。这就是为什么这种技术有时被称为“HANGING GET”。如果服务器没有可用于客户端的任何数据,则服务器保留请求并等待直到某些数据可用,而不是发送空响应。数据可用后,将向客户端发送完整响应。然后,客户端立即从服务器重新请求信息,以便服务器几乎总是有一个可用的等待请求,它可以用来传递数据以响应事件。使用HTTP Long-Polling的应用程序的基本生命周期如下:客户端使用常规HTTP发出初始请求,然后等待响应。服务器会延迟响应,直到更新可用,或者直到发生超时。当更新可用时,服务器会向客户端发送完整响应。客户端通常在接收到响应时立即发送新的长轮询请求,或者在暂停之后发送新的长轮询请求以允许可接受的等待时间段。每个Long-Poll请求都有一个超时。由于超时,客户端必须在连接关闭后定期重新连接。WebSocket通过单个TCP连接提供全双工通信通道。 它提供客户端和服务器之间的持久连接,双方可以使用它来随时开始发送数据。 客户端通过称为WebSocket握手的进程建立WebSocket连接。 如果该过程成功,则服务器和客户端可以随时在两个方向上交换数据。 WebSocket协议以较低的开销实现客户端和服务器之间的通信,便于从服务器到服务器的实时数据传输。 这可以通过为服务器提供标准化的方式来实现,即在不被客户端询问的情况下将内容发送到浏览器,并允许在保持连接打开的同时来回传递消息。 通过这种方式,可以在客户端和服务器之间进行双向(双向)正在进行的对话。在SSE下,客户端与服务器建立持久且长期的连接。 服务器使用此连接将数据发送到客户端。 如果客户端想要将数据发送到服务器,则需要使用其他技术/协议来执行此操作。客户端使用常规HTTP从服务器请求数据。请求的网页打开与服务器的连接。只要有新信息,服务器就会将数据发送到客户端。 SSE 适用于那些,服务器要在一段时间批量发数据给客户端的场景,或者是服务器单方面向客户端实时发数据的场景。
      11.WEB通讯

      怎样防止ACK攻击

      拒绝服务攻击(Denial of Service,DoS)是目前比较有效而又非常难于防御的一种网络攻击方式,它的目的就是使服务器不能够为正常访问的用户提供服务。所以,DoS对一些紧密依靠互联网开展业务的企业和组织带来了致命的威胁。 SYN Flood是最为有效和流行的一种DoS攻击形式。它利用TCP三次握手协议的缺陷,向目标主机发送大量的伪造源地址的SYN连接请求,消耗目标主机的资源,从而不能够为正常用户提供服务。1.1 TCP连接建立的过程要掌握SYN Flood攻击的基本原理,必须先介绍TCP的三次握手机制。TCP三次握手过程如下:1)客户端向服务器端发送一个SYN置位的TCP报文,包含客户端使用的端口号和初始序列号x;2)服务器端收到客户端发送来的SYN报文后,向客户端发送一个SYN和ACK都置位的TCP报文,包含确认号为x+1和服务器的初始序列号y;3)TCP客户端客户端端口(1024-65535)TCP服务器端服务器端口(1-1023)SYNSYN/ACKACK客户端收到服务器返回的SYN+ACK报文后,向服务器返回一个确认号为y+1序号为x+1的ACK报文,一个标准的TCP连接完成。如图1所示:1.2 攻击原理在SYN Flood攻击中,黑客机器向受害主机发送大量伪造源地址的TCP SYN报文,受害主机分配必要的资源,然后向源地址返回SYN+ACK包,并等待源端返回ACK包,如图2所示。由于源地址是伪造的,所以源端永远都不会返回ACK报文,受害主机继续发送SYN+ACK包,并将半连接放入端口的积压队列中,虽然一般的主机都有超时机制和默认的重传次数,但是由于端口的半连接队列的长度是有限的,如果不断的向受害主机发送大量的TCP SYN报文,半连接队列就会很快填满,服务器拒绝新的连接,将导致该端口无法响应其他机器进行的连接请求,最终使受害主机的资源耗尽。TCP客户端客户端端口(1024-65535)TCP服务器端服务器端口(1-1023)SYNSYN/ACK伪造源地址2几种防御技术SYN Flood攻击给互联网造成重大影响后,针对如何防御SYN Flood攻击出现了几种比较有效的技术。2.1 SYN-cookie技术一般情况下,当服务器收到一个TCP SYN报文后,马上为该连接请求分配缓冲区,然后返回一个SYN+ACK报文,这时形成一个半连接。SYN Flood正是利用了这一点,发送大量的伪造源地址的SYN连接请求,而不完成连接。这样就大量的消耗的服务器的资源。SYN-cookie技术针对标准TCP连接建立过程资源分配上的这一缺陷,改变了资源分配的策略。当服务器收到一个SYN报文后,不立即分配缓冲区,而是利用连接的信息生成一个cookie,并将这个cookie作为将要返回的SYN+ACK报文的初始序列号。当客户端返回一个ACK报文时,根据包头信息计算cookie,与返回的确认序列号(初始的序列号+1)的前24位进行对比,如果相同,则是一个正常连接,然后,分配资源,建立连接。该技术的巧妙之点在于避免了在连接信息未完全到达前进行资源分配,使SYN Flood攻击的资源消耗失效。实现的关键之处在于cookie的计算。cookie的计算应该做到包含本次连接的状态信息,使攻击者不能伪造cookie。cookie的计算过程如下:1)服务器收到一个SYN包后,计算一个消息摘要mac:mac = MAC(A,k);MAC是密码学中的一个消息认证码函数,也就是满足某种安全性质的带密钥的hash函数,它能够提供cookie计算中需要的安全性。A为客户和服务器双方的IP地址和端口号以及参数t的串联组合:A = SOURCE_IP || SOURCE_PORT || DST_IP || DST_PORT || tK为服务器独有的密钥;时间参数t为32比特长的时间计数器,每64秒加1;2)生成cookie:cookie = mac(0:24):表示取mac值的第0到24比特位;3)设置将要返回的SYN+ACK报文的初始序列号,设置过程如下:i.高24位用cookie代替;ii.接下来的3比特位用客户要求的最大报文长度MMS代替;iii.最后5比特位为t mod 32。客户端收到来自服务器SYN+ACK报文后,返回一个ACK报文,这个ACK报文将带一个cookie(确认号为服务器发送过来的SYN ACK报文的初始序列号加1,所以不影响高24位),在服务器端重新计算cookie,与确认号的前24位比较,如果相同,则说明未被修改,连接合法,然后,服务器完成连接的建立过程。SYN-cookie技术由于在连接建立过程中不需要在服务器端保存任何信息,实现了无状态的三次握手,从而有效的防御了SYN Flood攻击。但是该方法也存在一些弱点。由于cookie的计算只涉及了包头的部分信心,在连接建立过程中不在服务器端保存任何信息,所以失去了协议的许多功能,比如,超时重传。此外,由于计算cookie有一定的运算量,增加了连接建立的延迟时间,因此,SYN-cookie技术不能作为高性能服务器的防御手段。通常采用动态资源分配机制,当分配了一定的资源后再采用cookie技术,Linux就是这样实现的。还有一个问题是,当我们避免了SYN Flood攻击的同时,同时也提供了另一种拒绝服务攻击方式,攻击者发送大量的ACK报文,使服务器忙于计算验证。尽管如此,在预防SYN Flood攻击方面,SYN-cookie技术仍然是一种有效的技术。2.2地址状态监控的解决方法地址状态监控的解决方法是利用监控工具对网络中的有关TCP连接的数据包进行监控,并对监听到的数据包进行处理。处理的主要依据是连接请求的源地址。每个源地址都有一个状态与之对应,总共有四种状态:初态:任何源地址刚开始的状态;NEW状态:第一次出现或出现多次也不能断定存在的源地址的状态;GOOD状态:断定存在的源地址所处的状态;BAD状态:源地址不存在或不可达时所处的状态。具体的动作和状态转换根据TCP头中的位码值决定:1)监听到SYN包,如果源地址是第一次出现,则置该源地址的状态为NEW状态;如果是NEW状态或BAD状态;则将该包的RST位置1然后重新发出去,如果是GOOD状态不作任何处理。2)监听到ACK或RST包,如果源地址的状态为NEW状态,则转为GOOD状态;如果是GOOD状态则不变;如果是BAD状态则转为NEW状态;如果是BAD状态则转为NEW状态。3)监听到从服务器来的SYN ACK报文(目的地址为addr),表明服务器已经为从addr发来的连接请求建立了一个半连接,为防止建立的半连接过多,向服务器发送一个ACK包,建立连接,同时,开始计时,如果超时,还未收到ACK报文,证明addr不可达,如果此时addr的状态为GOOD则转为NEW状态;如果addr的状态为NEW状态则转为BAD状态;如果为addr的状态为BAD状态则不变。状态的转换图如图3所示:初态GOODNEWBADACK/RSTSYNACK/RSTACK包确认超时ACK/RSTACK包确认超时下面分析一下基于地址状态监控的方法如何能够防御SYN Flood攻击。1)对于一个伪造源地址的SYN报文,若源地址第一次出现,则源地址的状态为NEW状态,当监听到服务器的SYN+ACK报文,表明服务器已经为该源地址的连接请求建立了半连接。此时,监控程序代源地址发送一个ACK报文完成连接。这样,半连接队列中的半连接数不是很多。计时器开始计时,由于源地址是伪造的,所以不会收到ACK报文,超时后,监控程序发送RST数据包,服务器释放该连接,该源地址的状态转为BAD状态。之后,对于每一个来自该源地址的SYN报文,监控程序都会主动发送一个RST报文。2)对于一个合法的SYN报文,若源地址第一次出现,则源地址的状态为NEW状态,服务器响应请求,发送SYN+ACK报文,监控程序发送ACK报文,连接建立完毕。之后,来自客户端的ACK很快会到达,该源地址的状态转为GOOD状态。服务器可以很好的处理重复到达的ACK包。从以上分析可以看出,基于监控的方法可以很好的防御SYN Flood攻击,而不影响正常用户的连接。3 小结本文介绍了SYN Flood攻击的基本原理,然后详细描述了两种比较有效和方便实施的防御方法:SYN-cookie技术和基于监控的源地址状态技术。SYN-cookie技术实现了无状态的握手,避免了SYN Flood的资源消耗。基于监控的源地址状态技术能够对每一个连接服务器的IP地址的状态进行监控,主动采取措施避免SYN Flood攻击的影响。这两种技术是目前所有的防御SYN Flood攻击的最为成熟和可行的技术。参考文献1. 颜学雄,王清贤,李梅林.SYN Flood攻击原理与预防方法.计算机应用,20002. 孙曦,朱晓妍,王育林. DDoS下的TCP洪流攻击及对策. 网络安全技术与应用,20043. 李磊,赵永祥,陈常嘉. TCP SYN Flooding原理及其应对策略. 网络与应用,20034. 陈波. SYN Flood攻击的原理、实现与防范. 计算机应用与研究,2003【转自世纪安全网http://www.21safe.com 】
      怎样防止ACK攻击

      chrome浏览器会不会因为服务器长时间没有响应而重复发送请求

      如果代码里没有处理请求超时的话,Chrome浏览器不会对超时情况做出重发的操作 如需要超时重发,请在代码里添加定时器,超过时间未收到数据,则重新发送请求
      chrome浏览器会不会因为服务器长时间没有响应而重复发送请求

      如何通过HTTP状态判断服务器运营状态

      HTTP状态码(HTTP Status Code)是用以表示网页服务器HTTP响应状态的3位数字代码。它由 RFC 2616 规范定义的,并得到RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。 所有状态码的第一个数字代表了响应的五种状态之一。1xx 消息这一类型的状态码,代表请求已被接受,需要继续处理。这类响应是临时响应,只包含状态行和某些可选的响应头信息,并以空行结束。由于 HTTP/1.0 协议中没有定义任何 1xx 状态码,所以除非在某些试验条件下,服务器禁止向此类客户端发送 1xx 响应。100 Continue客户端应当继续发送请求。这个临时响应是用来通知客户端它的部分请求已经被服务器接收,且仍未被拒绝。客户端应当继续发送请求的剩余部分,或者如果请求已经完成,忽略这个响应。服务器必须在请求完成后向客户端发送一个最终响应。101 Switching Protocols服务器已经理解了客户端的请求,并将通过 Upgrade 消息头通知客户端采用不同的协议来完成这个请求。在发送完这个响应最后的空行后,服务器将会切换到在 Upgrade 消息头中定义的那些协议。只有在切换新的协议更有好处的时候才应该采取类似措施。例如,切换到新的 HTTP 版本比旧版本更有优势,或者切换到一个实时且同步的协议以传送利用此类特性的资源。102 Processing由WebDAV(RFC 2518)扩展的状态码,代表处理将被继续执行。2xx 成功这一类型的状态码,代表请求已成功被服务器接收、理解、并接受。200 OK请求已成功,请求所希望的响应头或数据体将随此响应返回。201 Created请求已经被实现,而且有一个新的资源已经依据请求的需要而建立,且其 URI 已经随 Location 头信息返回。假如需要的资源无法及时建立的话,应当返回 '202 Accepted'。202 Accepted服务器已接受请求,但尚未处理。正如它可能被拒绝一样,最终该请求可能会也可能不会被执行。在异步操作的场合下,没有比发送这个状态码更方便的做法了。返回202状态码的响应的目的是允许服务器接受其他过程的请求(例如某个每天只执行一次的基于批处理的操作),而不必让客户端一直保持与服务器的连接直到批处理操作全部完成。在接受请求处理并返回202状态码的响应应当在返回的实体中包含一些指示处理当前状态的信息,以及指向处理状态监视器或状态预测的指针,以便用户能够估计操作是否已经完成。203 Non-Authoritative Information服务器已成功处理了请求,但返回的实体头部元信息不是在原始服务器上有效的确定集合,而是来自本地或者第三方的拷贝。当前的信息可能是原始版本的子集或者超集。例如,包含资源的元数据可能导致原始服务器知道元信息的超级。使用此状态码不是必须的,而且只有在响应不使用此状态码便会返回200 OK的情况下才是合适的。204 No Content服务器成功处理了请求,但不需要返回任何实体内容,并且希望返回更新了的元信息。响应可能通过实体头部的形式,返回新的或更新后的元信息。如果存在这些头部信息,则应当与所请求的变量相呼应。如果客户端是浏览器的话,那么用户浏览器应保留发送了该请求的页面,而不产生任何文档视图上的变化,即使按照规范新的或更新后的元信息应当被应用到用户浏览器活动视图中的文档。由于204响应被禁止包含任何消息体,因此它始终以消息头后的第一个空行结尾。205 Reset Content服务器成功处理了请求,且没有返回任何内容。但是与204响应不同,返回此状态码的响应要求请求者重置文档视图。该响应主要是被用于接受用户输入后,立即重置表单,以便用户能够轻松地开始另一次输入。与204响应一样,该响应也被禁止包含任何消息体,且以消息头后的第一个空行结束。206 Partial Content服务器已经成功处理了部分 GET 请求。类似于 FlashGet 或者迅雷这类的 HTTP 下载工具都是使用此类响应实现断点续传或者将一个大文档分解为多个下载段同时下载。该请求必须包含 Range 头信息来指示客户端希望得到的内容范围,并且可能包含 If-Range 来作为请求条件。响应必须包含如下的头部域:Content-Range 用以指示本次响应中返回的内容的范围;如果是 Content-Type 为 multipart/byteranges 的多段下载,则每一 multipart 段中都应包含 Content-Range 域用以指示本段的内容范围。假如响应中包含 Content-Length,那么它的数值必须匹配它返回的内容范围的真实字节数。DateETag 和/或 Content-Location,假如同样的请求本应该返回200响应。Expires, Cache-Control,和/或 Vary,假如其值可能与之前相同变量的其他响应对应的值不同的话。假如本响应请求使用了 If-Range 强缓存验证,那么本次响应不应该包含其他实体头;假如本响应的请求使用了 If-Range 弱缓存验证,那么本次响应禁止包含其他实体头;这避免了缓存的实体内容和更新了的实体头信息之间的不一致。否则,本响应就应当包含所有本应该返回200响 应中应当返回的所有实体头部域。假如 ETag 或 Last-Modified 头部不能精确匹配的话,则客户端缓存应禁止将206响应返回的内容与之前任何缓存过的内容组合在一起。任何不支持 Range 以及 Content-Range 头的缓存都禁止缓存206响应返回的内容。207 Multi-Status由WebDAV(RFC 2518)扩展的状态码,代表之后的消息体将是一个XML消息,并且可能依照之前子请求数量的不同,包含一系列独立的响应代码。3xx 重定向这类状态码代表需要客户端采取进一步的操作才能完成请求。通常,这些状态码用来重定向,后续的请求地址(重定向目标)在本次响应的 Location 域中指明。当且仅当后续的请求所使用的方法是 GET 或者 HEAD 时,用户浏览器才可以在没有用户介入的情况下自动提交所需要的后续请求。客户端应当自动监测无限循环重定向(例如:A->A,或者A->B->C->A),因为这会导致服务器和客户端大量不必要的资源消耗。按照 HTTP/1.0 版规范的建议,浏览器不应自动访问超过5次的重定向。300 Multiple Choices被请求的资源有一系列可供选择的回馈信息,每个都有自己特定的地址和浏览器驱动的商议信息。用户或浏览器能够自行选择一个首选的地址进行重定向。除非这是一个 HEAD 请求,否则该响应应当包括一个资源特性及地址的列表的实体,以便用户或浏览器从中选择最合适的重定向地址。这个实体的格式由 Content-Type 定义的格式所决定。浏览器可能根据响应的格式以及浏览器自身能力,自动作出最合适的选择。当然,RFC 2616规范并没有规定这样的自动选择该如何进行。如果服务器本身已经有了首选的回馈选择,那么在 Location 中应当指明这个回馈的 URI;浏览器可能会将这个 Location 值作为自动重定向的地址。此外,除非额外指定,否则这个响应也是可缓存的。301 Moved Permanently被请求的资源已永久移动到新位置,并且将来任何对此资源的引用都应该使用本响应返回的若干个 URI 之一。如果可能,拥有链接编辑功能的客户端应当自动把请求的地址修改为从服务器反馈回来的地址。除非额外指定,否则这个响应也是可缓存的。新的永久性的 URI 应当在响应的 Location 域中返回。除非这是一个 HEAD 请求,否则响应的实体中应当包含指向新的 URI 的超链接及简短说明。如果这不是一个 GET 或者 HEAD 请求,因此浏览器禁止自动进行重定向,除非得到用户的确认,因为请求的条件可能因此发生变化。注意:对于某些使用 HTTP/1.0 协议的浏览器,当它们发送的 POST 请求得到了一个301响应的话,接下来的重定向请求将会变成 GET 方式。302 Found请求的资源现在临时从不同的 URI 响应请求。由于这样的重定向是临时的,客户端应当继续向原有地址发送以后的请求。只有在Cache-Control或Expires中进行了指定的情况下,这个响应才是可缓存的。新的临时性的 URI 应当在响应的 Location 域中返回。除非这是一个 HEAD 请求,否则响应的实体中应当包含指向新的 URI 的超链接及简短说明。如果这不是一个 GET 或者 HEAD 请求,那么浏览器禁止自动进行重定向,除非得到用户的确认,因为请求的条件可能因此发生变化。注意:虽然RFC 1945和RFC 2068规范不允许客户端在重定向时改变请求的方法,但是很多现存的浏览器将302响应视作为303响应,并且使用 GET 方式访问在 Location 中规定的 URI,而无视原先请求的方法。状态码303和307被添加了进来,用以明确服务器期待客户端进行何种反应。303 See Other对应当前请求的响应可以在另一个 URI 上被找到,而且客户端应当采用 GET 的方式访问那个资源。这个方法的存在主要是为了允许由脚本激活的POST请求输出重定向到一个新的资源。这个新的 URI 不是原始资源的替代引用。同时,303响应禁止被缓存。当然,第二个请求(重定向)可能被缓存。新的 URI 应当在响应的 Location 域中返回。除非这是一个 HEAD 请求,否则响应的实体中应当包含指向新的 URI 的超链接及简短说明。注意:许多 HTTP/1.1 版以前的 浏览器不能正确理解303状态。如果需要考虑与这些浏览器之间的互动,302状态码应该可以胜任,因为大多数的浏览器处理302响应时的方式恰恰就是上述规范要求客户端处理303响应时应当做的。304 Not Modified如果客户端发送了一个带条件的 GET 请求且该请求已被允许,而文档的内容(自上次访问以来或者根据请求的条件)并没有改变,则服务器应当返回这个状态码。304响应禁止包含消息体,因此始终以消息头后的第一个空行结尾。该响应必须包含以下的头信息:Date,除非这个服务器没有时钟。假如没有时钟的服务器也遵守这些规则,那么代理服务器以及客户端可以自行将 Date 字段添加到接收到的响应头中去(正如RFC 2068中规定的一样),缓存机制将会正常工作。ETag 和/或 Content-Location,假如同样的请求本应返回200响应。Expires, Cache-Control,和/或 Vary,假如其值可能与之前相同变量的其他响应对应的值不同的话。假如本响应请求使用了强缓存验证,那么本次响应不应该包含其他实体头;否则(例如,某个带条件的 GET 请求使用了弱缓存验证),本次响应禁止包含其他实体头;这避免了缓存了的实体内容和更新了的实体头信息之间的不一致。假如某个304响应指明了当前某个实体没有缓存,那么缓存系统必须忽视这个响应,并且重复发送不包含限制条件的请求。假如接收到一个要求更新某个缓存条目的304响应,那么缓存系统必须更新整个条目以反映所有在响应中被更新的字段的值。305 Use Proxy被请求的资源必须通过指定的代理才能被访问。 Location 域中将给出指定的代理所在的 URI 信息,接收者需要重复发送一个单独的请求,通过这个代理才能访问相应资源。只有原始服务器才能建立305响应。注意:RFC 2068中没有明确305响应是为了重定向一个单独的请求,而且只能被原始服务器建立。忽视这些限制可能导致严重的安全后果。306 Switch Proxy在最新版的规范中,306状态码已经不再被使用。307 Temporary Redirect请求的资源现在临时从不同的 URI 响应请求。由于这样的重定向是临时的,客户端应当继续向原有地址发送以后的请求。只有在Cache-Control或Expires中进行了指定的情况下,这个响应才是可缓存的。新的临时性的 URI 应当在响应的 Location 域中返回。除非这是一个 HEAD 请求,否则响应的实体中应当包含指向新的 URI 的超链接及简短说明。因为部分浏览器不能识别307响应,因此需要添加上述必要信息以便用户能够理解并向新的 URI 发出访问请求。 如果这不是一个 GET 或者 HEAD 请求,那么浏览器禁止自动进行重定向,除非得到用户的确认,因为请求的条件可能因此发生变化。
      1xx- 信息提示这些状态代码表示临时的响应。客户端在收到常规响应之前,应准备接收一个或多个1xx响应。100-继续。101-切换协议。2xx-成功这类状态代码表明服务器成功地接受了客户端请求。200-确定。客户端请求已成功。201-已创建。202-已接受。203-非权威性信息。204-无内容。205-重置内容。206-部分内容。3xx-重定向客户端浏览器必须采取更多操作来实现请求。例如,浏览器可能不得不请求服务器上的不同的页面,或通过代理服务器重复该请求。301-对象已永久移走,即永久重定向。302-对象已临时移动。304-未修改。307-临时重定向。4xx-客户端错误发生错误,客户端似乎有问题。例如,客户端请求不存在的页面,客户端未提供有效的身份验证信息。400-错误的请求。401-访问被拒绝。IIS定义了许多不同的401错误,它们指明更为具体的错误原因。这些具体的错误代码在浏览器中显示,但不在IIS日志中显示:401.1-登录失败。401.2-服务器配置导致登录失败。401.3-由于ACL对资源的限制而未获得授权。401.4-筛选器授权失败。401.5-ISAPI/CGI应用程序授权失败。401.7–访问被Web服务器上的URL授权策略拒绝。这个错误代码为IIS6.0所专用。403-禁止访问:IIS定义了许多不同的403错误,它们指明更为具体的错误原因:403.1-执行访问被禁止。403.2-读访问被禁止。403.3-写访问被禁止。403.4-要求SSL。403.5-要求SSL128。403.6-IP地址被拒绝。403.7-要求客户端证书。403.8-站点访问被拒绝。403.9-用户数过多。403.10-配置无效。403.11-密码更改。403.12-拒绝访问映射表。403.13-客户端证书被吊销。403.14-拒绝目录列表。403.15-超出客户端访问许可。403.16-客户端证书不受信任或无效。403.17-客户端证书已过期或尚未生效。403.18-在当前的应用程序池中不能执行所请求的URL。这个错误代码为IIS6.0所专用。403.19-不能为这个应用程序池中的客户端执行CGI。这个错误代码为IIS6.0所专用。403.20-Passport登录失败。这个错误代码为IIS6.0所专用。404-未找到。404.0-(无)–没有找到文件或目录。404.1-无法在所请求的端口上访问Web站点。404.2-Web服务扩展锁定策略阻止本请求。404.3-MIME映射策略阻止本请求。405-用来访问本页面的HTTP谓词不被允许(方法不被允许)406-客户端浏览器不接受所请求页面的MIME类型。407-要求进行代理身份验证。412-前提条件失败。413–请求实体太大。414-请求URI太长。415–不支持的媒体类型。416–所请求的范围无法满足。417–执行失败。423–锁定的错误。5xx-服务器错误服务器由于遇到错误而不能完成该请求。500-内部服务器错误。500.12-应用程序正忙于在Web服务器上重新启动。500.13-Web服务器太忙。500.15-不允许直接请求Global.asa。500.16–UNC授权凭据不正确。这个错误代码为IIS6.0所专用。500.18–URL授权存储不能打开。这个错误代码为IIS6.0所专用。500.100-内部ASP错误。501-页眉值指定了未实现的配置。502-Web服务器用作网关或代理服务器时收到了无效响应。502.1-CGI应用程序超时。502.2-CGI应用程序出错。application.503-服务不可用。这个错误代码为IIS6.0所专用。504-网关超时。 --天下数据--
      如何通过HTTP状态判断服务器运营状态

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类