计算机网络协议名词解释(计算机网络名词解释汇总)

      最后更新:2023-10-11 16:17

      计算机网络协议的概念是什么,有大神能概括一下吗?

      网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。 例如,网络中一个微机用户和一个大型主机的操作员进行通信,由于这两个数据终端所用字符集不同,因此操作员所输入的命令彼此不认识。为了能进行通信,规定每个终端都要将各自字符集中的字符先变换为标准字符集的字符后,才进入网络传送,到达目的终端之后,再变换为该终端字符集的字符。当然,对于不相容终端,除了需变换字符集字符外还需转换其他特性,如显示格式、行长、行数、屏幕滚动方式等也需作相应的变换。
      在计算机网络中,为使计算机之间或计算机与终端设备之间能有序而准确的传送数据,必须在数据传输顺序、格式和内容等方面有统一的标准、约定或规则,这组标准、约定或规则称为计算机网络协议。 参考资料:《大学计算机-计算思维导论》,清华大学出版社2019
      在计算机网络中要做到有条不紊的交换、传递数据,就必须遵守一些事先约定好的 数据格式、同步问题等,我们把这些在计算机之间实现通信要遵守的有关规则称为计算机网 络协议。
      这上面回答你的,应该都是直接百度的吧,谁能一句话说清楚的,好想膜拜
      这个问题,估计你直接百度会有很全面的答案
      计算机网络协议的概念是什么,有大神能概括一下吗?

      计算机网络的协议是什么?

      计算机协议,也叫作网络协议,是通信计算机双方必须共同遵从的一组约定。为了使数据在网络上从源到达目的,网络通信的参与方必须遵循相同的规则,这套规则称为协议,它最终体现为在网络上传输的数据包的格式。最常见的计算机协议是OSI/RM协议。国际标准化组织(ISO)在1978年提出了“开放系统互联参考模型”,即著名的OSI/RM模型。它将计算机网络体系结构的通信协议划分为七层,自下而上依次为:物理层、数据链路层、网络层、传输层、会话层、表示层、应用层。其中第四层完成数据传送服务,上面三层面向用户。扩展资料常见的计算机协议还有:1、IPX/SPX协议是Novell开发的专用于NetWare网络中的协议,但是也非常常用。大部分可以联机的游戏都支持IPX/SPX协议,比如星际争霸,反恐精英等等。2、ARP/RARP协议地址解析协议,原理是主机发送信息时将包含目标IP地址的ARP请求广播到网络上的所有主机,并接收返回消息,以此确定目标的物理地址;收到返回消息后将该IP地址和物理地址存入本机ARP缓存中并保留一定时间,下次请求时直接查询ARP缓存以节约资源。3、TCP/IP协议是Internet最基本的协议、Internet国际互联网络的基础,由网络层的IP协议和传输层的TCP协议组成。通俗而言:TCP负责发现传输的问题,一有问题就发出信号,要求重新传输,直到所有数据安全正确地传输到目的地。而IP是给因特网的每一台联网设备规定一个地址。参考资料来源:百度百科-协议
      刚才说过网络体系结构的关键要素之一就是网络协议。而所谓协议(Protocol)就是对数据格式和计算机之间交换数据时必须遵守的规则的正式描述,它的作用和普通话的作用如出一辙。依据网络的不同通常使用Ethernet(以太网)、NetBEUI、IPX/SPX以及TCP/IP协议。Ethernet是总线型协议中最常见的网络低层协议,安装容易且造价便宜;而NetBEUI可以说是专为小型局域网设计的网络协议。对那些无需跨经路由器与大型主机通信的小型局域网,安装NetBEUI协议就足够了,但如果需要路由到另外的局域网,就必须安装IPX/SPX或TCP/IP协议。前者几乎成了Novell网的代名词,而后者就被著名的Internet网所采用。
      计算机网络的协议是什么?

      简述计算机网络协议

      网络协议概述 在网络的各层中存在着许多协议,它是定义通过网络进行通信的规则,接收方的发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息,以这种规则规定双方完成信息在计算机之间的传送过程。 要使服务器支持远程启动服务,必须在服务器上安装DLC(Data Link Control)和NetBEUI(NetBIOS Extended User Interface)协议,并确保工作站能用这些协议与服务器通讯。 DLC不同于NT中的其它协议如NetBEUI和TCP/IP,DLC协议并不在OSI参考模型的网络层和传输层发挥作用,而是向较高层提供了一个与数据链路层的直接接口。使用DLC,可使得NT计算机可以运行访问主机系统的软件,使得NT计算机作为直连网络的打印机的打印服务器。通常我们不把DLC作为PC和PC的通信的主协议。NetBIOS扩展用户接口协议(NetBEUI)最初由IBM于1995年开发的,被优化为在用于非常高的性能,在一个LAN分段里的通信。NetBEUI是NT发行的协议中速度最快的一种协议之一。它还具有良好的错误保护,占用很少的内存,但它不支持路由选择且跨WAN的性能很差。 而TCP/IP则成为当前应用协议中无可非议的标准。
      ·DHCP(动态主机分配协议) · DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议
      计算机网络协议:网络协议就是计算机之间进行通信的规则。为了使处于不同地点、装有不同操作系统的计算机之间有效地通信,必须有一种为各类计算机都能认可的通信方法,任一方所表达的信息均能被其他各方所认同,这就需要指定一种标准:网络协议。 就象老师在讲课时为了大家都能听懂,就必须使用普通话一样。最常用的协议有TCP/IP协议。
      简述计算机网络协议

      名词解释:计算机网络通信协议,希望专业点哦

      网络协议的定义:为计算机网络中进行数据交换而建立的规则、标准或约定的集合。例如,网络中一个微机用户和一个大型主机的操作员进行通信,由于这两个数据终端所用字符集不同,因此操作员所输入的命令彼此不认识。为了能进行通信,规定每个终端都要将各自字符集中的字符先变换为标准字符集的字符后,才进入网络传送,到达目的终端之后,再变换为该终端字符集的字符。当然,对于不相容终端,除了需变换字符集字符外。其他特性,如显示格式、行长、行数、屏幕滚动方式等也需作相应的变换。 常用的网络协议一:NETBEUI   NETBEUI是为IBM开发的非路由协议,用于携带NETBIOS通信。NETBEUI缺乏路由和网络层寻址功能,既是其最大的优点,也是其最大的缺点。因为它不需要附加的网络地址和网络层头尾,所以很快并很有效且适用于只有单个网络或整个环境都桥接起来的小工作组环境。   因为不支持路由,所以NETBEUI永远不会成为企业网络的主要协议。NETBEUI帧中唯一的地址是数据链路层媒体访问控制(MAC)地址,该地址标识了网卡但没有标识网络。路由器靠网络地址将帧转发到最终目的地,而NETBEUI帧完全缺乏该信息。   网桥负责按照数据链路层地址在网络之间转发通信,但是有很多缺点。因为所有的广播通信都必须转发到每个网络中,所以网桥的扩展性不好。NETBEUI特别包括了广播通信的记数并依赖它解决命名冲突。一般而言,桥接NETBEUI网络很少超过100台主机。   近年来依赖于第二层交换器的网络变得更为普遍。完全的转换环境降低了网络的利用率,尽管广播仍然转发到网络中的每台主机。事实上,联合使用100-BASE-T Ethernet,允许转换NetBIOS网络扩展到350台主机,才能避免广播通信成为严重的问题。   二:IPX/SPX   IPX是NOVELL用于NETWARE客户端/服务器的协议群组,避免了NETBEUI的弱点。但是,IPX具有完全的路由能力,可用于大型企业网。它允许有许多路由网络。包括32位网络地址,在单个环境中带来了新的不同弱点。   IPX的可扩展性受到其高层广播通信和高开销的限制。服务广告协议(ServiceAdvertising Protocol,SAP)将路由网络中的主机数限制为几千。尽管SAP的局限性已经被智能路由器和服务器配置所克服,但是,大规模IPX网络的管理员仍是非常困难的工作。   三:TCP/IP   每种网络协议都有自己的优点,但是只有TCP/IP允许与Internet完全的连接。TCP/IP是在60年代由麻省理工学院和一些商业组织为美国国防部开发的,即便遭到核攻击而破坏了大部分网络,TCP/IP仍然能够维持有效的通信。ARPANET就是由基于协议开发的,并发展成为作为科学家和工程师交流媒体的Internet。   TCP/IP同时具备了可扩展性和可靠性的需求。不幸的是牺牲了速度和效率(可是:TCP/IP的开发受到了政府的资助)。   Internet公用化以后,人们开始发现全球网的强大功能。Internet的普遍性是TCP/IP至今仍然使用的原因。常常在没有意识到的情况下,用户就在自己的PC上安装了TCP/IP栈,从而使该网络协议在全球应用最广。   TCP/IP的32位寻址功能方案不足以支持即将加入Internet的主机和网络数。因而可能代替当前实现的标准是IPv6。参考http://baike.baidu.com/view/860535.htm
      网络通信协议(Network Communication Protocol,通常简称为“网络协议”(Network Protocol))就是对计算机之间通信的信息格式、能被收/发双方接受的传送信息内容的一组定义。为了实现OSI七层参考模型功能,各层都有许多负责各个不同方面,解决不同问题的通信协议,如有物理层中的物理接口通信协议(如RS-232、RS-449和V.35等),数据链路层的数据链接协议(如CSMA/CD、SDLC和HDLC等),网络层则有许多路由层协议(如IP、RIP、OSPF和IGRP等),传输层则有许多传输控制协议(如TCP、FTP和TFFP等),同样会话层、表示层和应用都有许多相应的的网络协议(如应用层的POP3、SMTP、SNMP和DNS等)。就是在这些许许多多的通信协议的共同作用下,网络的七层模型才能全部正常工作,确保网络通信的正常。
      名词解释:计算机网络通信协议,希望专业点哦

      什么是计算机网络协议?为什么需要网络协议?

      计算机网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。例如,网络中一个微机用户和一个大型主机的操作员进行通信,由于这两个数据终端所用字符集不同,因此操作员所输入的命令彼此不认识。为了能进行通信,规定每个终端都要将各自字符集中的字符先变换为标准字符集的字符后,才进入网络传送,到达目的终端之后,再变换为该终端字符集的字符。对于不相容终端,除了需变换字符集字符外还需转换其他特性。扩展资料由于网络节点之间联系的复杂性,在制定协议时,通常把复杂成分分解成一些简单成分,然后再将它们复合起来。最常用的复合技术就是层次方式,网络协议的层次结构如下:1、结构中的每一层都规定有明确的服务及接口标准;2、把用户的应用程序作为最高层;3、除了最高层外,中间的每一层都向上一层提供服务,同时又是下一层的用户;4、把物理通信线路作为最低层,它使用从最高层传送来的参数,是提供服务的基础。参考资料来源:百度百科——网络协议
      网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。例如,网络中一个微机用户和一个大型主机的操作员进行通信,由于这两个数据终端所用字符集不同,因此操作员所输入的命令彼此不认识。为了能进行通信,就像我们说话用某种语言一样,在网络上的各台计算机之间也有一种语言,因为不同的计算机之间必须使用相同的网络协议才能进行通信。扩展资料多数网络都采用分层的体系结构,每一层都建立在它的下层之上,向它的上一层提供一定的服务,而把如何实现这一服务的细节对上一层加以屏蔽。一台设备上的第 n层与另一台设备上的第n层进行通信的规则就是第n层协议。在网络的各层中存在着许多协议,接收方和发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息。网络协议使网络上各种设备能够相互交换信息。网络协议是由语义、语法、时序三个要素组成参考资料来源:百度百科-计算机网络协议
      网络上的计算机之间又是如何交换信息的呢?就像我们说话用某种语言一样,在网络上的各台计算机之间也有一种语言,这就是网络协议,不同的计算机之间必须使用相同的网络协议才能进行通信。 网络协议是网络上所有设备(网络服务器、计算机及交换机、路由器、防火墙等)之间通信规则的集合,它规定了通信时信息必须采用的格式和这些格式的意义。大多数网络都采用分层的体系结构,每一层都建立在它的下层之上,向它的上一层提供一定的服务,而把如何实现这一服务的细节对上一层加以屏蔽。一台设备上的第 n层与另一台设备上的第n层进行通信的规则就是第n层协议。在网络的各层中存在着许多协议,接收方和发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息。网络协议使网络上各种设备能够相互交换信息。常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议等。在局域网中用得的比较多的是IPX/SPX.。用户如果访问Internet,则必须在网络协议中添加TCP/IP协议。TCP/IP是“transmission Control Protocol/Internet Protocol”的简写,中文译名为传输控制协议/互联网络协议)协议, TCP/IP(传输控制协议/网间协议)是一种网络通信协议,它规范了网络上的所有通信设备,尤其是一个主机与另一个主机之间的数据往来格式以及传送方式。TCP/IP是INTERNET的基础协议,也是一种电脑数据打包和寻址的标准方法。在数据传送中,可以形象地理解为有两个信封,TCP和IP就像是信封,要传递的信息被划分成若干段,每一段塞入一个TCP信封,并在该信封面上记录有分段号的信息,再将TCP信封塞入IP大信封,发送上网。在接受端,一个TCP软件包收集信封,抽出数据,按发送前的顺序还原,并加以校验,若发现差错,TCP将会要求重发。因此,TCP/IP在INTERNET中几乎可以无差错地传送数据。 对普通用户来说,并不需要了解网络协议的整个结构,仅需了解IP的地址格式,即可与世界各地进行网络通信。IPX/SPX是基于施乐的XEROX’S Network System(XNS)协议,而SPX是基于施乐的XEROX’S SPP(Sequenced Packet Protocol:顺序包协议)协议,它们都是由novell公司开发出来应用于局域网的一种高速协议。它和TCP/IP的一个显著不同就是它不使用ip 地址,而是使用网卡的物理地址即(MAC)地址。在实际使用中,它基本不需要什么设置,装上就可以使用了。由于其在网络普及初期发挥了巨大的作用,所以得到了很多厂商的支持,包括microsoft等,到现在很多软件和硬件也均支持这种协议。NetBEUI即NetBios Enhanced User Interface ,或NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用,例如Windows for Workgroup、Win 9x系列、Windows NT等。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。总之NetBEUI协议是一种短小精悍、通信效率高的广播型协议,安装后不需要进行设置,特别适合于在“网络邻居”传送数据。所以建议除了TCP/IP协议之外,局域网的计算机最好也安上NetBEUI协议。另外还有一点要注意,如果一台只装了TCP/IP协议的WINDOWS98机器要想加入到WINNT域,也必须安装NetBEUI协议。网络上的计算机之间又是如何交换信息的呢?就象我们说话用某种语言一样,在网络上的各台计算机之间也有一种语言,这就是网络协议,不同的计算机之间必须使用相同的网络协议才能进行通信。当然了,网络协议也有很多种,具体选择哪一种协议则要看情况而定。Internet上的计算机使用的是TCP/IP协议。ARPANET网成功的主要原因是因为它使用了TCP/IP标准网络协议,TCP/IP(Transmission Control Protocol/Internet Protocol)----传输控制协议/互连网协议是Internet采用的一种标准网络协议。它是由ARPA于1977年到1979年推出的一种网络体系结构和协议规范。随着Internet网的发展,TCP/IP也得到进一步的研究开发和推广应用,成为Internet网上的"通用语言"。一个网络协议至少包括三要素:语法 用来规定信息格式;语义 用来说明通信双方应当怎么做;时序 详细说明事件的先后顺序。网际层协议:包括:IP协议、ICMP协议、ARP协议、RARP协议。传输层协议:TCP协议、UDP协议。应用层协议:FTP、Telnet、SMTP、HTTP、RIP、NFS、DNS。可以简单的把计算机网络协议理解成一种语音、一种规则、一种法律。是使计算机之间起到沟通、协作和相互规范作用的。 欢迎一起学习网络技术,可以加我好友,以便日后切磋!
      什么是计算机网络协议?为什么需要网络协议?

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类