计算机网络协议名词解释(计算机考试名词解释大全)

      最后更新:2023-11-03 17:45

      简述计算机网络协议

      网络协议概述 在网络的各层中存在着许多协议,它是定义通过网络进行通信的规则,接收方的发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息,以这种规则规定双方完成信息在计算机之间的传送过程。 要使服务器支持远程启动服务,必须在服务器上安装DLC(Data Link Control)和NetBEUI(NetBIOS Extended User Interface)协议,并确保工作站能用这些协议与服务器通讯。 DLC不同于NT中的其它协议如NetBEUI和TCP/IP,DLC协议并不在OSI参考模型的网络层和传输层发挥作用,而是向较高层提供了一个与数据链路层的直接接口。使用DLC,可使得NT计算机可以运行访问主机系统的软件,使得NT计算机作为直连网络的打印机的打印服务器。通常我们不把DLC作为PC和PC的通信的主协议。NetBIOS扩展用户接口协议(NetBEUI)最初由IBM于1995年开发的,被优化为在用于非常高的性能,在一个LAN分段里的通信。NetBEUI是NT发行的协议中速度最快的一种协议之一。它还具有良好的错误保护,占用很少的内存,但它不支持路由选择且跨WAN的性能很差。 而TCP/IP则成为当前应用协议中无可非议的标准。
      ·DHCP(动态主机分配协议) · DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议
      计算机网络协议:网络协议就是计算机之间进行通信的规则。为了使处于不同地点、装有不同操作系统的计算机之间有效地通信,必须有一种为各类计算机都能认可的通信方法,任一方所表达的信息均能被其他各方所认同,这就需要指定一种标准:网络协议。 就象老师在讲课时为了大家都能听懂,就必须使用普通话一样。最常用的协议有TCP/IP协议。
      简述计算机网络协议

      16.什么是计算机网络协议

      目前网络协议有许多种,但是最基本的协议是TCP/IP协议,许多协议都是它的子协议。下面我们就对TCP/IP协议作一下简单介绍。1  TCP/IP协议基础TCP/IP协议包括两个子协议:一个是TCP协议(Transmission Control Protocol,传输控制协议),另一个是IP协议(Internet Protocol,互联网协议),它起源于20世纪60年代末。在TCP/IP协议中,TCP协议和IP协议各有分工。TCP协议是IP协议的高层协议,TCP在IP之上提供了一个可靠的,连接方式的协议。TCP协议能保证数据包的传输以及正确的传输顺序,并且它可以确认包头和包内数据的准确性。如果在传输期间出现丢包或错包的情况,TCP负责重新传输出错的包,这样的可靠性使得TCP/IP协议在会话式传输中得到充分应用。IP协议为TCP/IP协议集中的其它所有协议提供“包传输”功能,IP协议为计算机上的数据提供一个最有效的无连接传输系统,也就是说IP包不能保证到达目的地,接收方也不能保证按顺序收到IP包,它仅能确认IP包头的完整性。最终确认包是否到达目的地,还要依靠TCP协议,因为TCP协议是有连接服务。在计算机服务中如果按连接方式来分的话,可分为“有连接服务”和“无连接服务”两种。“有连接服务”必须先建立连接才能提供相应服务,而“无连接服务”则不需先建立连接。TCP协议是一种典型的有连接协议,而UDP协议则是典型的无连接服务。TCP/IP协议所包括的协议和工具TCP/IP协议是一组网络协议的集合,它主要包括以下几方面的协议和工具。·TCP/IP协议核心协议这些核心协议除了自身外,还包括用户数据报协议(UDP协议)、地址代理协议(ARP协议)以及网间控制协议(ICMP协议)。这组协议提供了一系列计算机互连和网络互连的标准协议。·应用接口协议这类协议主要包括Windows套接字(Socket,用于开发网络应用程序)、远程调用、NetBIOS协议(用于建立逻辑名和网络上的会话)和网络动态数据交换(Network,用于通过网络共享嵌入在文本中的信息)。·基本的TCP/IP协议互连应用协议主要包括finger、ftp、rep、rsh、telnet、tftp等协议。这些工具协议使得Windows系统用户使用非Microsoft系统计算机上(如UNIX系统计算机)的资源成为可能。·TCP/IP协议诊断工具这些工具包括arp、hostname、ipconfig、nbstat、netstat、ping和route,它们可用来检测并恢复TCP/IP协议网络故障。·有关服务和管理工具这些服务和管理工具包括FTP服务器服务(用于在两个远程计算机之间传输文件,这是远程控制通信中的关键功能)、网际命名服务WINS(用于在一个网际上动态记录和询问计算机的名字)、动态计算机配置协议DHCP(用于在Windows NT计算机上自动配置TCP/IP协议)以及TCP/IP协议打印(主要用于远程打印和网络打印)。·简单网络管理协议代理(SNMP)这个工具允许通过使用管理工具(如“Sun Net Manages” 或“HP Open View”),从远程管理Windows NT计算机。(2)TCP/IP的主要协议简述为了使读者能全面了解一些基本的网络通信协议和服务,本节就对TCP/IP协议所包括的几种主要协议进行简要说明。·远程登录协议(Telnet)Telnet协议是用来登录到远程计算机上,并进行信息访问,通过它可以访问所有的数据库、联机游戏、对话服务以及电子公告牌,如同与被访问的计算机在同一房间中工作一样,但只能进行些字符类操作和会话。·文件传输协议(Ftp)这是文件传输的基本协议,有了FTP协议就可以把的文件进行上传,也可从网上得到许多应用程序和信息(下载),有许多软件站点就是通过FTP协议来为用户提供下载任务的,俗称“FTP服务器”。最初的FTP程序是工作在UNIX系统下的,而目前的许多FTP程序是工作在Windows系统下的。FTP程序除了完成文件的传送之外,还允许用户建立与远程计算机的连接,登录到远程计算机上,并可在远程计算机上的目录间移动。·电子邮件服务(Email)电子邮件服务是目前最常见、应用最广泛的一种到联网服务。通过电子邮件,可以与Internet上的任何人交换信息。电子邮件的快速、高效、方便以及价廉,越来越得到了广泛的应用,目前只要是上过网的网民就肯定用过电子邮件这种服务。目前,全球平均每天约有几千万份电子邮件在网上传输。·WWW服务WWW服务(3W服务)也是目前应用最广的一种基本互联网应用,我们每天上网都要用到这种服务。通过WWW服务,只要用鼠标进行本地操作,就可以到达世界上的任何地方。由于WWW服务使用的是超文本链接(HTML),所以可以很方便的从一个信息页转换到另一个信息页。它不仅能查看文字,还可以欣赏图片、音乐、动画。最流行的WWW服务的程序就是微软的IE浏览器。·简单邮件传输协议(SMTP)SMTP是TCP/IP协议族的一个成员,这种协议认为你的计算机是永久连接在Internet上的,而且认为你在网络上的计算机在任何时候是可以被访问的。它适用于永久连接在Internet的计算机,但无法使用通过SLIP/PPP协议连接的用户接收电子邮件。解决这个问题的办法是在邮件计算机上同时运行SMTP和POP协议的程序,SMTP负责邮件的发送和在邮件计算机上的分拣和存储,POP协议负责将邮件通过SLIP/PPP协议连接传送到用户计算机上。·信息服务(Gopher)Gopher最早出现在1991年,它是第一个操作简便、使用广泛的从Internet服务器上获取信息的客户应用程序。除了操作简便外,它的另一个特点是速度快。Gopher运行时,将显示一个交互式的供用户选择的菜单,菜单中的选项由简单的短句组成,每个短句通常指向另一个菜单,并最终指向有用的文件。Gopher是帮助用户在Internet信息海洋中搜索有用信息的导航器。用户只要关心浏览的内容,而不必关心具体的服务器。·文件检索服务(Archie)它是一个从整个Internet上匿名FTP服务器获取文件的服务。其完全依赖于匿名FTP系统的管理员,他们将站点在全世界的Archie服务器进行了注册,Archie仅通过文件名进行检索。2 IP协议目前正在使用的IP协议是第4版的,称之为“IPv4”,新版本的IP协议正在完善过程中,它就是经常可以在各大IT媒体中见到的IPv6。IPv6所要解决的主要是IPv4协议中IP地址远远不够的现象。IPv4所采用的是32位,而IPv6则是128位,是原来的4倍。IPv6所提供的IP地址数已可算是天文数字了,据专家们分析,这个数字的IP地址可以使全球的每一个人都可拥有10以上的IP地址,这么多的IP地址相信再也不会出现IPv4那样除了美国外,各国都出现IP地址短缺现象,为将来实现移动上网打下了坚实的基础。但这属于较新技术,在此就不作详细介绍,本文仍以目前主流的IPv4协议为基础进行介绍。IP协议的功能是把数据报在互联的网络上传送,通过将数据报在一个个IP协议模块间传送,直到目的模块。网络中每个计算机和网关上都有IP协议模块。数据报在一个个模块间通过路由处理网络地址传送到目的地址,因此搜寻网络地址对于IP协议十分重要的功能。另外,因为各个网络上的数据报大小可能不同,所以数据报的分段也是IP协议的不可或缺的功能,不然对于一些网络带宽较窄的网络,大的数据报就无法正确传输了。下面主要介绍我们初级学者所关心的现行方面问题。(1)IP地址在计算机寻址中经常会遇到“名字”、“地址”和“路由”这三个术语,它们之间是有较大区别的。名字是要找的,就像的人名一样;而地址是用来指出这个名字在什么地方,就像人的住址一样;路由是解决如何到达目的地址的问题,就像已经知道了某个人住在什么地方,现在要考虑走什么路线、采用什么交通工具到达目的地方最为简便。这里所介绍的IP协议主要是解决地址的问题。名字和地址进行解析的工作是由其上层协议--TCP协议完成。IP协议模块将地址和本地网络地址加以映射(就像写信一样,IP协议只负责把收、发信人的地址写上,把信投进邮箱就可不管了),而将本地网络地址和路由进行映射则是低层协议(如路由协议)的任务,所以说IP协议是一个无连接的服务。IP协议要寻找的“地址”是32位长(4个分段的16进制组成),由网络号(网络ID)和主机号(主机ID)两部分构成,按照IP协议规定因特网上的地址共有A、B、C、D、E五类.按照IP协议规定因特网上的地址共有A、B、C、D、E五类·A类IP地址:用前面8位来标识网络号,其中规定最前面一位为“0”,24位标识主机地址,即A类地址的第一段取值(也即网络号)可以是“00000001 ̄01111111”之间任一数字,转换为十进制后即为1~128之间。主机号没有做硬性规定,所以它的IP地址范围为“1.0.0.0-128.255.255.255”。A类地址是为大型政府网络而提供,因为A地址中有10.0.0.0-10.255.255.254和127.0.0.0-127.255.255.254这两段地址有专门用途,所以全世界总共只有126个可能的A类网络。每个A类网络最多可以连接16777214台计算机,这类地址数是最少的,但这类网络所允许连接的计算机是最多的。·B类IP地址:用前面16位来标识网络号,其中最前面两位规定为“10”,16位标识主机号,也就是说B类地址的第一段“10000000 ̄10111111”,转换成十进制后即为128~191之间,第一段和第二段合在一起表示网络地址,它的地址范围为“128.0.0.0-191.255.255.255”。B类地址适用于中等规模的网络,全世界大约有16000个B类网络,每个B类网络最多可以连接65534台计算机。这类IP地址通常为中等规模的网络提供。其中172.16.0.0-172.31.255.254地址段有专门用途。·C类IP地址:用前面24位来标识网络号,其中最前面三位规定为“110”,8位标识主机号。这样C类地址的第一段取值为“11000000 ̄11011111”之间,转换成十进制后即为192~223。第一段、第二段、第三段合在一起表示网络号,最后一段标识网络上的主机号,它的地址范围为“192.0.0.0-223.255.255.255”。C类地址适用于校园网等小型网络,每个C类网络最多可以有254台计算机。这类地址是所有的地址类型中地址数最多的,但这类网络所允许连接的计算机是最少的。这类IP地址可分配给任何有需要的人。其中192.168.0.0-192.168.255.255为企业局域网专用地址段。·D类地址:它用于多重广播组,一个多重广播组可能包括1台或更多主机,或根本没有。D类地址的最高位为1110,第一段八位体为“11100000 ̄11101111”,转换成十进制即为224 ̄239,剩余的位设计客户机参加的特定组,它的地址范围为“224.0.1.1-239.255.255.255”。在多重广播操作中没有网络或主机位,数据包将传送到网络中选定的主机子集中,只有注册了多重广播地址的主机才能接收到数据包。Microsoft支持D类地址,用于应用程序将多重广播数据发送到网络间的主机上,包括WINS和Microsoft NetShow。·E类地址:这是一个通常不用的实验性地址,保留作为以后使用。E类地址的最高位为11110,第一段八位体为“11110000 ̄11110111”,转换成十进制即为240 ̄247。IPv4协议中对首段位为248 ̄254 的地址段暂无规定。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。其实还有一类IP地址,就是以“127”开头的IP地址,这类IP地址也是属于保留使用的,这类地址属于环路测试类IP地址。这类IP地址不能作为计算机的IP地址用,也就不能在网络上使用这样的IP地址来标识计算机的位置,更不能通过在浏览器或者其他搜索位置输入这样的IP地址,来搜索想要查找的计算机,因为它只能在本地计算机上用于测试使用。(2) 子网掩码和域名以上介绍的是网络IP地址,但随着网络的发展,IPv4标准中的IP地址远不够用,为了解决这一矛盾,于是又在IP地址加上子网掩码来进一步识别。在TCP/IP协议中规定,A类网络的子网掩码格式为“255.0.0.0”形式,后面的“0”可以为“0 ̄254”之间任一数字。B类网络的子网掩码格式为“255.255.0.0”,C类网络的子网掩码为格式为“255.255.255.0”,同样其中的“0”可以是“0 ̄254”之间任一数字。如果没有子网,可以为“0”,也可以不配置,如果有子网则一定要配置。前面介绍的IP地址都是以数字形式表示计算机的地址,这种IP地址人们记忆起来是非常困难的。对非计算机和网络的专业人士来说,记住这种地址是很不现实的。因此,Internet还采用域名地址来表示每台计算机。通过为每台计算机建立IP地址与域名地址之间的映射关系,用户可以在网上避开难以记忆的IP地址,而用域名地址来唯一标记网上的计算机。域名地址与IP地址的关系类似于一个人的姓名与身份证号码之间的关系。要把计算机连入Internet,必须获得网上唯一的IP地址与对应的域名地址。域名地址由域名系统(DNS)管理。每个连到Internet的网络中都有至少一个DNS服务器,其中存有该网络中所有计算机的域名和对应的IP地址,通过与其他网络的DNS服务器相连就可以找到其他站点。这也是在TCP/IP协议属性中要进行DNS配置的原因。域名地址也是分段表示的,每段分别授权给不同的机构管理,各段之间用圆点(.)分隔。与IP地址相反,各段自左至右级别是越来越高。
      16.什么是计算机网络协议

      计算机网络的协议是什么?

      计算机协议,也叫作网络协议,是通信计算机双方必须共同遵从的一组约定。为了使数据在网络上从源到达目的,网络通信的参与方必须遵循相同的规则,这套规则称为协议,它最终体现为在网络上传输的数据包的格式。最常见的计算机协议是OSI/RM协议。国际标准化组织(ISO)在1978年提出了“开放系统互联参考模型”,即著名的OSI/RM模型。它将计算机网络体系结构的通信协议划分为七层,自下而上依次为:物理层、数据链路层、网络层、传输层、会话层、表示层、应用层。其中第四层完成数据传送服务,上面三层面向用户。扩展资料常见的计算机协议还有:1、IPX/SPX协议是Novell开发的专用于NetWare网络中的协议,但是也非常常用。大部分可以联机的游戏都支持IPX/SPX协议,比如星际争霸,反恐精英等等。2、ARP/RARP协议地址解析协议,原理是主机发送信息时将包含目标IP地址的ARP请求广播到网络上的所有主机,并接收返回消息,以此确定目标的物理地址;收到返回消息后将该IP地址和物理地址存入本机ARP缓存中并保留一定时间,下次请求时直接查询ARP缓存以节约资源。3、TCP/IP协议是Internet最基本的协议、Internet国际互联网络的基础,由网络层的IP协议和传输层的TCP协议组成。通俗而言:TCP负责发现传输的问题,一有问题就发出信号,要求重新传输,直到所有数据安全正确地传输到目的地。而IP是给因特网的每一台联网设备规定一个地址。参考资料来源:百度百科-协议
      刚才说过网络体系结构的关键要素之一就是网络协议。而所谓协议(Protocol)就是对数据格式和计算机之间交换数据时必须遵守的规则的正式描述,它的作用和普通话的作用如出一辙。依据网络的不同通常使用Ethernet(以太网)、NetBEUI、IPX/SPX以及TCP/IP协议。Ethernet是总线型协议中最常见的网络低层协议,安装容易且造价便宜;而NetBEUI可以说是专为小型局域网设计的网络协议。对那些无需跨经路由器与大型主机通信的小型局域网,安装NetBEUI协议就足够了,但如果需要路由到另外的局域网,就必须安装IPX/SPX或TCP/IP协议。前者几乎成了Novell网的代名词,而后者就被著名的Internet网所采用。
      计算机网络的协议是什么?

      (协议)在计算机网络中的名词解释

      为了使数据在网络上从源到达目的,网络通信的参与方必须遵循相同的规则,这套规则称为协议(protocol),它最终体现为在网络上传输的数据包的格式。 它的三要素是:语法、语义、时序。
      (协议)在计算机网络中的名词解释

      计算机网络协议的概念是什么,有大神能概括一下吗?

      网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。 例如,网络中一个微机用户和一个大型主机的操作员进行通信,由于这两个数据终端所用字符集不同,因此操作员所输入的命令彼此不认识。为了能进行通信,规定每个终端都要将各自字符集中的字符先变换为标准字符集的字符后,才进入网络传送,到达目的终端之后,再变换为该终端字符集的字符。当然,对于不相容终端,除了需变换字符集字符外还需转换其他特性,如显示格式、行长、行数、屏幕滚动方式等也需作相应的变换。
      在计算机网络中,为使计算机之间或计算机与终端设备之间能有序而准确的传送数据,必须在数据传输顺序、格式和内容等方面有统一的标准、约定或规则,这组标准、约定或规则称为计算机网络协议。 参考资料:《大学计算机-计算思维导论》,清华大学出版社2019
      在计算机网络中要做到有条不紊的交换、传递数据,就必须遵守一些事先约定好的 数据格式、同步问题等,我们把这些在计算机之间实现通信要遵守的有关规则称为计算机网 络协议。
      这上面回答你的,应该都是直接百度的吧,谁能一句话说清楚的,好想膜拜
      这个问题,估计你直接百度会有很全面的答案
      计算机网络协议的概念是什么,有大神能概括一下吗?

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类