18,什么是路由选择算法和路由选择协议
-路由选择协议(Routing Protocols): 用于建立和维护路由表和按照达到数据包的目的地的最佳路径转发数据数据包的协议。比如,RIPV1,IGRP,OSPF等。 路由选择算法就是路由选择协议用于决定达到目的网络的最佳路径的计算方法。路由选择算法越简单,则路由器将使用的处理能力就越小。这将减少路由器的日常费用。

典型的路由选择协议是什么?rip是以什么来衡量路由最佳的?
典型的路由协议有rip,ospf,isis,bgp等。rip是用经过的路由器跳数来衡量的,最少的跳数就是最优路由。

路由协议有哪些
一般路由器支持多种等。这些路由选择协议可分为有路由选择协议,例如静态路由、RIP类路由选择协议和无类路由选择协议、IGRP、RIPv2、EIGRP、OSPF和BGP等。----1.有类路由选择协议----一般把路由信息协议由选择协议中,只在路由器之间各路由器通过下面2种方法判定(RIP)和内部网关路由选择协议(I传送路由和它的度量值,对每个转发目的地网络掩码。GRP)等称为有类路由协议。在有类路报文,路由器从报文中取出目的地址,----(1)如果有一个接口连到目的地网络,须相同。则使用此接口的网络掩码。隶属网络的所有子网的大小必----(2)否则,使用对应目的地址类的网络网络使用24位掩码。掩码。A类网络使用8位掩码,B类网络使用16位掩码,C类----根据设置掩码的规则,转发报文。因为路由选择基于端网络使用的掩码,从而决定目,除去目的地址中的“局部操纵”位IP地址类(有A类、B类、C类和D类等的地的网络地址,故此类路由选择协,在路由选择表中查寻产生的网络地址4类)或与之相连的网络接口来决定远议被称为有类路由选择协议。----2.无类路由选择协议----RIPv2、EIGRP、OSPF和BGP等是一些比较与路径一起广播出去,这时网络掩码也称为前缀屏为255.255.255.0,可标识为192.168.1.0/24。由址类型和缺省掩码,这就是无类地址及无类路由选新的路由选择协议,它们在路由更新过程中,将网络掩码蔽或前缀。例如,如果C类IP地址192.168.1.0的网络掩码于在路由器之间传送掩码(前缀),因而没有必要判断地择,也是目前Internet上所基于的路由选择协议。----在无类路由中,IP地都由前缀来决定用于网络标识的码对。通过使用无类路由,用户外,新的IP编址标准IPv6也使用的是,通过使用无类路由协议,网化。址之间不再有类型差别,如A类地址位数,IP地址不再归属于某一个类,可以更充分地利用已有的IP地址空间无类路由协议,通过使用无类路由,用户在子网化时非常方便,尤其是可、B类地址或C类地址等之分,所有地址取而代之的是将它们看作一个地址和掩,从而避免浪费宝贵的IP地址资源。

RIP路由选择协议
典型的路由协议有rip,ospf,isis,bgp等。rip是用经过的路由器跳数来衡量的,最少的跳数就是最优路由。 RIP共有三个版本,RIPv1, RIPv2, RIPng其中RIPV1和RIPV2是用在IPV4的网络环境里,RIPng是用在IPV6的网络环境里。 因为RIPv1的缺陷,RIPv2在1994年被提出,将子网络的资讯包含在内,透过这样的方式提供无类别域间路由,不过对于最大节点数15的这个限制仍然被保留着。另外针对安全性的问题,RIPv2也提供一套方法,透过加密来达到认证的效果。而之后[RFC 2082 ]也定义了利用MD5来达到认证的方法。 RIPv2的相关规定在[RFC 2453 ] orSTD56。现今的IPv4网络中使用的大多是RIPv2,RIPv2是在RIPv1基础上的改进, RIPv2和RIPv1相比主要有以下区别。RIPng(Routing Information Protocol next generation)则被定义在[RFC 2080 ],主要是针对IPv6做一些延伸的规范。与RIPv2相比下其最主要的差异是:RIPv2 支持RIP更新认证, RIPng 则没有 (IPv6 routers were, at the time, supposed to use IPsec for authentication);RIPv2 容许附上arbitrary 的标签, RIPng 则不容许;RIPv2 encodes the next-hop into each route entries, RIPng requires specific encoding of the nexthop for a set of route entries. RIPv2 UDP的Port number 为 520,RIPng UDP的Port number 为 521

什么是路由选择协议
当两台非直接连接的计算机需要经过几个网络通信时,通常就需要路由器。路由器提供一种方法来开辟通过一个网状联结的路径。在图R-9中标示了几条存在于洛杉矶和纽约办公室的路径。这种网状网络提供了冗余路径以调整通信负载或倒行链路,通常有一条路径由于费用、速度或避开拥挤等理由优选于其它路径。路由选择协议的任务是,为路由器提供他们建立通过网状网络最佳路径所需要的相互共享的路由信息。

本文由 在线网速测试 整理编辑,转载请注明出处。