互联网协议有多少种(互联网七层协议)

      最后更新:2024-01-03 14:06

      互联网协议包括哪些?

      目前网络协议有许多种,但是最基本的协议是TCP/IP协议,许多协议都是它的子协议。下面我们就对TCP/IP协议作一下简单介绍。 1 TCP/IP协议基础 TCP/IP协议包括两个子协议:一个是TCP协议(Transmission Control Protocol,传输控制协议),另一个是IP协议(Internet Protocol,互联网协议),它起源于20世纪60年代末。 在TCP/IP协议中,TCP协议和IP协议各有分工。TCP协议是IP协议的高层协议,TCP在IP之上提供了一个可靠的,连接方式的协议。TCP协议能保证数据包的传输以及正确的传输顺序,并且它可以确认包头和包内数据的准确性。如果在传输期间出现丢包或错包的情况,TCP负责重新传输出错的包,这样的可靠性使得TCP/IP协议在会话式传输中得到充分应用。IP协议为TCP/IP协议集中的其它所有协议提供“包传输”功能,IP协议为计算机上的数据提供一个最有效的无连接传输系统,也就是说IP包不能保证到达目的地,接收方也不能保证按顺序收到IP包,它仅能确认IP包头的完整性。最终确认包是否到达目的地,还要依靠TCP协议,因为TCP协议是有连接服务。 【说明】在计算机服务中如果按连接方式来分的话,可分为“有连接服务”和“无连接服务”两种。“有连接服务”必须先建立连接才能提供相应服务,而“无连接服务”则不需先建立连接。TCP协议是一种典型的有连接协议,而UDP协议则是典型的无连接服务。 (1)TCP/IP协议所包括的协议和工具 TCP/IP协议是一组网络协议的集合,它主要包括以下几方面的协议和工具。 ·TCP/IP协议核心协议 这些核心协议除了自身外,还包括用户数据报协议(UDP协议)、地址代理协议(ARP协议)以及网间控制协议(ICMP协议)。这组协议提供了一系列计算机互连和网络互连的标准协议。 ·应用接口协议 这类协议主要包括Windows套接字(Socket,用于开发网络应用程序)、远程调用、NetBIOS协议(用于建立逻辑名和网络上的会话)和网络动态数据交换(Network,用于通过网络共享嵌入在文本中的信息)。 ·基本的TCP/IP协议互连应用协议 主要包括finger、ftp、rep、rsh、telnet、tftp等协议。这些工具协议使得Windows系统用户使用非Microsoft系统计算机上(如UNIX系统计算机)的资源成为可能。 ·TCP/IP协议诊断工具 这些工具包括arp、hostname、ipconfig、nbstat、netstat、ping和route,它们可用来检测并恢复TCP/IP协议网络故障。 ·有关服务和管理工具 这些服务和管理工具包括FTP服务器服务(用于在两个远程计算机之间传输文件,这是远程控制通信中的关键功能)、网际命名服务WINS(用于在一个网际上动态记录和询问计算机的名字)、动态计算机配置协议DHCP(用于在Windows NT计算机上自动配置TCP/IP协议)以及TCP/IP协议打印(主要用于远程打印和网络打印)。 ·简单网络管理协议代理(SNMP) 这个工具允许通过使用管理工具(如“Sun Net Manages” 或“HP Open View”),从远程管理Windows NT计算机。 (2)TCP/IP的主要协议简述 为了使读者能全面了解一些基本的网络通信协议和服务,本节就对TCP/IP协议所包括的几种主要协议进行简要说明。 ·远程登录协议(Telnet)Telnet协议是用来登录到远程计算机上,并进行信息访问,通过它可以访问所有的数据库、联机游戏、对话服务以及电子公告牌,如同与被访问的计算机在同一房间中工作一样,但只能进行些字符类*作和会话。·文件传输协议(Ftp)这是文件传输的基本协议,有了FTP协议就可以把的文件进行上传,也可从网上得到许多应用程序和信息(下载),有许多软件站点就是通过FTP协议来为用户提供下载任务的,俗称“FTP服务器”。最初的FTP程序是工作在UNIX系统下的,而目前的许多FTP程序是工作在Windows系统下的。FTP程序除了完成文件的传送之外,还允许用户建立与远程计算机的连接,登录到远程计算机上,并可在远程计算机上的目录间移动。 ·电子邮件服务(Email)电子邮件服务是目前最常见、应用最广泛的一种到联网服务。通过电子邮件,可以与Internet上的任何人交换信息。电子邮件的快速、高效、方便以及价廉,越来越得到了广泛的应用,目前只要是上过网的网民就肯定用过电子邮件这种服务。目前,全球平均每天约有几千万份电子邮件在网上传输。·WWW服务WWW服务(3W服务)也是目前应用最广的一种基本互联网应用,我们每天上网都要用到这种服务。通过WWW服务,只要用鼠标进行本地*作,就可以到达世界上的任何地方。由于WWW服务使用的是超文本链接(HTML),所以可以很方便的从一个信息页转换到另一个信息页。它不仅能查看文字,还可以欣赏图片、音乐、动画。最流行的WWW服务的程序就是微软的IE浏览器。·简单邮件传输协议(SMTP)SMTP是TCP/IP协议族的一个成员,这种协议认为你的计算机是永久连接在Internet上的,而且认为你在网络上的计算机在任何时候是可以被访问的。它适用于永久连接在Internet的计算机,但无****使用通过SLIP/PPP协议连接的用户接收电子邮件。解决这个问题的办****是在邮件计算机上同时运行SMTP和POP协议的程序,SMTP负责邮件的发送和在邮件计算机上的分拣和存储,POP协议负责将邮件通过SLIP/PPP协议连接传送到用户计算机上。·信息服务(Gopher)Gopher最早出现在1991年,它是第一个*作简便、使用广泛的从Internet服务器上获取信息的客户应用程序。除了*作简便外,它的另一个特点是速度快。Gopher运行时,将显示一个交互式的供用户选择的菜单,菜单中的选项由简单的短句组成,每个短句通常指向另一个菜单,并最终指向有用的文件。Gopher是帮助用户在Internet信息海洋中搜索有用信息的导航器。用户只要关心浏览的内容,而不必关心具体的服务器。·文件检索服务(Archie)它是一个从整个Internet上匿名FTP服务器获取文件的服务。其完全依赖于匿名FTP系统的管理员,他们将站点在全世界的Archie服务器进行了注册,Archie仅通过文件名进行检索
      TCP/IP协议、IPX/SPX协议、NetBEUI协议网络上的计算机之间又是如何交换信息的呢?就像我们说话用某种语言一样,在网络上的各台计算机之间也有一种语言,这就是网络协议,不同的计算机之间必须使用相同的网络协议才能进行通信。网络协议是网络上所有设备(网络服务器、计算机及交换机、路由器、防火墙等)之间通信规则的集合,它定义了通信时信息必须采用的格式和这些格式的意义。大多数网络都采用分层的体系结构,每一层都建立在它的下层之上,向它的上一层提供一定的服务,而把如何实现这一服务的细节对上一层加以屏蔽。一台设备上的第n层与另一台设备上的第n层进行通信的规则就是第n层协议。在网络的各层中存在着许多协议,接收方和发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息。网络协议使网络上各种设备能够相互交换信息。常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议等。在局域网中用得的比较多的是IPX/SPX.。用户如果访问Internet,则必须在网络协议中添加TCP/IP协议。TCP/IP是“transmission Control Protocol/Internet Protocol”的简写,中文译名为传输控制协议/互联网络协议)协议, TCP/IP(传输控制协议/网间协议)是一种网络通信协议,它规范了网络上的所有通信设备,尤其是一个主机与另一个主机之间的数据往来格式以及传送方式。TCP/IP是INTERNET的基础协议,也是一种电脑数据打包和寻址的标准方法。在数据传送中,可以形象地理解为有两个信封,TCP和IP就像是信封,要传递的信息被划分成若干段,每一段塞入一个TCP信封,并在该信封面上记录有分段号的信息,再将TCP信封塞入IP大信封,发送上网。在接受端,一个TCP软件包收集信封,抽出数据,按发送前的顺序还原,并加以校验,若发现差错,TCP将会要求重发。因此,TCP/IP在INTERNET中几乎可以无差错地传送数据。 对普通用户来说,并不需要了解网络协议的整个结构,仅需了解IP的地址格式,即可与世界各地进行网络通信。IPX/SPX是基于施乐的XEROX’S Network System(XNS)协议,而SPX是基于施乐的XEROX’S SPP(Sequenced Packet Protocol:顺序包协议)协议,它们都是由novell公司开发出来应用于局域网的一种高速协议。它和TCP/IP的一个显著不同就是它不使用ip地址,而是使用网卡的物理地址即(MAC)地址。在实际使用中,它基本不需要什么设置,装上就可以使用了。由于其在网络普及初期发挥了巨大的作用,所以得到了很多厂商的支持,包括microsoft等,到现在很多软件和硬件也均支持这种协议。NetBEUI即NetBios Enhanced User Interface ,或NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用,例如Windows for Workgroup、Win 9x系列、Windows NT等。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。总之NetBEUI协议是一种短小精悍、通信效率高的广播型协议,安装后不需要进行设置,特别适合于在“网络邻居”传送数据。所以建议除了TCP/IP协议之外,局域网的计算机最好也安上NetBEUI协议。另外还有一点要注意,如果一台只装了TCP/IP协议的WINDOWS98机器要想加入到WINNT域,也必须安装NetBEUI协议。
      常见的互联网协议包括:ARP(Address Resolution Protocol)地址解析协议SNMP(Simple Network Management Protocol)网络管理协议AppleShare protocol(AppleShare协议)AppleTalk协议它是Macintosh计算机使用的主要网络协议。BGP4(Border Gateway Protocol Vertion 4)边界网关协议-版本4BOOTP协议它是一个基于TCP/IP协议的协议,它可以让无盘站从一个中心服务器上获得IP地址,CMIP(Common Management Information Protocol)通用管理信息协议它是建立在开放系统互连通信模式上的网络管理协议。Connection-oriented Protocol/Connectionless Protocol面向连接的协议/无连接协议在广域网中,两台计算机建立物理连接过程所使用的协议,这种物理连接要持续到成功地交换完数据为止。DHCP(Dynamic Host Configuration Protocol)动态主机配置协议它是在TCP/IP网络上使客户机获得配置信息的协议,它是基于BOOTP协议,Discard Protocol抛弃协议它的作用就是接收到什么抛弃什么,它对调试网络状态的一定的用处。Echo Protocol协议这个协议主要用于调试和检测中。FTP(File Transfer Protocol)文件传输协议它是一个标准协议,是在计算机和网络之间交换文件的最简单的方法。HDLC(High-Level Data Link Control)高层数据链路协议它是一组用于在网络结点间传送数据的协议。HTTP1.1(Hypertext Transfer Protocol Vertion 1.1)超文本传输协议-版本1.1HTTPS(Secure Hypertext Transfer Protocol)安全超文本传输协议它是由Netscape开发并内置于其浏览器中,用于对数据进行压缩和解压操作,ICMP(Internet Control Message Protocol)Internet控制信息协议IMAP4(Internet Mail Access Protocol Version 4)Internet邮件访问协议-版本4NNTP(Network News Transfer Protocol)网络新闻传输协议NNTP同POP3协议一样,也存在某些局限性。IOTP(Internet Open Trading Protocol)Internet开放贸易协议IPv6(Internet Protocol Version 6)Internet协议-版本6IPX/SPX(Internetwork Packet Exchange/Sequential PacketExchange)互连网包交换/顺序包交换它是由Novell提出的用于客户/服务器相连的网络协议。OSPF(Open Shortest Path First)开放最短路优先POP3(Post Office Protocol Version 3)邮局协议-版本3它是一个关于接收电子邮件的客户/服务器协议。PPP(Point to Point Protocol)点对点协议它是用于串行接口的两台计算机的通信协议,RIP(Routing Infomation Protocol)路由信息协议SLIP(Serial Line Internet Protocol)串行线路Internet协议SMB protocol (Server Message Block protocol)服务器信息块协议LMTP(Local Mail Transfer Protocol)本地邮件传输协议SMTP(Simple Mail Transfer Protocol)简单邮件传送协议Talk协议Talk协议能使远程计算机上的两个用户以实时方式进行通信。TELNET Protocol虚拟终端协议Time Protocol时间协议TFTP(Trivial File Transfer Protocol)小文件传输协议UDP(User Datagram Protocol)用户数据报协议它是定义用来在互连网络环境中提供包交换的计算机通信的协议,UUCP(UNIX-to-UNIX Copy Protocol)UNIX至UNIX拷贝协议它是一组用于在不同UNIX系统之间复制(传送)文件或传送用于其它UNIX系统执行命令的一组指令,是UNIX网络的基础。
      互联网协议(IP)是互联网协议群(Internet Protocol Suite ,IPS)中众多通信协议中的一个,也是其中最重要的一个。专家们一般将IPS解释为一个协议堆栈,它可以将应用程序的信息(比如电子邮件或者网页传输的内容)转换为网络可以传输的数据包。“互联网协议(IP)特指为实现在一个相互连接的网络系统上从一个源到一个目的地传输比特数据包(互联网数据包)所提供必要功能的协议。其中并没有增加端到端数据可靠性机制、流量控制机制、排序机制或者其它在端到端协议常见的功能机制。互联网协议可在其支持的网络上提供相应服务,实现多种类型和品质的服务。”
      互联网协议包括哪些?

      网络协议都有哪几种??

      不同层的协议有很多,协议大全 http://www.cnpaf.net/class/protocolAll/常用的三个网络协议网络中不同的工作站,服务器之间能传输数据,源于协议的存在。随着网络的发展,不同 的开发商开发了不同的通信方式。为了使通信成功可靠,网络中的所有主机都必须使用同 一语言,不能带有方言。因而必须开发严格的标准定义主机之间的每个包中每个字中的每 一位。这些标准来自于多个组织的努力,约定好通用的通信方式,即协议。这些都使通信更容易。当今局域网中最常见的三个协议是MICROSOFT的NETBEUI、NOVELL的IPX/SPX和交叉 平台TCP/IP。一:NETBEUINETBEUI是为IBM开发的非路由协议,用于携带NETBIOS通信。NETBEUI缺乏路由和网络 层寻址功能,既是其最大的优点,也是其最大的缺点。因为它不需要附加的网络地址和网 络层头尾,所以很快并很有效且适用于只有单个网络或整个环境都桥接起来的小工作组环境。 因为不支持路由,所以NETBEUI永远不会成为企业网络的主要协议。NETBEUI帧中唯一的地址是数据链路层媒体访问控制(MAC)地址,该地址标识了网卡但没有标识网络。路由器靠网络地址将帧转发到最终目的地,而NETBEUI帧完全缺乏该信息。网桥负责按照数据链路层地址在网络之间转发通信,但是有很多缺点。因为所有的广播通信都必须转发到每个网络中,所以网桥的扩展性不好。NETBEUI特别包括了广播通信的记数并依赖它解决命名冲突。一般而言,桥接NETBEUI网络很少超过100台主机。近年来依赖于第二层交换器的网络变得更为普遍。完全的转换环境降低了网络的利用率,尽管广播仍然转发到网络中的每台主机。事实上,联合使用100-BASE-T Ethernet,允许转换NetBIOS网络扩展到350台主机,才能避免广播通信成为严重的问题。二:IPX/SPXIPX是NOVELL用于NETWARE客户端/服务器的协议群组,避免了NETBEUI的弱点。但是,带来了新的不同弱点。IPX具有完全的路由能力,可用于大型企业网。它包括32位网络地址,在单个环境中允许有许多路由网络。IPX的可扩展性受到其高层广播通信和高开销的限制。服务广告协议(Service Advertising Protocol,SAP)将路由网络中的主机数限制为几千。尽管SAP的局限性已经被智能路由器和服务器配置所克服,但是,大规模IPX网络的管理员仍是非常困难的工作。三:TCP/IP每种网络协议都有自己的优点,但是只有TCP/IP允许与Internet完全的连接。TCP/IP是在60年代由麻省理工学院和一些商业组织为美国国防部开发的,即便遭到核攻击而破坏了大部分网络,TCP/IP仍然能够维持有效的通信。ARPANET就是由基于协议开发的,并发展成为作为科学家和工程师交流媒体的Internet。 TCP/IP同时具备了可扩展性和可靠性的需求。不幸的是牺牲了速度和效率(可是:TCP/IP的开发受到了政府的资助)。Internet公用化以后,人们开始发现全球网的强大功能。Internet的普遍性是TCP/IP至今仍然使用的原因。常常在没有意识到的情况下,用户就在自己的PC上安装了TCP/IP栈 ,从而使该网络协议在全球应用最广。TCP/IP的32位寻址功能方案不足以支持即将加入Internet的主机和网络数。因而可能代替当前实现的标准是IPv6。
      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。

      网络协议都有哪几种??

      网络协议有哪些?

      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议。 TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层, 几个常用协议如下:1、Telnet(Remote Login):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(File Transfer Protocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(Simple Mail transfer Protocol):简单邮政传输协议,用于传输电子邮件。4、NFS(Network File Server):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(User Datagram Protocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。HTTP协议简介HTTP是一个属于应用层的面向对象的协议,由于其简捷、快速的方式,适用于分布式超媒体信息系统。它于1990年提出,经过几年的使用与发展,得到不断地完善和扩展。目前在WWW中使用的是HTTP/1.0的第六版,HTTP/1.1的规范化工作正在进行之中,而且HTTP-NG(Next Generation of HTTP)的建议已经提出。HTTP协议的主要特点可概括如下:1.支持客户/服务器模式。2.简单快速:客户向服务器请求服务时,只需传送请求方法和路径。请求方法常用的有GET、HEAD、POST。每种方法规定了客户与服务器联系的类型不同。由于HTTP协议简单,使得HTTP服务器的程序规模小,因而通信速度很快。3.灵活:HTTP允许传输任意类型的数据对象。正在传输的类型由Content-Type加以标记。4.无连接:无连接的含义是限制每次连接只处理一个请求。服务器处理完客户的请求,并收到客户的应答后,即断开连接。采用这种方式可以节省传输时间。 5.无状态:HTTP协议是无状态协议。无状态是指协议对于事务处理没有记忆能力。缺少状态意味着如果后续处理需要前面的信息,则它必须重传,这样可能导致每次连接传送的数据量增大。另一方面,在服务器不需要先前信息时它的应答就较快。
      常用的协议有TCP/IP协议、NetBEUI协议和IPX/SPX协议。TCP/IP协议作为互联网的基础协议毫无疑问是这三大协议中最重要的一个,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层, 几个常用协议如下:1、Telnet(Remote Login):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(File Transfer Protocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(Simple Mail transfer Protocol):简单邮政传输协议,用于传输电子邮件。4、NFS(Network File Server):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(User Datagram Protocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。
      介绍IT互联网基础知识TCP/IP四层协议模型

      网络协议有哪些?

      电脑有多少种网络协议?

      电脑网络协议分为以下几种: IP/IPv4:网际协议TCP:传输控制协议IGMP:Internet 组管理协议ICMP/ICMPv6:Internet控制信息协议SNMP:简单网络管理协议DNS:域名系统(服务)协议TFTP:简单文件传输协议NFS:(网络文件系统Network File System)由美SUN微系统公司发协议能使计算机系统通网络访问其计算机系统目录文件象些文件存储本硬盘具体介绍:IP/IPv4:网际协议网际协议(IP)网络层协议包含寻址信息控制信息 使数据包网络路由IP 协议 TCP/IP 协议族主要网络层协议与 TCP 协议结合组整特网协议核协议IP 协议同都适用于 LANWAN 通信 IP 协议两基本任务:提供连接效数据包传送;提供数据包割及重组支持同传输单元数据连接于互联网络 IP 数据报路由选择处理套完善 IP 寻址式每 IP 址都其特定组同遵循基本格式IP 址进行细并用于建立网址TCP/IP 网络每台计算机都配唯 32 位逻辑址址两主要部:网络号主机号网络号用确认网络该网络特网部其网络号必须由 InterNIC 统配网络服务器供应商(ISP) InterNIC 获块网络址按照需要自配址空间主机号确认网络主机由本网络管理员配 发送或接受数据(例封电信函或网页)消息若干块我所说包每包既包含发送者网络址包含接受者址由于消息划量包若需要每包都通同网络路径发送包达顺序定发送顺序相同 IP 协议用于发送包 TCP 协议负责其按确顺序排列 除 ARPRARP其所 TCP/IP 族协议都使用 IP 传送主机与主机间通信前 IP 协议两种版本:IPv4IPv6本文主要阐述 IPv4 IPv6 相关细节其文件再作介绍TCP:传输控制协议传输控制协议 TCPTCP/IP 协议栈传输层协议通序列确认及包重发机制提供靠数据流发送应用程序虚拟连接服务与 IP 协议相结合 TCP 组特网协议核 由于数网络应用程序都同台机器运行计算机必须能够确保目机器软件程序能源址机器处获数据包及源计算机能收确复通使用 TCP 端口号完网络 IP 址端口号结合唯标识 , 我称套接字或端点 TCP 端点间建立连接或虚拟电路进行靠通信 TCP 服务提供数据流传输、靠性、效流控制、全双工操作路复用技术等 关于流数据传输 ,TCP 交付由序列号定义结构字节流 服务应用程序利送 TCP 前应用程序需要数据划块 TCP 字节整合字段传给 IP 进行发送 TCP 通面向连接、端端靠数据报发送保证靠性 TCP 字节加递进确认序列号告诉接收者发送者期望收字节规定间内没收关于包确认响应重新发送包 TCP 靠机制允许设备处理丢失、延、重复及读错包超机制允许设备监测丢失包并请求重发 TCP 提供效流控制向发送者返确认响应接收 TCP 进程说明能接收并保证缓存发溢高序列号 全双工操作: TCP 进程能够同发送接收包 TCP 路技术:量同发层能单连接进行路复用IGMP:Internet 组管理协议Internet 组管理协议(IGMP)特网协议家族组播协议用于 IP 主机向任直接相邻路由器报告组员情况IGMP 信息封装 IP 报文其 IP 协议号 2IGMP 具三种版本即 IGMP v1、v2v3IGMPv1: 主机加入组播组没离信息(leave messages)路由器使用基于超机制发现其员关注组 IGMPv2: 该协议包含离信息允许迅速向路由协议报告组员终止情况高带宽组播组或易变型组播组员言非重要 IGMPv3: 与两种协议相比该协议主要改:允许主机指定要接收通信流量主机象自网络其主机流量隔离IGMPv3 支持主机阻止些自于非要求主机发送网络数据包 IGMP 协议变种: 距离矢量组播路由选择协议(DVMRP: Distance Vector Multicast Routing Protocol) IGMP 用户认证协议 (IGAP: IGMP for user Authentication Protocol) 路由器端口组管理协议(RGMP: Router-port Group Management Protocol)ICMP/ICMPv6:Internet控制信息协议Internet 控制信息协议(ICMP) IP 组整合部通 IP 包传送 ICMP 信息主要用于涉及网络操作或错误操作达信息ICMP 包发送靠所主机能依靠接收 ICMP 包解决任何网络问题ICMP 主要功能: 通告网络错误比某台主机或整网络由于某些故障达指向某端口号 TCP 或 UDP 包没指明接受端由 ICMP 报告 通告网络拥塞路由器缓存太包由于传输速度达接收速度 ICMP 源结束信息于发送者些信息导致传输速度降低更 ICMP 源结束信息引起更网络拥塞所使用起较保守 协助解决故障ICMP 支持 Echo 功能即两主机间往返路径发送包 Ping 种基于种特性通用网络管理工具传输系列包测量平均往返数并计算丢失百比 通告超 IP 包 TTL 降低零路由器丢弃包 ICMP 包通告事实TraceRoute 工具通发送 TTL 值包及监视 ICMP 超通告显示网络路由 ICMPIPv6 定义重新修订外 IPv4 组员协议(IGMP)点传送控制功能嵌入 ICMPv6SNMP:简单网络管理协议SNMP 专门设计用于 IP 网络管理网络节点(服务器、工作站、路由器、交换机及 HUBS 等)种标准协议种应用层协议 SNMP 使网络管理员能够管理网络效能发现并解决网络问题及规划网络增通 SNMP 接收随机消息(及事件报告)网络管理系统获知网络现问题 SNMP 管理网络三主要组部:管理设备、代理网络管理系统管理设备网络节点包含 ANMP 代理并处管理网络管理设备用于收集并储存管理信息通 SNMPNMS 能些信息管理设备称网络单元能指路由器、访问服务器交换机网桥、 HUBS 、主机或打印机 SNMP 代理管理设备网络管理软件模块 SNMP 代理拥本相关管理信息并转换与 SNMP 兼容格式 NMS 运行应用程序实现监控管理设备外 NMS 网络管理提供量处理程序及必须储存资源任何受管理网络至少需要或 NMS目前 SNMP3 种: SNMPV1 、 SNMPV2 、 SNMPV3第 1 版第 2 版没太差距 SNMPV2 增强版本包含其协议操作与前两种相比 SNMPV3 则包含更安全远程配置解决同 SNMP 版本间兼容问题 RFC3584 种定义三者共存策略 SNMP 包括组由 RMON 、 RMON2 、 MTB 、 MTB2 、 OCDS 及 OCDS 定义扩展协议DNS:域名系统(服务)协议域名系统(服务)协议(DNS)种布式网络目录服务主要用于域名与 IP 址相互转换及控制特网电邮件发送数特网服务依赖于 DNS 工作旦 DNS 错连接 Web 站点电邮件发送止 DNS 两独立面 : 定义命名语规范利于通名称委派域名权限基本语: local.group.site; 定义何实现布式计算机系统便效域名转换 IP 址DNS 命名式采用散层机制实现域名空间委派授权及域名与址相转换授权通使用 DNS 命名式遍布全球网络设备配域名则由散世界各服务器实现 理论 DNS 协议域名标准阐述种用任意标签值布式抽象域名空间任何组织都建立域名系统其所布结构选择标签数 DNS 协议用户遵循官特网域名系统使用级标签见顶级域: COM 、 EDU 、 GOV 、 NET 、 ORG 、 BIZ 另外些带家代码顶级域 DNS 布式机制支持效且靠名字 IP 址映射数名字本映射同站点服务器相互合作能够解决网络名字与 IP 址映射问题单服务器故障影响 DNS 确操作 DNS 种通用协议并仅限于网络设备名称TFTP:简单文件传输协议 简单文件传输协议种用传输文件简单协议运行 UDP (用户数据报协议) TFTP 设计简单容易运行缺乏标准 FTP 协议许特征 TFTP 能远程服务器读、写文件(邮件)或者读、写文件传送给远程服务器能列目录并且前提供用户认证 前 TFTP3 种传输模式: netASC11 模式即 8 位 ASC11 ;八位组模式(替代前版本二进制模式)原始八位字节;邮件模式种模式传输给用户文件字符主机双自定义其模式TFTP 协议任何传输进程都请求读写文件始同建立连接服务器同意请求则连接功文件固定 512 字节块度进行传送每数据包都包含数据块发送包前数据块必须确认响应包确认少于 512 字节数据包说明传输结束包网络丢失接收端超并重新发送其包(能数据能确认响应)导致丢失包发送者重新发送丢失包发送者需要保留包手用于重新发送 LOCK 确认响应保证所包都已经收注意传输双都看作发送者接收者发送数据并接收确认响应另发送确认响应并接受数据
      常用的三种网络协议  [3]TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。 TCP/IP尽管是目前最流行的网络协议,但TCP/IP协议在局域网中的通信效率并不高,使用它在浏览“网上邻居”中的计算机时,经常会出现不能正常浏览的现象。此时安装NetBEUI协议就会解决这个问题。NetBEUI即NetBios Enhanced User Interface ,或NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用,例如Windows for Workgroup、Win 9x系列、WindowsNT等。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。NetBEUI协议是一种短小精悍、通信效率高的广播型协议,安装后不需要进行设置,特别适合于在“网络邻居”传送数据。所以建议除了TCP/IP协议之外,小型局域网的计算机也可以安上NetBEUI协议。另外还有一点要注意,如果一台只装了TCP/IP协议的WINDOWS98机器要想加入到WINNT域,也必须安装NetBEUI协议。IPX/SPX协议本来就是Novell开发的专用于NetWare网络中的协议,但是现在也非常常用--大部分可以联机的游戏都支持IPX/SPX协议,比如星际争霸,反恐精英等等。虽然这些游戏通过TCP/IP协议也能联机,但显然还是通过IPX/SPX协议更省事,因为根本不需要任何设置。除此之外,IPX/SPX协议在局域网络中的用途似乎并不是很大.如果确定不在局域网中 联机玩游戏,那么这个协议可有可无。
      物理层:以太网 · 调制解调器 · 电力线通信(PLC) · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线等 数据链路层:Wi-Fi(IEEE 802.11) · WiMAX(IEEE 802.16) · ARP · RARP ·ATM · DTM · 令牌环 · 以太网 ·FDDI · 帧中继 · GPRS · EVDO ·HSPA · HDLC · PPP · L2TP ·PPTP · ISDN·STP 等网络层协议:IP (IPv4 · IPv6) · ICMP· ICMPv6·IGMP ·IS-IS · IPsec 等传输层协议:TCP · UDP · TLS · DCCP · SCTP · RSVP · OSPF 等 应用层协议:DHCP · DNS · FTP · Gopher · HTTP· IMAP4 · IRC · NNTP · XMPP ·POP3 · SIP · SMTP ·SNMP · SSH ·TELNET · RPC · RTCP · RTP ·RTSP· SDP · SOAP · GTP · STUN · NTP· SSDP · BGP · RIP 等

      很多啊
      电脑有多少种网络协议?

      计算机网络协议有哪些

      网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议。TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层,几个常用协议如下:1、Telnet(RemoteLogin):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(FileTransferProtocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(SimpleMailtransferProtocol):简单邮政传输协议,用于传输电子邮件。4、NFS(NetworkFileServer):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(UserDatagramProtocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。HTTP协议简介HTTP是一个属于应用层的面向对象的协议,由于其简捷、快速的方式,适用于分布式超媒体信息系统。它于1990年提出,经过几年的使用与发展,得到不断地完善和扩展。目前在WWW中使用的是HTTP/1.0的第六版,HTTP/1.1的规范化工作正在进行之中,而且HTTP-NG(NextGenerationofHTTP)的建议已经提出。HTTP协议的主要特点可概括如下:1.支持客户/服务器模式。2.简单快速:客户向服务器请求服务时,只需传送请求方法和路径。请求方法常用的有GET、HEAD、POST。每种方法规定了客户与服务器联系的类型不同。由于HTTP协议简单,使得HTTP服务器的程序规模小,因而通信速度很快。3.灵活:HTTP允许传输任意类型的数据对象。正在传输的类型由Content-Type加以标记。4.无连接:无连接的含义是限制每次连接只处理一个请求。服务器处理完客户的请求,并收到客户的应答后,即断开连接。采用这种方式可以节省传输时间。 5.无状态:HTTP协议是无状态协议。无状态是指协议对于事务处理没有记忆能力。缺少状态意味着如果后续处理需要前面的信息,则它必须重传,这样可能导致每次连接传送的数据量增大。另一方面,在服务器不需要先前信息时它的应答就较快。
      应用层 ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   · RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
      应用层 ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   · RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
      ·DHCP(动态主机分配协议) · DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议
      TCOP/IP DNSDHCPTELNETHTTPSMTPTFTPSNMPTCPUDPIPARPRAPPICMPIGMPPPP X.25
      计算机网络协议有哪些

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类