Https协议
简单地来说,是基于ssl的http协议,依托ssl协议,https协议能够确保整个通信是加密的,密钥随机产生,并且能够通过数字证书验证通信双方的身份,以此来保障信息安全。其中证书包含了证书所代表一端的公钥,以及一些其所具有的基本信息,如机构名称,证书所作用域名、证书的数字签名等,通过数字签名能够验证证书的真实性。通信的内容使用对称加密方式进行加密,通信两端约定好通信密码后,通过公钥对密码进行加密传输,只有该公钥对应的私钥,也就是通信的另一端才能够解密获得通信密码,这样既保证了通信的安全,也使加密性能和时间成本可控。 https协议在http协议和tcp协议增加一层安全层,所有请求和响应的数据在结果网络传输之前都会先进行加密,然后在进行传输。Https协议既支持单向认证,也支持双向认证。单向认证:只校验服务端证书的有效性。双向认证:既校验服务端也校验客户端。SSL的全称是Secure Socket Layer,既安全套接层。SSL协议独立于应用层,高层应用http,ftp,ssh都可以简历在ssl之上。TLS全程是Transport Layer Security,传输层安全协议,是基于SSL的通用化协议,同样位于应用层和传输层之间,正逐步接替SSL成为下一代网络安全协议。SSL/TLS分为两层:1.Record Protocol,记录协议;记录协议建立在可靠的传输协议(TCP)之上,提供数据封装,加密解密,数据压缩,数据校验等基本功能。2,Handshake Protocol,握手协议。建立在握手协议之上,在实际的数据传输开始前,进行加密算法的协商,通信密钥的交换,通信双方身份的认证。(1)客户端发送一个client hello消息,消息包含协议的版本信息、sessionid、客户端支持的加密算法、压缩算法等信息,并且还包含客户端产生的随机数。(2)服务端响应一个server hello消息,消息包含服务端产生的随机数、协议版本信息、sessionid、压缩算法信息,还有服务端数字证书,如果服务端配置是双向验证,则服务端将请求客户端证书。(3)客户端通过证书来验证服务端证书的有效性。(4)如果证书验证通过,客户端将向服务端发送经过服务端公钥加密的预主密钥,即PreMaster Secret。假如服务端在上一个步骤请求了客户端证书,客户端会将客户端证书发送给服务端进行校验。(5)服务端验证客户端证书的有效性,并用自己的私钥对PMS进行解密,使用client hello和server hello两个步骤所生成的随机数,加上解密的PMS来生成主密钥,即Master Secret,然后通过MS生成加密密钥。(6)客户端也将使用client hello和server hello两个步骤所生成的随机数,加上解密的PMS来生成MS,,然后通过MS生成加密密钥。(7)通知服务端未来信息将使用加密密钥来加密。(8)给服务端发送加密密钥来加密信息,终止握手。(9)通知客户端未来信息将使用加密密钥来加密。(10)给客户端发送加密密钥来加密信息,终止握手。 完成握手后,客户端与服务端便可以开始加密数据通信:

常用的网络协议有哪些?
常用的网络协议有TCP/IP协议、HTTP协议、FTP协议、Telnet协议、FTP协议、SMTP协议、NFS协议、UDP协议等。网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。网络协议是由三个要素组成:1、语义语义是解释控制信息每个部分的意义。它规定了需要发出何种控制信息,以及完成的动作与做出什么样的响应。2、语法语法是用户数据与控制信息的结构与格式,以及数据出现的顺序。3、时序时序是对事件发生顺序的详细说明。网络协议的层次结构如下:1、结构中的每一层都规定有明确的服务及接口标准。2、把用户的应用程序作为最高层3、除了最高层外,中间的每一层都向上一层提供服务,同时又是下一层的用户。4、把物理通信线路作为最低层,它使用从最高层传送来的参数,是提供服务的基础。
1.ARP(Address Resolution Protocol):地址解析协议,将IP解析成MAC地址地址解析协议,即ARP(Address Resolution Protocol),是根据IP地址获取物理地址的协议。主机发送信息时将包含目标IP地址的ARP请求广播到网络上的所有主机,并接收返回消息,以此确定目标的物理地址;收到返回消息后将该IP地址和物理地址存入本机ARP缓存中并保留一定时间,下次请求时直接查询ARP缓存以节约资源。地址解析协议是建立在网络中各个主机互相信任的基础上的,网络上的主机可以自主发送ARP应答消息,其他主机收到应答报文时不会检测该报文的真实性就会将其记入本机ARP缓存;由此攻击者就可以向某一主机发送伪ARP应答报文,使其发送的信息无法到达预期的主机或到达错误的主机,这就构成了一个ARP欺骗(网络执法官软件的工作原理就是arp欺骗)。2.DNS:域名解析协议 www.baidu.com3.SNMP(Simple Network Management Protocol)简单网络管理协议4.DHCP(Dynamic Host Configuration Protocol)动态主机配置协议,它是在TCP/IP网络上使客户机获得配置信息的协议5.FTP(File Transfer Protocol)文件传输协议,它是一个标准协议,是在计算机和网络之间交换文件的最简单的方法。6.HTTP(Hypertext Transfer Protocol ):超文本传输协议7.HTTPS(Secure Hypertext Transfer Protocol):安全超文本传输协议,它是由Netscape开发并内置于其浏览器中,用于对数据进行压缩和解压操作.8.ICMP(Internet Control Message Protocol):Internet控制信息协议,互联网控制报文协议ping ip定义消息类型有:TTL超时、地址的请求与应答、信息的请求与应答、目的地不可到达9.SMTP(Simple Mail Transfer Protocol):简单邮件传送协议10.TELNET Protocol:虚拟终端协议11.TFTP(Trivial File Transfer Protocol):小文件传输协议12.UDP(User Datagram Protocol):用户数据报协议,它是定义用来在互连网络环境中提供包交换的计算机通信的协议13.TCP(Transmission Control Protocol): 传输控制协议,是一种面向连接的、可靠的、基于字节流的传输层通信协议 log转发:开启一个协议:tcp(三次握手和四次挥手)

计算机网络协议有哪些
网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。 局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议。TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。TCP/IP协议族中包括上百个互为关联的协议,不同功能的协议分布在不同的协议层,几个常用协议如下:1、Telnet(RemoteLogin):提供远程登录功能,一台计算机用户可以登录到远程的另一台计算机上,如同在远程主机上直接操作一样。2、FTP(FileTransferProtocol):远程文件传输协议,允许用户将远程主机上的文件拷贝到自己的计算机上。3、SMTP(SimpleMailtransferProtocol):简单邮政传输协议,用于传输电子邮件。4、NFS(NetworkFileServer):网络文件服务器,可使多台计算机透明地访问彼此的目录。5、UDP(UserDatagramProtocol):用户数据包协议,它和TCP一样位于传输层,和IP协议配合使用,在传输数据时省去包头,但它不能提供数据包的重传,所以适合传输较短的文件。HTTP协议简介HTTP是一个属于应用层的面向对象的协议,由于其简捷、快速的方式,适用于分布式超媒体信息系统。它于1990年提出,经过几年的使用与发展,得到不断地完善和扩展。目前在WWW中使用的是HTTP/1.0的第六版,HTTP/1.1的规范化工作正在进行之中,而且HTTP-NG(NextGenerationofHTTP)的建议已经提出。HTTP协议的主要特点可概括如下:1.支持客户/服务器模式。2.简单快速:客户向服务器请求服务时,只需传送请求方法和路径。请求方法常用的有GET、HEAD、POST。每种方法规定了客户与服务器联系的类型不同。由于HTTP协议简单,使得HTTP服务器的程序规模小,因而通信速度很快。3.灵活:HTTP允许传输任意类型的数据对象。正在传输的类型由Content-Type加以标记。4.无连接:无连接的含义是限制每次连接只处理一个请求。服务器处理完客户的请求,并收到客户的应答后,即断开连接。采用这种方式可以节省传输时间。 5.无状态:HTTP协议是无状态协议。无状态是指协议对于事务处理没有记忆能力。缺少状态意味着如果后续处理需要前面的信息,则它必须重传,这样可能导致每次连接传送的数据量增大。另一方面,在服务器不需要先前信息时它的应答就较快。
应用层 ·DHCP(动态主机分配协议) · DNS (域名解析) · FTP(File Transfer Protocol)文件传输协议 · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议) · HTTP (Hypertext Transfer Protocol)超文本传输协议 · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本 · IRC (Internet Relay Chat )网络聊天协议 · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议 · XMPP 可扩展消息处理现场协议 · POP3 (Post Office Protocol 3)即邮局协议的第3个版本 · SIP 信令控制协议 · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议 · SNMP (Simple Network Management Protocol,简单网络管理协议) · SSH (Secure Shell)安全外壳协议 · TELNET 远程登录协议 · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议 · RTCP (RTP Control Protocol)RTP 控制协议 · RTSP (Real Time Streaming Protocol)实时流传输协议 · TLS (Transport Layer Security Protocol)安全传输层协议 · SDP( Session Description Protocol)会话描述协议 · SOAP (Simple Object Access Protocol)简单对象访问协议 · GTP 通用数据传输平台 · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议 · UDP (User Datagram Protocol) 用户数据报协议 · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议 · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议 · RTPReal-time Transport Protocol或简写RTP)实时传送协议 · RSVP (Resource ReSer Vation Protocol)资源预留协议 · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
应用层 ·DHCP(动态主机分配协议) · DNS (域名解析) · FTP(File Transfer Protocol)文件传输协议 · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议) · HTTP (Hypertext Transfer Protocol)超文本传输协议 · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本 · IRC (Internet Relay Chat )网络聊天协议 · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议 · XMPP 可扩展消息处理现场协议 · POP3 (Post Office Protocol 3)即邮局协议的第3个版本 · SIP 信令控制协议 · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议 · SNMP (Simple Network Management Protocol,简单网络管理协议) · SSH (Secure Shell)安全外壳协议 · TELNET 远程登录协议 · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议 · RTCP (RTP Control Protocol)RTP 控制协议 · RTSP (Real Time Streaming Protocol)实时流传输协议 · TLS (Transport Layer Security Protocol)安全传输层协议 · SDP( Session Description Protocol)会话描述协议 · SOAP (Simple Object Access Protocol)简单对象访问协议 · GTP 通用数据传输平台 · STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol) 传输控制协议 · UDP (User Datagram Protocol) 用户数据报协议 · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议 · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议 · RTPReal-time Transport Protocol或简写RTP)实时传送协议 · RSVP (Resource ReSer Vation Protocol)资源预留协议 · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec数据链路层802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN物理层 以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线
·DHCP(动态主机分配协议) · DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议
TCOP/IP DNSDHCPTELNETHTTPSMTPTFTPSNMPTCPUDPIPARPRAPPICMPIGMPPPP X.25

网络安全基础
网络安全通信所需要的基本属性: 1. 机密性2. 消息完整性3. 可访问与可用性4. 身份认证1. 窃听2. 插入3. 假冒4. 劫持5. 拒绝服务DoS和分布式拒绝服务DDoS6. 映射7. 嗅探8. IP欺骗数据加密明文:未被加密的消息密文:被加密的消息加密:伪装消息以隐藏消息的过程,即 明文密文 的过程.解密: 密文明文 的过程1.替代密码 :用密文字母替代明文字母。移位密码加密函数::加密过程:明文信息:密钥,表示移几位:如果是26个字母,那q就是26解密函数::解密过程:密文:密钥2. 换位密码 :根据一定规则重新排列明文。【 例题 】如果对明文“bob.i love you. Alice",利用k=3的凯撒密码加密,得到的密文是什么?利用密钥 "nice" 进行列置换加密后得到的密文是什么?【 答案 】 凯撒密码 加密后得到的密文是:"ere l oryh brx Dolfh"列置换密码 加密后得到的密文是:iex bvu bly ooo"【 解析 】 凯撒密码 :以明文字母b为例,M=2(b的位置为2),k=3,q=26,则:密文,对应字母e,故b经过加密转为了e将明文全部替换后得到的密文 "ere l oryh brx Dolfh"列置换密码:密钥 "nice" 字母表先后顺序为 "4,3,1,2" ,因此,按这个顺序读出表中字母,构成密文:"iex bvu bly ooo",(密钥有几位就有几列,如果明文不够就补x,然后按列读取)1.对称密钥 密码:加密秘钥和解密秘钥相同(),例如用一个锁将箱子锁起来,这个锁有2把相同的钥匙,锁好之后把另一把钥匙派人送给他。2. 对称密钥密码 分类 :分组密码:DES、AES、IDEA等。(分组处理)1)(数据加密标准):56位密钥,64位分组。(56位二进制数,每位的取值是0或1,则所有的取值就是个)2):使用 两个秘钥 (共 112位 ),执行三次DES算法。(用1个密钥执行一次加密,再用另一个密钥执行一次解密,共执行三次)3)(高级加密算法):分组128位,密钥 128/192/256 位。4)IDEA:分组64位,密钥 128 位。流密码(挨个处理)1.非对称密钥 密码:加密密钥和解密密钥不同,,其中一个用于加密,另一个用于解密。( 私钥 :持有人所有 公钥 :公开的)2. 加密密钥可以公开,也称公开密钥加密。3. 典型的公钥算法:Diffie-Hellman算法RSA算法密码散列函数1. 特性:定长输出;单向性(无法根据散列值逆推报文)抗碰撞性(无法找到具有相同散列值的两个报文)2. 典型的散列函数MD5:128位散列值SHA-1:160位散列值报文认证是使消息的接收者能够检验收到的消息是否是真实的认证方法。来源真实,未被篡改。1. 报文摘要(数字指纹)2. 报文认证方法简单报文验证:仅使用报文摘要,无法验证来源真实性报文认证码:使用共享认证密匙,但无法防止接收方篡改身份认证、数据完整性、不可否认性1. 简单数字签名:直接对报文签名2. 签名报文摘要1. 口令:会被窃听2. 加密口令:可能遭受回放/重放攻击加密的口令可能会被截获,虽然不知道口令是什么,但他将加密口令提交给服务器,说这是我加密的口令,这叫重放.3. 加密一次性随机数:可能遭受中间人攻击Alice发给Bob说她是Alice,但Bob说你要向我证明,Bob生成一个随机数发给Alice,让Alice用自己的私钥进行加密,加密后再把数据发给Bob,然后Bob再向Alice要公钥进行解密解出来的随机数如果和Bob发给Alice的随机数一样的话,那就说明她是Alice。这种方法会被中间人攻击,Alice发送的私钥加密被Trudy更换为自己用私钥加密的数据然后发给Bob,公钥也被Trudy换了,最后Bob用公钥加密数据发给Alice,Trudy截获了,用自己的私钥进行解密,获得了数据。密钥分发存在漏洞:主要在密钥的分发和对公钥的认证环节,这需要密匙分发中心与证书认证机构解决双方通信时需要协商一个密钥,然后进行加密,每次通信都要协商一个密钥,防止密钥被人截获后重复使用,所以密钥每次都要更换,这就涉及到密钥分发问题。基于 KDC 的秘钥生成和分发认证中心CA:将公钥与特定的实体绑定1. 证实一个实体的真实身份;2. 为实体颁发 数字证书 (实体身份和 公钥 绑定)。防火墙 :能够隔离组织内部网络与公共互联网,允许某些分组通过,而阻止其它分组进入或离开内部网络的软件、硬件或者软硬件结合的一种设施。前提 :从外部到内部和从内部到外部的所有流量都经过防火墙1.无状态分组过滤器基于特定规则对分组是通过还是丢弃进行决策,如使用实现防火墙规则。2.有状态分组过滤器跟踪每个TCP连接建立、拆除,根据状态确定是否允许分组通过。3.应用网关鉴别 用户身份 或针对 授权用户 开放 特定服务 。入侵检测系统(IDS):当观察到潜在的恶意流量时,能够产生警告的设备或系统。1. 电子邮件安全需求1)机密性2)完整性3)身份认证性4)抗抵赖性2. 安全电子邮件标准:1. SSL是介于和之间的安全协议.2. SSL协议栈(传统的TCP协议是没有安全协议的,传输都是明文,所以在TCP上面设置SSL协议保证安全性)3. SSL握手过程协商密码组,生成秘钥,服务器/客户认证与鉴别。1. VPN建立在上的安全通道,实现远程用户、分支机构、业务伙伴等与机构总部网络的安全连接,从而构建针对特定组织机构的专用网络。关键技术 :,如IPSec。2. 典型的 网络层安全协议 ——提供机密性、身份鉴别、数据完整性和防重放攻击服务。体系结构: 认证头AH协议 、 封装安全载荷ESP协议 。运行模式: 传输模式 (AH传输模式、ESP传输模式)、 隧道模式 (AH隧道模式、ESP隧道模式)本文主要介绍了网络安全基本概念、数据加密算法、消息完整性与数字签名、身份认证、密钥分发中心与证书认证机构、防火墙与入侵检测以及网络安全协议等内容。回顾:1. 网络安全基本属性2. 典型数据加密算法; 3. 消息完整性、数字前面以及身份认证原理。

各网络层安全协议有哪些
应用层 ·DHCP(动态主机分配协议)· DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议· RTCP (RTP Control Protocol)RTP 控制协议· RTSP (Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN (Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议· NTP (Network Time Protocol)网络校时协议传输层·TCP(Transmission Control Protocol)传输控制协议· UDP (User Datagram Protocol)用户数据报协议· DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议· SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议· RTP(Real-time Transport Protocol或简写RTP)实时传送协议· RSVP (Resource ReSer Vation Protocol)资源预留协议· PPTP ( Point to Point Tunneling Protocol)点对点隧道协议网络层IP(IPv4 · IPv6) Internet Protocol(网络之间互连的协议)ARP : Address Resolution Protocol即地址解析协议,实现通过IP地址得知其物理地址。RARP :Reverse Address Resolution Protocol 反向地址转换协议允许局域网的物理机器从网关服务器的 ARP 表或者缓存上请求其 IP 地址。ICMP :(Internet Control Message Protocol)Internet控制报文协议。它是TCP/IP协议族的一个子协议,用于在IP主机、路由器之间传递控制消息。ICMPv6:IGMP :Internet 组管理协议(IGMP)是因特网协议家族中的一个组播协议,用于IP 主机向任一个直接相邻的路由器报告他们的组成员情况。RIP : 路由信息协议(RIP)是一种在网关与主机之间交换路由选择信息的标准。OSPF :(Open Shortest Path First开放式最短路径优先).BGP :(Border Gateway Protocol )边界网关协议,用来连接Internet上独立系统的路由选择协议IS-IS:(Intermediate System to Intermediate System Routing Protocol)中间系统到中间系统的路由选择协议.IPsec:“Internet 协议安全性”是一种开放标准的框架结构,通过使用加密的安全服务以确保在 Internet 协议 (IP) 网络上进行保密而安全的通讯。数据链路层 802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN
IP,ARP,RARP,ICMP.

本文由 在线网速测试 整理编辑,转载请注明出处。