路由信息协议RIP解析
关于路由信息协议RIP解析路由信息协议RIP是内部网关协议IGP中最先得到广泛应用的协议,是一种距离矢量路由协议,RIP最大的特点是,无论实现原理还是配置方法,都非常简单。RIP的度量基于跳数,每经过一台路由器,路径的跳数加一。如此一来,跳数越多,路径就越长,RIP算法会优先选择跳数比较少的路径。RIP支持的最大跳数是15,跳数为16的网络被认为不可达。所以RIP协议适用于小型的网络环境。为了维持所学路由的正确性以及与邻居的一致性,运行RIP协议的路由器之间要周期性地向邻居传递之间的整个路由表。周期性(默认为30秒)传递的路由表被封装在Updata包--路由更新包中。具体说明到本自治系统中所有网络的.最短距离,以及到每个网络应经过的下一个路由器。在路由协议刚刚开始启动时,只知道到直连网络的距离。接着,每一个路由器只会和相邻的路由器交换信息。经过若干次的更新交换后,所有的路由器最终可以知道到达本自治系统中任何一个网络的最短距离和到达每个网络应该经过的下一个路由器地址。现在较新的RIP版本为1998年公布的RIPv2,与RIPv1相比,RIPv2可以支持变长子网掩码和CIDR,同时还提供简单的鉴别过程支持多播。RIP协议存在的一个问题是当网络出现故障时,路由表会频繁的变化,导致很长时间整个路由表都无法收敛。例如在2003年网络工程师下午试题五则体现了RIP协议的这一特点。同时广大网友可以可参阅《网络工程师考试冲刺指南》最新版P306页。为了让网络出现故障时能路由器能快速收敛,可以采取以下几种措施:1.水平分割:就是对于一台路由器来说,从一个方向上学习到的路由信息,不让同一路由信息再通过此接口向反方向传送。例如我们对照《网络工程师考试冲刺指南》最新版P306页的图,当路由器R3发现网段192.168.40.0出现故障时,就会把这条路由清除出路由器。由于水平分割的原因,路由器R2在向路由器R3发送路由更新包时,不能将关于192.168.40.0的网段放入该更新包,因为他是从路由器R3那里学过来。2.路由中毒:水平分割能避免路由环路。但在R1和R2路由器的路由表中,关于故障网段192.168.40.0的信息依然存在。这时候引入路由中毒的方法。当路由器R3发现网段192.168.40.0出现故障时,会首先对自己“下毒”,标记该路由不可达。然后再通过路由更新包给自己的邻居路由器R2“下毒”,这样通过一连串的“下毒”,整个网络都会知道192.168.40.0网段出现了故障。3.反向下毒:当路由器R2、R1被成功“下毒”后,他们会向“毒源”的方向反向“下毒”,这样保证所有的路由器都接受到了毒化的路由信息,虽然违反水平分割原则,但在路由协议中是被允许的。4.保持时间:指的是当路由器R3发现网段192.168.40.0出现故障时,使自己的路由表关于该网段的路由变成“可能DOWN”状态后,还要继续保持该状态一段时间。在此时间段内,路由器收到邻居发来的关于该网段的更新信息后,如果再次收到从邻居发送来的更新信息,包含一个比原来路径具有更好度量值的路由,就标记为可以访问,并取消保持时间。如果在保持时间超时之前从不同邻居收到的更新信息包含的度量值比以前的更差,更新将被忽略,这样可以有更多的时间让更新信息传遍整个网络。5.触发更新:正常情况下,路由器会定期将路由表发送给邻居路由器。而触发更新就是立刻发送路由更新信息,以响应某些变化。测到网络故障的路由器会立即发送一个更新信息给邻居路由器,并依次产生触发更新通知它们的邻居路由器,使整个网络上的路由器在最短的时间内收到更新信息,从而快速了解整个网络的变化。事实上,只依靠以上几种方法中的任何一种或几种,都不能完全解决路由表正确的问题,只有将几种方法联合起来才能凑效。 ;

RIP路由协议的主要特点有哪些
路由信息协议(rip) 是内部网关协议igp中最先得到使用的协议。rip是一种分布式的基于距离矢量的路由选择协议,是因特网的标准协议,其最大优点就是实现简单,开销较小。 但rip的缺点也较多。首先,其限制了网络的规模,能使用的最大距离为15(16表示不可达)。其次路由器交换的信息是路由器的完整路由表,因而随着网络规模的扩大,开销也就增加。最后,"坏消息传播得慢",使更新过程的收敛时间过长。因此对于规模较大的网络就应当使用ospf协议。然而目前在规模较小的网络中,使用rip协议的仍占多数。
RIP 协议的特点是: (1)仅和相邻路由器交换信息。【注】如果两个路由器之间的通信不需要经过另一个路由器,那么这两个路由器就是相邻的。RIP协议规定,不相邻的路由器不交换信息。(2)路由器交换的信息是当前本路由器所知道的全部信息,即自己的路由表。【注】交换的信息是:“我到本自治制系统中所有网路的(最短)距离,以及到每个网络应该经过的下一跳路由器。” (3)按固定的时间间隔交换路由信息。【注】每个30秒,然后路由器根据收到的路由信息更新路由表。当网路拓扑发生变化时,路由器也及时向相邻路由器通告拓扑变化后的路由信息。

请问rip路由协议配置的具体步骤是什么?谢谢
1、确定所要配置的网络组网及相关ip规划,然后进行具体的配置。2、首先进行路由器的端口ip配置,下面以路由器R2为例,R1与R3的配置命令类似,只用修改IP即可:R2#conf t (configure terminal的简写)R2(config)#int f 0/0 (interface fastEthernet f 0/0,进入该接口配置模式)R2(config-if)#ip add 192.168.12.2 255.255.255.0 (接口配置ip地址)R2(config-if)#no shut (激活接口)R2(config-if)#int f 0/1R2(config-if)#ip add 192.168.21.1 255.255.255.0R2(config-if)#no shutR2(config-if)#int s 1/0R2(config-if)#ip add 192.168.23.2 255.255.255.0R2(config-if)#no shutR2(config-if)#endR2#show ip route(查看路由表)3、配置完成后,通过命令"show ip interface brief"查看路由的各接口ip配置是否正确。并验证与非直连网段的互通性,由于此时还没有到非直连网段的路由,故此时不通。4、在路由器上启动rip协议:R2#conf tR2(config)#router rip(进入rip协议配置)R2(config-router)#version 2 (启用rip v2版本)R2(config-router)#no auto (关闭路由自动汇总)R2(config-router)#network 192.168.12.0 (通过RIP宣告该网段)R2(config-router)#network 192.168.21.0R2(config-router)#network 192.168.23.0R2(config-router)#end5、rip配置完成后,通过"show ip route"查看路由表中存在有"R"标识的rip协议路由。6、再次验证费直连网络的互通性,此时可以相互通信。
enable 进入特权模式 config t进入全局配置模式int 【端口】进入端口配置模式ip add 【ip地址+ 子网掩码】 配置端口ip地址 子网掩码no shut 激活端口exit退回到全局配置模式router rip开启rip协议network 【ip 网段】 宣告地址范围end回到特权模式wr保存配置排错用到的命令show run查看全局配置show ip intbri查看简要接口信息 是否激活 ip地址对与不对 show ip router查看路由表信息 有没有没宣告的 没学习到的
以H3C为例 【H3C】rip 1 (启用rip,rip进程1)【H3C-rip-1】network 192.168.1.0 (把网段宣告进rip中)【H3C-rip-1】network 192.168.2.0(同上)【H3C-rip-1】version 2 (ripv2)【H3C-rip-1】undo summary (关闭自动聚合) 如果配置RIPv1,则最后两句不用配置。
以思科路由器为例 enableconf trouter ripnetwork + ip地址 大致就这么几步,公布的ip要包括想要通告的路由和自己想要传输rip信息的端口ip地址。

RIP路由选择协议
典型的路由协议有rip,ospf,isis,bgp等。rip是用经过的路由器跳数来衡量的,最少的跳数就是最优路由。 RIP共有三个版本,RIPv1, RIPv2, RIPng其中RIPV1和RIPV2是用在IPV4的网络环境里,RIPng是用在IPV6的网络环境里。 因为RIPv1的缺陷,RIPv2在1994年被提出,将子网络的资讯包含在内,透过这样的方式提供无类别域间路由,不过对于最大节点数15的这个限制仍然被保留着。另外针对安全性的问题,RIPv2也提供一套方法,透过加密来达到认证的效果。而之后[RFC 2082 ]也定义了利用MD5来达到认证的方法。 RIPv2的相关规定在[RFC 2453 ] orSTD56。现今的IPv4网络中使用的大多是RIPv2,RIPv2是在RIPv1基础上的改进, RIPv2和RIPv1相比主要有以下区别。RIPng(Routing Information Protocol next generation)则被定义在[RFC 2080 ],主要是针对IPv6做一些延伸的规范。与RIPv2相比下其最主要的差异是:RIPv2 支持RIP更新认证, RIPng 则没有 (IPv6 routers were, at the time, supposed to use IPsec for authentication);RIPv2 容许附上arbitrary 的标签, RIPng 则不容许;RIPv2 encodes the next-hop into each route entries, RIPng requires specific encoding of the nexthop for a set of route entries. RIPv2 UDP的Port number 为 520,RIPng UDP的Port number 为 521

网络里面RIP是什么?
简单说,RIP 是路由信息协议( Routing Information Protocol)的缩写。它是一种动态路由选择协议。RIP协议基于距离矢量算法衡量到达目标地址的路由距离。这种协议的路由器只关心自己周围的网络,只与自己相邻的路由器交换信息。RIP 应用于 OSI 参考模型的第七层(即应用层)。
我一本正经地胡说一下吧。 RIP是一种分布式的基于距离向量的路由选择协议,是因特网的标准协议,其最大的优点就是简单
RIP协议:一种内部网关协议
距离矢量路由协议只对自己的相邻的路由器交换路由表

本文由 在线网速测试 整理编辑,转载请注明出处。