计算机网络协议的概念是什么,有大神能概括一下吗?
网络协议为计算机网络中进行数据交换而建立的规则、标准或约定的集合。 例如,网络中一个微机用户和一个大型主机的操作员进行通信,由于这两个数据终端所用字符集不同,因此操作员所输入的命令彼此不认识。为了能进行通信,规定每个终端都要将各自字符集中的字符先变换为标准字符集的字符后,才进入网络传送,到达目的终端之后,再变换为该终端字符集的字符。当然,对于不相容终端,除了需变换字符集字符外还需转换其他特性,如显示格式、行长、行数、屏幕滚动方式等也需作相应的变换。
在计算机网络中,为使计算机之间或计算机与终端设备之间能有序而准确的传送数据,必须在数据传输顺序、格式和内容等方面有统一的标准、约定或规则,这组标准、约定或规则称为计算机网络协议。 参考资料:《大学计算机-计算思维导论》,清华大学出版社2019
在计算机网络中要做到有条不紊的交换、传递数据,就必须遵守一些事先约定好的 数据格式、同步问题等,我们把这些在计算机之间实现通信要遵守的有关规则称为计算机网 络协议。
这上面回答你的,应该都是直接百度的吧,谁能一句话说清楚的,好想膜拜
这个问题,估计你直接百度会有很全面的答案

什么是计算机网络协议
网络上的计算机之间又是如何交换信息的呢?就像我们说话用某种语言一样,在网络上的各台计算机之间也有一种语言,这就是网络协议,不同的计算机之间必须使用相同的网络协议才能进行通信。 网络协议是网络上所有设备(网络服务器、计算机及交换机、路由器、防火墙等)之间通信规则的集合,它定义了通信时信息必须采用的格式和这些格式的意义。大多数网络都采用分层的体系结构,每一层都建立在它的下层之上,向它的上一层提供一定的服务,而把如何实现这一服务的细节对上一层加以屏蔽。一台设备上的第 n层与另一台设备上的第n层进行通信的规则就是第n层协议。在网络的各层中存在着许多协议,接收方和发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息。网络协议使网络上各种设备能够相互交换信息。常见的协议有:TCP/IP协议、IPX/SPX协议、NetBEUI协议等。在局域网中用得的比较多的是IPX/SPX.。用户如果访问Internet,则必须在网络协议中添加TCP/IP协议。TCP/IP是“transmission Control Protocol/Internet Protocol”的简写,中文译名为传输控制协议/互联网络协议)协议, TCP/IP(传输控制协议/网间协议)是一种网络通信协议,它规范了网络上的所有通信设备,尤其是一个主机与另一个主机之间的数据往来格式以及传送方式。TCP/IP是INTERNET的基础协议,也是一种电脑数据打包和寻址的标准方法。在数据传送中,可以形象地理解为有两个信封,TCP和IP就像是信封,要传递的信息被划分成若干段,每一段塞入一个TCP信封,并在该信封面上记录有分段号的信息,再将TCP信封塞入IP大信封,发送上网。在接受端,一个TCP软件包收集信封,抽出数据,按发送前的顺序还原,并加以校验,若发现差错,TCP将会要求重发。因此,TCP/IP在INTERNET中几乎可以无差错地传送数据。 对普通用户来说,并不需要了解网络协议的整个结构,仅需了解IP的地址格式,即可与世界各地进行网络通信。IPX/SPX是基于施乐的XEROX’S Network System(XNS)协议,而SPX是基于施乐的XEROX’S SPP(Sequenced Packet Protocol:顺序包协议)协议,它们都是由novell公司开发出来应用于局域网的一种高速协议。它和TCP/IP的一个显著不同就是它不使用ip 地址,而是使用网卡的物理地址即(MAC)地址。在实际使用中,它基本不需要什么设置,装上就可以使用了。由于其在网络普及初期发挥了巨大的作用,所以得到了很多厂商的支持,包括microsoft等,到现在很多软件和硬件也均支持这种协议。NetBEUI即NetBios Enhanced User Interface ,或NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用,例如Windows for Workgroup、Win 9x系列、Windows NT等。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。总之NetBEUI协议是一种短小精悍、通信效率高的广播型协议,安装后不需要进行设置,特别适合于在“网络邻居”传送数据。所以建议除了TCP/IP协议之外,局域网的计算机最好也安上NetBEUI协议。另外还有一点要注意,如果一台只装了TCP/IP协议的WINDOWS98机器要想加入到WINNT域,也必须安装NetBEUI协议。一个网络协议至少包括三要素:语法用来规定信息格式;语义用来说明通信双方应当怎么做; 时序详细说明事件的先后顺序。
计算机网络的最大特点是通过不同的通信介质把不同厂家、不同操作系统的计算机和其他相关设备(例如打印机、传达室感器等)连接在一起,打破时间和空间的界限,共享软硬件资源和进行信息传输。然而,如何实现不同传输介质上的不同软硬件资源之间的通令共享呢?这就需要计算机与相关设备按照相同的协议,也就是通信规则的集合来进行通信。这正如人类进行通信、交谈时要使用相同的语言一样。 网络协议(Network Protcol)是计算机网络中互相通信的对等实体间交换信息时所必须遵守的规则的集合。当前的计算机网络的体系结构是以TCP/IP协议为主的Internet结构。对等实体通常是指在计算机网络体系结构中处于相同层次的通信协议进程。网络协议为传输的信息宣言严格的格式(语法)和传输顺序(文法)。而且还定义所传输信息的词汇表和这些词汇所表示的意义(语义)。既然谈到Internet网络,那我们就来看一下网络协议与Internet网络的关系:Internet网络体系结构以TCP/IP协议为核心。其中IP协议用来给各种不同的通信子网或局域网提供一个统一的互连平台,TCP协议则用来为应用程序提供端到端的通信和控制功能。事实上,Internet并不是一个实际的物理网络或独立的计算机网络,它是世界上各种使用统一TCP/IP协议的网络的互连。TCP/IP协议分为4层(通信子网层、网络层、运输层和应用层)1、通信子网层(subnetwork layer)TCP/IP协议的通信子网层与OSI协议的物理层 、数据链路层以及网络层的一部分相对应。该层中所使用的协议为各通信子网本身固有的协议,例如以太网的802.3协议、令牌环网的802.5协议有及分组交互网的X.25协议等。通信子网层的作用是传输经网络层处理过的消息。2、网络层(internet layer)网络层所使用的协议是IP协议。它把运输层送来的消息组装成IP数据包,并把IP数据包传递给通信子网层。IP协议提供统一的IP数据格式,以消除各通信子层的差异,从而为信息发送方和接收方提供透明通道。网络层的主要功能是:①Internet全网址的识别与管理;②IP数据包路由功能;③发送或接收时例IP数据包的长度与通信子网所允许的数据包长度相匹配,例如,以太网所传输的帧长为1500字节,而ARPA网所传输的数据包长1008字节。当以太网上的数据帧通过网络层IP协议转达发给ARPA网时,就要进行数据帧的分解处理。3、运输层(transport layer)运输层为应用程序提供端到羰通信功能。运输层有3个主要协议,即传输控制的协议(TCP)、用户数据报协议(UDP)和互连网控制消息协议(ICMP)。4、应用层(application layer) 应用层为用户提供所需要的各种服务。它提供的主要服务有:过程登录,用户可以使用异地主机;文件传输,用户可在不同主机之间传输文件;电子邮件,用户可通过主机和终羰互相发送信件;Web服务器,发布和访问具有超文本格式HTML的各种信息。|
是 芯片厂商之前的协议 我这么说吧芯片与芯片直接的协议好比 你要上网 大家可以自主研发 芯片有华硕 INTELAMD 等你都听过的问题来了谁 说了 算 信号频率 怎么说 还有个个国家 怎么讲全球 GPS 等最后由老大早期的美国旗下附属 INTEL来做个民用的基本 通讯的 频率下的一个基础 协定以后各国参考按照这个 民用就这么做出来卓见的演变成全球通用最后成为 今天的 网络协议
通信双方在通信中必须遵守的规定。 在现实的网络中需要遵守的协议就是TCPIP协议
什么是计算机网络协议,网络工程师通过动画视频,通俗易懂来讲解

(协议)在计算机网络中的名词解释
为了使数据在网络上从源到达目的,网络通信的参与方必须遵循相同的规则,这套规则称为协议(protocol),它最终体现为在网络上传输的数据包的格式。 它的三要素是:语法、语义、时序。

简述计算机网络协议
网络协议概述 在网络的各层中存在着许多协议,它是定义通过网络进行通信的规则,接收方的发送方同层的协议必须一致,否则一方将无法识别另一方发出的信息,以这种规则规定双方完成信息在计算机之间的传送过程。 要使服务器支持远程启动服务,必须在服务器上安装DLC(Data Link Control)和NetBEUI(NetBIOS Extended User Interface)协议,并确保工作站能用这些协议与服务器通讯。 DLC不同于NT中的其它协议如NetBEUI和TCP/IP,DLC协议并不在OSI参考模型的网络层和传输层发挥作用,而是向较高层提供了一个与数据链路层的直接接口。使用DLC,可使得NT计算机可以运行访问主机系统的软件,使得NT计算机作为直连网络的打印机的打印服务器。通常我们不把DLC作为PC和PC的通信的主协议。NetBIOS扩展用户接口协议(NetBEUI)最初由IBM于1995年开发的,被优化为在用于非常高的性能,在一个LAN分段里的通信。NetBEUI是NT发行的协议中速度最快的一种协议之一。它还具有良好的错误保护,占用很少的内存,但它不支持路由选择且跨WAN的性能很差。 而TCP/IP则成为当前应用协议中无可非议的标准。
·DHCP(动态主机分配协议) · DNS (域名解析)· FTP(File Transfer Protocol)文件传输协议· Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)· HTTP (Hypertext Transfer Protocol)超文本传输协议· IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本· IRC (Internet Relay Chat )网络聊天协议· NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议· XMPP 可扩展消息处理现场协议· POP3 (Post Office Protocol 3)即邮局协议的第3个版本· SIP 信令控制协议· SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议· SNMP (Simple Network Management Protocol,简单网络管理协议)· SSH (Secure Shell)安全外壳协议· TELNET 远程登录协议· RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议·RTCP (RTP Control Protocol)RTP 控制协议· RTSP(Real Time Streaming Protocol)实时流传输协议· TLS (Transport Layer Security Protocol)安全传输层协议· SDP( Session Description Protocol)会话描述协议· SOAP (Simple Object Access Protocol)简单对象访问协议· GTP 通用数据传输平台· STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议 · NTP (Network Time Protocol)网络校时协议
计算机网络协议:网络协议就是计算机之间进行通信的规则。为了使处于不同地点、装有不同操作系统的计算机之间有效地通信,必须有一种为各类计算机都能认可的通信方法,任一方所表达的信息均能被其他各方所认同,这就需要指定一种标准:网络协议。 就象老师在讲课时为了大家都能听懂,就必须使用普通话一样。最常用的协议有TCP/IP协议。

计算机网络的协议是什么?
计算机协议,也叫作网络协议,是通信计算机双方必须共同遵从的一组约定。为了使数据在网络上从源到达目的,网络通信的参与方必须遵循相同的规则,这套规则称为协议,它最终体现为在网络上传输的数据包的格式。最常见的计算机协议是OSI/RM协议。国际标准化组织(ISO)在1978年提出了“开放系统互联参考模型”,即著名的OSI/RM模型。它将计算机网络体系结构的通信协议划分为七层,自下而上依次为:物理层、数据链路层、网络层、传输层、会话层、表示层、应用层。其中第四层完成数据传送服务,上面三层面向用户。扩展资料常见的计算机协议还有:1、IPX/SPX协议是Novell开发的专用于NetWare网络中的协议,但是也非常常用。大部分可以联机的游戏都支持IPX/SPX协议,比如星际争霸,反恐精英等等。2、ARP/RARP协议地址解析协议,原理是主机发送信息时将包含目标IP地址的ARP请求广播到网络上的所有主机,并接收返回消息,以此确定目标的物理地址;收到返回消息后将该IP地址和物理地址存入本机ARP缓存中并保留一定时间,下次请求时直接查询ARP缓存以节约资源。3、TCP/IP协议是Internet最基本的协议、Internet国际互联网络的基础,由网络层的IP协议和传输层的TCP协议组成。通俗而言:TCP负责发现传输的问题,一有问题就发出信号,要求重新传输,直到所有数据安全正确地传输到目的地。而IP是给因特网的每一台联网设备规定一个地址。参考资料来源:百度百科-协议
刚才说过网络体系结构的关键要素之一就是网络协议。而所谓协议(Protocol)就是对数据格式和计算机之间交换数据时必须遵守的规则的正式描述,它的作用和普通话的作用如出一辙。依据网络的不同通常使用Ethernet(以太网)、NetBEUI、IPX/SPX以及TCP/IP协议。Ethernet是总线型协议中最常见的网络低层协议,安装容易且造价便宜;而NetBEUI可以说是专为小型局域网设计的网络协议。对那些无需跨经路由器与大型主机通信的小型局域网,安装NetBEUI协议就足够了,但如果需要路由到另外的局域网,就必须安装IPX/SPX或TCP/IP协议。前者几乎成了Novell网的代名词,而后者就被著名的Internet网所采用。

本文由 在线网速测试 整理编辑,转载请注明出处。