tcp连接是逻辑连接吗(无效连接类型,仅支持TCP连接)

      最后更新:2023-05-05 07:13

      传输层Transport layer TCP, since 2020-08-05

      (2020.08.07)TCP被称为面向连接的(connection-oriented),这是因为一个进程可以向另一个进程发送数据之前,两个进程需要先握手,即他们开始互相发送预备报文段,以确保建立数据连接的参数。TCP是逻辑连接,其共同状态仅保存在两个通信端系统的TCP程序中。而端系统之间的网络元素不会维持TCP的连接状态。中间路由器对TCP完全视而不见,他们只看到数据报,而非连接。通信特点全双工(full-duplex service),处在不同主机的进程A和进程B之间存在一条连接,数据可以同时从A流向B和从B流向A。点对点(point-to-point),在单个发送方和单个接收方之间的连接。服务器进程和客户进程发起连接的进程称为客户进程,另一个称为服务器进程。(2020.08.08)数据一旦被送进socket,就由客户TCP控制了,TCP将数据放在一个数据缓存(send buffer)里(C/S两端都有),该缓存也是三次握手时数据存放处。TCP会从缓存中取出一块数据,传递给网络层。TCP首部+客户数据=TCP报文段(TCP segment)TCP从send buffer中取出并放入报文段中数据的数据量受限于最大报文段长度(maximum segment size, MSS),其根据最初确定的由本地主机发送的最大链路层帧长度(即最大传输单元Maximum transmission unit, MTU)来设置。以太网和PPP链路都有1500字节的MTU,考虑到TCP/IP首部一般是40字节(TCP首部20字节),TCP报文段中数据长度典型值是1460字节。注意到这里的MSS指的是TCP报文段中来自应用层的数据的最大长度。TCP连接的组成一台主机上的缓存、变量和连接进程的socket,以及另一台主机上的缓存、变量、socket。首部+数据字段。当TCP发送一个大文件,比如图片,TCP通常将该文件划分成长度为MSS的若干,除最后一块,其他的都是MSS长度。而Telnet这样的应用,数据字段只有一个字节长,也就是其TCP一般只有21个字节的长度。典型长度:20字节/160bits(选项字段为空时)源端口号:16bits目的端口号:16bits序号(seq num):32bits确认号(acknowledgment num):32bits接收窗口(receive window field):16bits,用于流量控制,指示接收方愿意接收的字节数量首部长度(header length field):4bits,以32bits的字为长度的TCP首部长度选项字段(options):可选和变长标志字段(flag field):6bits,ACK/RST/SYN/FIN/PSH/URG序号建立在传送的字节流之上而非报文段的序列值上,the sequence number for a segment是报文段首字节的字节流编号。比如一个待发送的文件共10,000个字节,每个TCP的报文段发送1,000个,则第一个报文段的序号是0,第二个序号是1,000,以此类推。该序号是字节的编号,并用于给报文段编号。上面的例子中假设初始序号是0,在实际应用中收发两方随机选择初始序号。确认号略复杂。主机A和B之间建立TCP通信,主机A填充进报文段的确认号是A期望从B收到的下一个字节的序号。报文段的样本RTT(SampleRTT)是报文段被发出(交给IP)到对该报文段的确认被收到之间的时间量。仅为一个已经发送的但目前尚未被确认的报文段估计SRTT,从而产生一个接近每个RTT的新SRTT值;不为已经被重传的报文段计算SRTT;仅为传输一次的报文段测量SRTT。由于网络环境变化,比如路由器的拥塞和端负载的变化,SRTT并不都是典型的。TCP会维持一个SRTT的均值(EstimatedRTT),并根据下面公式计算ERTT其中的推荐值。该指数加权移动平均值(Exponential Weighted Moving Average, EWMA)赋予最近样本的权值要高于旧样本的权值,因越近的样本能更好的反应网络的拥塞状态。此外,RTT的标准差DevRTT用于估算SRTT偏离ERTT的程度:推荐值。超时间隔应该大于等于ERTT,否则造成不必要的重传。但也不该比ERTT大很多,导致数据传输时延大。当SRTT波动大时,间隔大些,波动小时,间隔小些。初始推荐值,当出现超时候翻倍。只要收到报文就更新ERTT,并根据公式重算TimeoutInterval。(2020.08.09 Sat)定时器定时器的管理需要相当大的开销,因此[RFC 6298]推荐仅使用单一的重传定时器,即便有多个已发送但未被确认的报文段。(2020.08.09 Sat)TCP中发送方相关的三个主要动作发送方对这些主要动作的反馈参考可靠数据传输的部分。超时间隔的选取每当超时事件发生,TCP重传具有最小序号的未被确认的报文段。只是每次TCP重传是都会将下一次的超时间隔设为先前值的两倍,而不是用从EstimatedRTT和DevRTT推算的值。然而每当定时器遇到另外两个事件,即ACK和上层数据,定时器的启动TimeoutInterval由最近的ERTT和DRTT推算得到。TCP两侧的主机都有接收缓存。流量控制服务用于消除sndr使rcvr缓存溢出的可能性。fcs因此是一个速度匹配服务,即sndr的发送速率和rcvr应用程序的读取速率相匹配。TCP让sndr维护一个接收窗口(receive window)的变量来提供流量控制,即rw用于给sndr一个指示-该sndr还有多少可用的缓存空间。TCP是全双工通信,两端的发送方都维护一个rw。分析一种情况,主机A通过TCP向B发送一个大文件,B为该连接分配一个接收缓存,用RcvBuffer来表示。B的应用进程从该缓存中读取数据。有如下变量缓存不许溢出,故有接收窗口用rwnd表示,缓存可用空间数量(即空闲的空间数量)表示为主机A需要跟踪另外两个变量,LastByteSent和LastByteAcked,对A来说有一个特例,当B的接收缓存满,rwnd=0,假设此时B没有任何数据要发送给A。考虑到TCP并不向A发送带有rwnd的新报文段, 而事实上TCP仅当有数据或去人要发时才会发送报文段给A。导致A不知道B的接收缓存有新空间,A被阻塞不能在发送数据。解决方案,TCP规范要求,B的接收窗口为0时,A继续发送只有一个字节数据的报文段,这些报文段将会被接收方确认,最终缓存开始清空,且确认报文段将包含一个非0的rwnd值。(2020.08.05)TCP建立过程中三个握手(three-way handshake)的作用三次发送,sndr/rcvr双方各自确认了自身和对方的接收能力和发送能力。握手完成便可建立连接。(2020.08.07)前两次握手的报文段不承载"有效载荷",也就是不包含应用层数据,第三个握手可以承载应用层数据。(2020.08.09 Sat)完成这三步,C-S可通信,以后每一个报文段的SYN都设置为0。结束连接客户打算结束连接,发出一个特殊的报文段,设置其中的FIN=1。服务器接收到回复一个确认报文段,其中的FIN=1。服务器再次发送一个结束连接报文段,FIN=1。客户收到后发送ACK并释放占用的资源。IP层不会向两个端系统提供有关网络拥塞的反馈信息。略。发送方sndr设定一个变量,拥塞窗口congestion windown,cwnd,它对TCP发送方能向网络中发送流量的速率进行了限制,并且和前面提到的接收窗口rwnd联合决定了发送速率,即TCP如何感知它和目的地之间的拥塞定义丢包事件:出现超时,或者受到来自接收方的3个冗余ACK。一个丢失的报文段意味着拥塞,当报文丢失应该降低TCP sndr的发送速率。即减小cwnd。一个确认报文段指示该网络正在向rcvr交付sndr的报文段,因此,当对先前未确认报文段的确认到达时,能够增加发送方的速率。贷款检测。该算法分为三部分,1)慢启动,2)拥塞避免,3)快速恢复。其中的1和2是TCP强制部分。在收到ACK时,慢启动比拥塞避免更快的增加cwnd的长度。当一个TCP连接开始时,cwnd的值通常设为一个MSS的较小值。这使得发送速率大约为MSS/RTT。如MSS=500Bytes,RTT=200ms,则初始发送速率是20kbps。注意到此时带宽可能比初始速率快的多。慢启动(slow-start)状态,cwnd的值以一个MSS开始并且每当传输的报文段首次被确认就增加一个MSS。这一过程使得每过一个RTT,发送速率就翻番。初始速度慢,但ss阶段以指数增长。结束ss的情况
      传输层Transport layer TCP, since 2020-08-05

      TCP的连接方式是什么?

      TCP是因特网中的传输层协议,使用三次握手协议建立连接。当主动方发出SYN连接请求后,等待对方回答 TCP的三次握手SYN+ACK,并最终对对方的 SYN 执行 ACK 确认。这种建立连接的方法可以防止产生错误的连接,TCP使用的流量控制协议是可变大小的滑动窗口协议。TCP三次握手的过程如下:客户端发送SYN(SEQ=x)报文给服务器端,进入SYN_SEND状态。服务器端收到SYN报文,回应一个SYN (SEQ=y)ACK(ACK=x+1)报文,进入SYN_RECV状态。客户端收到服务器端的SYN报文,回应一个ACK(ACK=y+1)报文,进入Established状态。 三次握手完成,TCP客户端和服务器端成功地建立连接,可以开始传输数据了。
      首先纠正你一点。。不是连接方式。。是数据的交换方式。。 TCP属于分组交换方式。。
      TCP/IP(Transmission Control Protocol/Internet Protocol) 即传输控制协议/网间协议,是一个工业标准的协议集,它是为广域网(WANs)设计的。它是由ARPANET网的研究机构发展起来的。 有时我们将TCP/IP描述为互联网协议集"Internet Protocol Suite",TCP和IP是其中的两个协议(后面将会介绍)。由于TCP和IP是大家熟悉的协议,以至于用TCP/IP或IP/TCP这个词代替了整个协议集。这尽管有点奇怪,但没有必要去争论这个习惯。例如,有时我们讨论NFS 是基于TCP/IP时,尽管它根本没用到TCP(只用到IP,和另一种交互式 协议UDP而不是TCP)。Internet是网络的集合,包括ARPANET、NSFNET、分布在各地的局域网、以及其它类型的网络,如(DDN,Defense Data Network美国国防数据网络),这些统称为Internet。所有这些大大小小的网络互联在一起。(因为大多数网络基本协议是由DDN组织开发的,所以以前有时DDN与Internet在某种意义上具有相同的含义)。网络上的用户可以互相传送信息,除一些有授权限制和安全考虑外。一般的讲,互联网协议文档案是Internet委员会自己采纳的基本标准。 TCP/IP标准与其说由委员会指定,倒不如说由"舆论"来开发的。 任何人都可以提供一个文档,以RFC(Request for Comment需求注释) 方式公布。TCP/IP的标准在一系列称为RFC的文档中公布。文档由技术专家、特别工作组、或RFC编辑修订。公布一个文档时,该文档被赋予一个RFC量,如RFC959说明FTP、RFC793说明TCP、RFC791说明IP等。 最初的RFC一直保留而从来不会被更新,如果修改了该文档,则该文档又以一个新号码公布。因此,重要的是要确认你拥有了关于某个专题的最新RFC文档。文后会列出主要的RFC文档号。不管怎样,TCP/IP是一个协议集。为应用提供一些"低级"功能,这些包括IP、TCP、UDP。其它是执行特定任务的应用协议,如计算机间传送文件、发送电子邮件、或找出谁注册到另外一台计算机。因此, 最重要的"商业"TCP/IP服务有:* 文件传送File Transfer。文件传送协议FTP(File Transfer Protocol)允许用户从一台计算机到另一台取得文件,或发送文件到另外一台计算机。从安全性方面考虑,需要用户指定一个使用其它计算机的用户名和口令。它不同与NFS(Network File System)和Netbios协议。一旦你要访问另一台 系统中的文件,任何时刻都要运行FTP。而且你只能拷贝文件到自己的机器中去来使用它。(RFC 959中关于FTP的说明)* 远程登录Remote login网络终端协议TELNET允许用户登录到网络上任一计算机上。你可启动一个远程进程连接到指定的计算机,直到进程结束,期间你所键入的内容被送到所指定的计算机。值得注意的是,这时你实际上是与你的计算机进行对话。TELENET程序使得你的计算机在整个过程中不见了,所敲的每一个字符直接送到所登录的计算机系统。一般的说,这种远程连接是通过类式拨号连接的,也就是,拨通后,远程系统提示你输入注册名和口令,退出远程系统,TELNET程序也就退出,你又与自己的计算机对话了。微电脑中的TELNET工具一般含有一个终端仿真程序。* 计算机邮件Mail允许你发送消息给其它计算机的用户。通常,人们趋向于使用指定的一台或两台计算机。计算机邮件系统只需你简单地往另一用户的邮件文件中添加信息,但随之产生问题,使用的微电脑的环境不同,还有重要的是宏(MICRO)不适合于接受计算机邮件。为了发送电子邮件,邮件软件希望连接到目的计算机,如果是微电脑,也许它已关机,或者正在运行另一个应用程序呢?出于这种原因,通常由一个较大的系统来处理这些邮件,也就是一个一直运行着的邮件服务器。邮件软件成为用户从邮件服务器取回邮件的一个界面。任何一个的TCP/IP工具提供上述这些服务。这些传统的应用功能在基于TCP/IP的网络中一直扮演非常重要的角色。目前情况有点变化,这些功能使用也发生变化,如老系统的改造,计算机的发展等,出现了各种安装版本,如:微电脑、工作站、小型机、和巨型机等。这些计算机好象在一起完成指定的任务,尽管有时看来像是只用到某个指定 的计算机,但它是通过网络得到其它计算机系统的服务。服务器Server是为网络上其它提供指定服务的系统,客户Client是得到这种服务的另外计算机系统。(值得注意的是,服务/客户机不一定是不同的计算机,有可能是同一计算机中的不同运行程序)。以下是几种目前计算机上典型的一些服务,这些服务可在TCP/IP网络上调用。* 网络文件系统(NFS)这种访问另一计算机的文件的方法非常接近于流行的FTP。网络文件系统提供磁盘或设备服务,而无需特定的网络实用程序来访问另一系统的文件。可以简单地认为它是一个外加的磁盘驱动器。这种额外"虚拟"磁盘驱动器就是其它计算机系统的磁盘。这非常有用。你只需加大几台计算机的磁盘容量,就可使网络上其他用户访问它,且不说所带来的经济效益,它还能够让几台工作的计算机共享相同的文件。它也使得系统维护和备份易如反掌,因为再不必为大量的不同机器上 的文件的升级和备份而担心。* 远程打印(Remote printing)允许你使用其它计算机上的打印机,好象这些打印机直接连到你的计算机上。* 远程执行(Remote execution)允许你请求运行在不同计算机上的特殊程序。当你在一个很小的计算机上运行一个需要大机系统资源的程序时,这时候远程执行非常有用。* 名字服务器(Name servers)在一个大的系统安装过程中,需要用到大量的各种名字,包括用户名、口令,姓名、网络地址、帐号等,管理这些是非常令人乏味的。因此将这些数据形成数据库,放到一个小系统中去,其它系统通过网络来访问这些数据。* 终端服务器(Terminal servers)很多的终端连接安装不再直接将终端连到计算机,取而代之的是,将他们连接到终端服务器上。终端服务器是一个小的计算机,它只需知道怎样运行TELNET(或其它一些完成远程登录的协议)。如果你的终端想连上去,只用键入要连的计算机名就可。通常有可能同时有几个这种连接,这时终端服务器采用快速开关技术来切换。 上述所描述的一些协议是由Berkeley, Sun,或其它组织定义的。因此,它们不是互联网协议集(Internet Protocol Suite)的一部分, 只是使用到TCP/IP的工具,如同一般的TCP/IP 应用协议。因为协议的定义不一致,并且商业支持的TCP/IP工具广泛应用,也许会把这些协议作为互联协议集中的一部分。上述列出的只是基于TCP/IP部分服务的一些简单例子,但包含了一些"主要"的应用。
      TCP的连接方式是什么?

      局域网的物理连接和逻辑连接的含义?谢谢

      你好! 就像楼上说的物理连接是看得见摸的着的逻辑连接则是像TCP/IP这一类的协议等系统底层的连接. 如果对你有帮助,望采纳。
      局域网的物理连接和逻辑连接的含义?谢谢

      什么是TCP连接

      TCP即传输控制协议。TCP连接是互联网连接协议集的一种。TCP通信最重要的特征是:有序和可靠。有序通过将文本流分段并编号实现,可靠通过ACK回复和重复发送实现。TCP连接状态图参考文章:TCP连接过程详解blog.163.com/hlz_2599/blog/static/142378474201151943414397/
      TCP/IP(Transmission Control Protocol/Internet Protocol) 即传输控制协议/网间协议,是一个工业标准的协议集,它是为广域网(WAN)设计的。它是由ARPANET网的研究机构发展起来的。   有时我们将TCP/IP描述为互联网协议集"InternetProtocolSuite",TCP和IP是其中的两个协议(后面将会介绍)。由于TCP和IP是大家熟悉的协议,以至于用TCP/IP或IP/TCP这个词代替了整个协议集。这尽管有点奇怪,但没有必要去争论这个习惯。例如,有时我们讨论NFS是基于TCP/IP时,尽管它根本没用到TCP(只用到IP,和另一种交互式 协议UDP而不是TCP)。   TCP/IP的标准在一系列称为RFC的文档中公布。文档由技术专家、特别工作组、或RFC编辑修订。公布一个文档时,该文档被赋予一个RFC编号,如RFC959(FTP的说明文档)、RFC793(TCP的说明文档)、RFC791(IP的说明文档)等。最初的RFC一直保留而从来不会被更新,如果修改了该文档,则该文档又以一个新号码公布。因此,重要的是要确认你拥有了关于某个专题的最新RFC文档。通常在RFC的开头部分,有相关RFC的更新(update)、修改(errata)、作废(obsolete)信息,提示读者信息的时效性。
      TCP/IP(Transmission Control Protocol/Internet Protocol) 即传输控制协议/网间协议,是一个工业标准的协议集,它是为广域网(WAN)设计的
      什么是TCP连接

      TCP协议的主要功能是 单选

      TCP协议主要功能是在传输数据前先在发送端和接收端建立逻辑连接,然后再传输数据,提供了两台计算机之间可靠无差错的数据传输。在TCP连接中必须要明确客户端与服务器端,由客户端向服务端发出连接请求,每次连接的创建都需要经过“三次握手”。第一次握手,客户端向服务器端发出连接请求,等待服务器确认第二次握手,服务器端向客户端回送一个响应,通知客户端收到了连接请求第三次握手,客户端再次向服务器端发送确认信息,确认连接扩展资料TCP为了保证报文传输的可靠,就给每个包一个序号,同时序号也保证了传送到接收端实体的包的按序接收。然后接收端实体对已成功收到的字节发回一个相应的确认(ACK);如果发送端实体在合理的往返时延(RTT)内未收到确认,那么对应的数据(假设丢失了)将会被重传。在数据正确性与合法性上,TCP用一个校验和函数来检验数据是否有错误,在发送和接收时都要计算校验和;同时可以使用md5认证对数据进行加密。在流量控制上,采用滑动窗口协议,协议中规定,对于窗口内未经确认的分组需要重传。参考资料来源:百度百科-TCP协议
      答案B A中,不只是TCP进行数据分组,其它的如UDPC中,TCP不能保证数据的传输路径,路由的选择也是动态的 D中,TCP协议有拥塞控制功能,在网络发生拥塞时,发送方会限制发送速度,从而降低网络拥塞程度。
      不选c。答案非常正确吧,和你想象一样。?这是我查找资料得到的。不知道你满意不?
      B
      TCP协议的主要功能是  单选

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类