RIP路由选择协议
典型的路由协议有rip,ospf,isis,bgp等。rip是用经过的路由器跳数来衡量的,最少的跳数就是最优路由。 RIP共有三个版本,RIPv1, RIPv2, RIPng其中RIPV1和RIPV2是用在IPV4的网络环境里,RIPng是用在IPV6的网络环境里。 因为RIPv1的缺陷,RIPv2在1994年被提出,将子网络的资讯包含在内,透过这样的方式提供无类别域间路由,不过对于最大节点数15的这个限制仍然被保留着。另外针对安全性的问题,RIPv2也提供一套方法,透过加密来达到认证的效果。而之后[RFC 2082 ]也定义了利用MD5来达到认证的方法。 RIPv2的相关规定在[RFC 2453 ] orSTD56。现今的IPv4网络中使用的大多是RIPv2,RIPv2是在RIPv1基础上的改进, RIPv2和RIPv1相比主要有以下区别。RIPng(Routing Information Protocol next generation)则被定义在[RFC 2080 ],主要是针对IPv6做一些延伸的规范。与RIPv2相比下其最主要的差异是:RIPv2 支持RIP更新认证, RIPng 则没有 (IPv6 routers were, at the time, supposed to use IPsec for authentication);RIPv2 容许附上arbitrary 的标签, RIPng 则不容许;RIPv2 encodes the next-hop into each route entries, RIPng requires specific encoding of the nexthop for a set of route entries. RIPv2 UDP的Port number 为 520,RIPng UDP的Port number 为 521

RIP路由协议的主要特点有哪些
路由信息协议(rip) 是内部网关协议igp中最先得到使用的协议。rip是一种分布式的基于距离矢量的路由选择协议,是因特网的标准协议,其最大优点就是实现简单,开销较小。 但rip的缺点也较多。首先,其限制了网络的规模,能使用的最大距离为15(16表示不可达)。其次路由器交换的信息是路由器的完整路由表,因而随着网络规模的扩大,开销也就增加。最后,"坏消息传播得慢",使更新过程的收敛时间过长。因此对于规模较大的网络就应当使用ospf协议。然而目前在规模较小的网络中,使用rip协议的仍占多数。
RIP 协议的特点是: (1)仅和相邻路由器交换信息。【注】如果两个路由器之间的通信不需要经过另一个路由器,那么这两个路由器就是相邻的。RIP协议规定,不相邻的路由器不交换信息。(2)路由器交换的信息是当前本路由器所知道的全部信息,即自己的路由表。【注】交换的信息是:“我到本自治制系统中所有网路的(最短)距离,以及到每个网络应该经过的下一跳路由器。” (3)按固定的时间间隔交换路由信息。【注】每个30秒,然后路由器根据收到的路由信息更新路由表。当网路拓扑发生变化时,路由器也及时向相邻路由器通告拓扑变化后的路由信息。

请问rip路由协议配置的具体步骤是什么?谢谢
1、确定所要配置的网络组网及相关ip规划,然后进行具体的配置。2、首先进行路由器的端口ip配置,下面以路由器R2为例,R1与R3的配置命令类似,只用修改IP即可:R2#conf t (configure terminal的简写)R2(config)#int f 0/0 (interface fastEthernet f 0/0,进入该接口配置模式)R2(config-if)#ip add 192.168.12.2 255.255.255.0 (接口配置ip地址)R2(config-if)#no shut (激活接口)R2(config-if)#int f 0/1R2(config-if)#ip add 192.168.21.1 255.255.255.0R2(config-if)#no shutR2(config-if)#int s 1/0R2(config-if)#ip add 192.168.23.2 255.255.255.0R2(config-if)#no shutR2(config-if)#endR2#show ip route(查看路由表)3、配置完成后,通过命令"show ip interface brief"查看路由的各接口ip配置是否正确。并验证与非直连网段的互通性,由于此时还没有到非直连网段的路由,故此时不通。4、在路由器上启动rip协议:R2#conf tR2(config)#router rip(进入rip协议配置)R2(config-router)#version 2 (启用rip v2版本)R2(config-router)#no auto (关闭路由自动汇总)R2(config-router)#network 192.168.12.0 (通过RIP宣告该网段)R2(config-router)#network 192.168.21.0R2(config-router)#network 192.168.23.0R2(config-router)#end5、rip配置完成后,通过"show ip route"查看路由表中存在有"R"标识的rip协议路由。6、再次验证费直连网络的互通性,此时可以相互通信。
enable 进入特权模式 config t进入全局配置模式int 【端口】进入端口配置模式ip add 【ip地址+ 子网掩码】 配置端口ip地址 子网掩码no shut 激活端口exit退回到全局配置模式router rip开启rip协议network 【ip 网段】 宣告地址范围end回到特权模式wr保存配置排错用到的命令show run查看全局配置show ip intbri查看简要接口信息 是否激活 ip地址对与不对 show ip router查看路由表信息 有没有没宣告的 没学习到的
以H3C为例 【H3C】rip 1 (启用rip,rip进程1)【H3C-rip-1】network 192.168.1.0 (把网段宣告进rip中)【H3C-rip-1】network 192.168.2.0(同上)【H3C-rip-1】version 2 (ripv2)【H3C-rip-1】undo summary (关闭自动聚合) 如果配置RIPv1,则最后两句不用配置。
以思科路由器为例 enableconf trouter ripnetwork + ip地址 大致就这么几步,公布的ip要包括想要通告的路由和自己想要传输rip信息的端口ip地址。

RIP,OSPF等路由协议严格意义上讲属哪一层?
RIP基于UDP,BGP基于TCP,OSPF和EIGRP基于IP 。这些在TCP/IP协议栈中定义的路由协议用于发现和维护前往目的地的最短路径。路由协议(英语:Routing protocol)是一种指定数据包转送方式的网上协议。Internet网络的主要节点设备是路由器,路由器通过路由表来转发接收到的数据。转发策略可以是人工指定的(通过静态路由、策略路由等方法)。在具有较小规模的网络中,人工指定转发策略没有任何问题。扩展资料:常见路由协议常见的路由协议有RIP、IGRP(Cisco私有协议)、EIGRP(Cisco私有协议)、OSPF、IS-IS、BGP等。RIP、IGRP、EIGRP、OSPF、IS-IS是内部网关协议(IGP),适用于单个ISP的统一路由协议的运行,一般由一个ISP运营的网络位于一个AS(自治系统)内,有统一的AS number(自治系统号)。BGP是自治系统间的路由协议,是一种外部网关协议,多用于不同ISP之间交换路由信息,以及大型企业、政府等具有较大规模的私有网络。RIP主条目:路由信息协议RIP很早就被用在Internet上,是最简单的路由协议。它是“路由信息协议(Route Information Protocol)”的简写主要传递路由信息,通过每隔30秒广播一次路由表,维护相邻路由器的位置关系,同时根据收到的路由表信息计算自己的路由表信息。RIP是一个距离矢量路由协议,最大跳数为15跳,超过15跳的网络则认为目标网络不可达。此协议通常用在网络架构较为简单的小型网络环境。现在分为RIPv1和RIPv2两个版本,后者支持VLSM技术以及一系列技术上的改进。RIP的收敛速度较慢。OSPF主条目:开放式最短路径优先OSPF协议是“开放式最短路径优先(Open Shortest Path First)”的缩写,属于链路状态路由协议。OSPF提出了“区域(area)”的概念,每个区域中所有路由器维护着一个相同的链路状态数据库(LSDB)。区域又分为骨干区域(骨干区域的编号必须为0)和非骨干区域(非0编号区域),如果一个运行OSPF的网络只存在单一区域,则该区域可以是骨干区域或者非骨干区域。如果该网络存在多个区域,那么必须存在骨干区域,并且所有非骨干区域必须和骨干区域直接相连。OSPF利用所维护的链路状态数据库,通过最短路径优先算法(SPF算法)计算得到路由表。OSPF的收敛速度较快。由于其特有的开放性以及良好的扩展性,目前OSPF协议在各种网络中广泛部署。IS-IS主条目:中间系统到中间系统IS-IS协议是Intermediate system to intermediate system(中间系统到中间系统)的缩写,属于链路状态路由协议。标准IS-IS协议是由国际标准化组织制定的ISO/IEC 10589:2002所定义的,标准IS-IS不适合用于IP网络,因此IETF制定了适用于IP网络的集成化IS-IS协议和OSPF相同,IS-IS也使用了“区域”的概念,同样也维护着一份链路状态数据库,通过最短生成树算法(SPF)计算出最佳路径。IS-IS的收敛速度较快。集成化IS-IS协议是ISP骨干网上最常用的IGP协议。IGRP主条目:内部网关路由协议IGRP协议是“内部网关路由协议(Interior Gateway Routing Protocol)”的缩写,由Cisco于二十世纪八十年代独立开发,属于Cisco私有协议。IGRP和RIP一样,同属距离矢量路由协议,因此在诸多方面有着相似点,如IGRP也是周期性的广播路由表,也存在最大跳数(默认为100跳,达到或超过100跳则认为目标网络不可达)。IGRP最大的特点是使用了混合度量值,同时考虑了链路的带宽、延迟、负载、MTU、可靠性5个方面来计算路由的度量值,而不像其他IGP协议单纯的考虑某一个方面来计算度量值。目前IGRP已经被Cisco独立开发的EIGRP协议所取代,版本号为12.3及其以上的Cisco IOS(Internetwork Operating System)已经不支持该协议,现在已经罕有运行IGRP协议的网络。EIGRP主条目:增强型内部网关路由协议由于IGRP协议的种种缺陷以及不足,Cisco开发了EIGRP协议(增强型内部网关路由协议)来取代IGRP协议。EIGRP属于高级距离矢量路由协议(又称混合型路由协议),继承了IGRP的混合度量值,最大特点在于引入了非等价负载均衡技术,并拥有极快的收敛速度。EIGRP协议在Cisco设备网络环境中广泛部署。BGP主条目:边界网关协议为了维护各个ISP的独立利益,标准化组织制定了ISP间的路由协议BGP。BGP是“边界网关协议(Border Gateway Protocol)”的缩写,处理各ISP之间的路由传递。但是BGP运行在相对核心的地位,需要用户对网络的结构有相当的了解,否则可能会造成较大损失。参考资料来源:百度百科-路由协议
1.
RIP基于UDP,BGP基于TCP,OSPF和EIGRP基于IP
。这些在TCP/IP协议栈中定义的路由协议用于发现和维护前往目的地的最短路径。你可以认为它们
不属于网络层协议(注意,
是用,based
on,而不是实现了
,BGP用TCP,所以BGP是应用层的,TCP用IP,所以TCP是传输层的,OSPF用IP,所以OSPF更应该是归类到传输层里比较合理。与书<<计算机网络自顶向下方法与Internet特色意思基本一致),但它们计算出来的路径最终为网络层提供服务。(在TCP/IP协议栈中,
RoutedProtocol(eg. IP)工作在网络层,而Routing
Protocol(eg.BGP)工作在传输层或应用层
,他们之间的关系为:Routing
Protocol负责学习最佳路径,而Routed Protocol根据最佳路径将来自上层的信息封装在IP包里传输。)
当然,你也要理解,
TCP/IP的定义本来就比较模糊
。另外一种为OSI提供服务的路由协议就不一样了,
IS-IS。它直接封装在数据帧中,自然是一种网络层协议了
。这也可以看出OSI的定义比TCP/IP严谨许多。2.
一个协议的实现需要依赖协议所在层次的下一层功能
。简单的说,如果TCP需要依赖网际层协议IP,那么它就是传输层的协议。同理,如果RIP需要依赖传输层的UDP,
那至少它应该是被定义在UDP之上的协议
,但我认为它并不能算是应用层协议。举个例子,ICMP是网络层协议,
但它需要依赖IP承载
不够严谨的TCP/IP啊。
4.如果一定在划分的话.单纯地从层次上讲的话,RIP,BGP应该在应用层,OSPF,EIGRP在传输层
这个问题我们从一下几个方面剖析:1.RIP,OSPF,在TCP/IP协议栈中定义的路由最短路径。它们不属于网络层协议OSPF,但它们计算出来的路径最终为网络层提供服务。(在TCP/IP协议栈中,Routed Protocol(eg. IP)工作在网络层,而Routing Protocol(eg.BGP)工作在传输层或应用层。2.一个协议的实现需要协议所在层次的下一层功能的帮助。就是说如果TCP需要依赖网际层协议IP,那么它就是传输层的协议。同理,如果RIP需要依赖传输层的UDP,那至少它应该是被定义在UDP之上的协议。举个例子,ICMP是网络层协议,但它需要依赖IP承载。3.学习这些协议关键是掌握它们在网络中的功能和如何应用它们。至于它们到底是哪一层的协议,不做重点考虑。4.从层次上讲的话,RIP,BGP应该在应用层,OSPF,EIGRP在传输层。
rip是应用层协议,ospf是传输层协议,理由是只有高层才会关注底层用的是什么协议,因rip底层是 UDP协议,OSPF是IP,计算出来的路径为网络层提供服务。 工作在哪一层和为哪一层提供服务是两个概念. 同样,pptp 和 l2tp是会话层协议,参考 RFC2661.
RIP是应用层协议,采用UDP传送数据 OSPF是网络层协议/(也有的书上写运输层?),使用IP数据报传送 BGP是应用层协议,采用TCP传送数据

RIP协议是什么意思?
路由信息协议(RIP)协议是一种动态路由选择,它基于距离向量算法(D-V),总是按最短的路由做出相同的选择。这种协议的路由器只关心自己周围的世界,只与自己相邻的路由器交换信息,范围限制在15跳(15度)之内,再远,它就不关心了。 补充内容:RIP(RoutinginformationProtocol)是应用较早、使用较普遍的内部网关协议(InteriorGatewayProtocol,简称IGP),适用于小型同类网络,是典型的距离向量(distance-vector)协议。文档见RFC1058、RFC1723。 RIP通过广播UDP报文来交换路由信息,每30秒发送一次路由信息更新。RIP提供跳跃计数(hopcount)作为尺度来衡量路由距离,跳跃计数是一个包到达目标所必须经过的路由器的数目。如果到相同目标有二个不等速或不同带宽的路由器,但跳跃计数相同,则RIP认为两个路由是等距离的。RIP最多支持的跳数为15,即在源和目的网间所要经过的最多路由器的数目为15,跳数16表示不可达。

本文由 在线网速测试 整理编辑,转载请注明出处。