dhcp request报文的作用是(dhcp request报文一定是以广播形式发送的)

      最后更新:2023-05-17 16:19

      DHCP服务的作用???

      DHCP DHCP 是 Dynamic Host Configuration Protocol(动态主机分配协议)缩写,它的前身是 BOOTP。BOOTP 原本是用于无磁盘主机连接的网络上面的:网络主机使用 BOOT ROM 而不是磁盘起动并连接上网络,BOOTP 则可以自动地为那些主机设定 TCP/IP 环境。但 BOOTP 有一个缺点:您在设定前须事先获得客户端的硬件地址,而且,与 IP 的对应是静态的。换而言之,BOOTP 非常缺乏 "动态性" ,若在有限的 IP 资源环境中,BOOTP 的一对一对应会造成非常可观的浪费。 DHCP 可以说是 BOOTP 的增强版本,它分为两个部份:一个是服务器端,而另一个是客户端。所有的 IP 网络设定数据都由 DHCP 服务器集中管理,并负责处理客户端的 DHCP 要求;而客户端则会使用从服务器分配下来的IP环境数据。比较起 BOOTP ,DHCP 透过 "租约" 的概念,有效且动态的分配客户端的 TCP/IP 设定,而且,作为兼容考虑,DHCP 也完全照顾了 BOOTP Client 的需求。 DHCP 的分配形式 首先,必须至少有一台 DHCP 工作在网络上面,它会监听网络的 DHCP 请求,并与客户端搓商 TCP/IP 的设定环境。它提供两种 IP 定位方式:Automatic Allocation自动分配,其情形是:一旦 DHCP 客户端第一次成功的从 DHCP 服务器端租用到 IP 地址之后,就永远使用这个地址。Dynamic Allocation动态分配,当 DHCP 第一次从 HDCP 服务器端租用到 IP 地址之后,并非永久的使用该地址,只要租约到期,客户端就得释放(release)这个 IP 地址,以给其它工作站使用。当然,客户端可以比其它主机更优先的更新(renew)租约,或是租用其它的 IP 地址。 动态分配显然比自动分配更加灵活,尤其是当您的实际 IP 地址不足的时候,例如:您是一家 ISP ,只能提供 200 个IP地址用来给拨接客户,但并不意味着您的客户最多只能有 200 个。因为要知道,您的客户们不可能全部同一时间上网的,除了他们各自的行为习惯的不同,也有可能是电话线路的限制。这样,您就可以将这 200 个地址,轮流的租用给拨接上来的客户使用了。这也是为什么当您查看 IP 地址的时候,会因每次拨接而不同的原因了(除非您申请的是一个固定 IP ,通常的 ISP 都可以满足这样的要求,这或许要另外收费)。当然,ISP 不一定使用 DHCP 来分配地址,但这个概念和使用 IP Pool 的原理是一样的。 DHCP 除了能动态的设定 IP 地址之外,还可以将一些 IP 保留下来给一些特殊用途的机器使用,它可以按照硬件地址来固定的分配 IP 地址,这样可以给您更大的设计空间。同时,DHCP 还可以帮客户端指定 router、netmask、DNS Server、WINS Server、等等项目,您在客户端上面,除了将 DHCP 选项打勾之外,几乎无需做任何的 IP 环境设定。 DHCP 的工作原理 根据客户端是否第一次登录网络,DHCP 的工作形式会有所不同。 第一次登录的时候:寻找 Server。当 DHCP 客户端第一次登录网络的时候,也就是客户发现本机上没有任何 IP 数据设定,它会向网络发出一个 DHCP DISCOVER 封包。因为客户端还不知道自己属于哪一个网络,所以封包的来源地址会为 0.0.0.0 ,而目的地址则为 255.255.255.255 ,然后再附上 DHCP discover 的信息,向网络进行广播。 在 Windows 的预设情形下,DHCP discover 的等待时间预设为 1 秒,也就是当客户端将第一个 DHCP discover 封包送出去之后,在 1 秒之内没有得到响应的话,就会进行第二次 DHCP discover 广播。若一直得不到响应的情况下,客户端一共会有四次 DHCP discover 广播(包括第一次在内),除了第一次会等待 1 秒之外,其余三次的等待时间分别是 9、13、16 秒。如果都没有得到 DHCP 服务器的响应,客户端则会显示错误信息,宣告 DHCP discover 的失败。之后,基于使用者的选择,系统会继续在 5 分钟之后再重复一次 DHCP discover 的过程。提供 IP 租用地址。当 DHCP 服务器监听到客户端发出的 DHCP discover 广播后,它会从那些还没有租出的地址范围内,选择最前面的空置 IP ,连同其它 TCP/IP 设定,响应给客户端一个 DHCP OFFER 封包。 由于客户端在开始的时候还没有 IP 地址,所以在其 DHCP discover 封包内会带有其 MAC 地址信息,并且有一个 XID 编号来辨别该封包,DHCP 服务器响应的 DHCP offer 封包则会根据这些资料传递给要求租约的客户。根据服务器端的设定,DHCP offer 封包会包含一个租约期限的信息。接受 IP 租约。如果客户端收到网络上多台 DHCP 服务器的响应,只会挑选其中一个 DHCP offer 而已(通常是最先抵达的那个),并且会向网络发送一个DHCP request广播封包,告诉所有 DHCP 服务器它将指定接受哪一台服务器提供的 IP 地址。 同时,客户端还会向网络发送一个 ARP 封包,查询网络上面有没有其它机器使用该 IP 地址;如果发现该 IP 已经被占用,客户端则会送出一个 DHCPDECLINE 封包给 DHCP 服务器,拒绝接受其 DHCP offer ,并重新发送 DHCP discover 信息。 事实上,并不是所有 DHCP 客户端都会无条件接受 DHCP 服务器的 offer ,尤其这些主机安装有其它 TCP/IP 相关的客户软件。客户端也可以用 DHCP request 向服务器提出 DHCP 选择,而这些选择会以不同的号码填写在 DHCP Option Field 里面:换一句话说,在 DHCP 服务器上面的设定,未必是客户端全都接受,客户端可以保留自己的一些 TCP/IP 设定。而主动权永远在客户端这边。租约确认。当 DHCP 服务器接收到客户端的 DHCP request 之后,会向客户端发出一个 DHCPACK 响应,以确认 IP 租约的正式生效,也就结束了一个完整的 DHCP 工作过程。 如上的工作流程如下图:DHCP 发放流程第一次登录之后: 一旦 DHCP 客户端成功地从服务器哪里取得 DHCP 租约之后,除非其租约已经失效并且 IP 地址也重新设定回 0.0.0.0 ,否则就无需再发送 DHCP discover 信息了,而会直接使用已经租用到的 IP 地址向之前之 DHCP 服务器发出 DHCP request 信息,DHCP 服务器会尽量让客户端使用原来的 IP 地址,如果没问题的话,直接响应 DHCPack 来确认则可。如果该地址已经失效或已经被其它机器使用了,服务器则会响应一个 DHCPNACK 封包给客户端,要求其从新执行 DHCP discover。 至于 IP 的租约期限却是非常考究的,并非如我们租房子那样简单, 以 NT 为例子:DHCP 工作站除了在开机的时候发出 DHCP request 请求之外,在租约期限一半的时候也会发出 DHCP request ,如果此时得不到 DHCP 服务器的确认的话,工作站还可以继续使用该 IP ;然后在剩下的租约期限的再一半的时候(即租约的75%),还得不到确认的话,那么工作站就不能拥有这个 IP 了。至于为什么不是到租约期限完全结束才放弃 IP 呢?,对不起,小弟也是不学无术之人,没有去深究了,只知道要回答 MCSE 题目的时候,您一定要记得 NT 是这么工作的就是了。 要是您想退租,可以随时送出 DHCPLEREASE 命令解约,就算您的租约在前一秒钟才获得的。跨网络的 DHCP 运作 从前面描述的过程中,我们不难发现:DHCDISCOVER 是以广播方式进行的,其情形只能在同一网络之内进行,因为 router 是不会将广播传送出去的。但如果 DHCP 服务器安设在其它的网络上面呢?由于 DHCP 客户端还没有 IP 环境设定,所以也不知道 Router 地址,而且有些 Router 也不会将 DHCP 广播封包传递出去,因此这情形下 DHCP DISCOVER 是永远没办法抵达 DHCP 服务器那端的,当然也不会发生 OFFER 及其它动作了。要解决这个问题,我们可以用 DHCP Agent (或 DHCP Proxy )主机来接管客户的 DHCP 请求,然后将此请求传递给真正的 DHCP 服务器,然后将服务器的回复传给客户。这里,Proxy 主机必须自己具有路由能力,且能将双方的封包互传对方。 若不使用 Proxy,您也可以在每一个网络之中安装 DHCP 服务器,但这样的话,一来设备成本会增加,而且,管理上面也比较分散。当然喽,如果在一个十分大型的网络中,这样的均衡式架构还是可取的。端视您的实际情况而定了。 DHCP封包格式以下为各字段的简要说明: OP若是 client 送给 server 的封包,设为 1 ,反向为 2 。 HTYPE硬件类别,Ethernet 为 1 。HLEN硬件地址长度, Ethernet 为 6 。HOPS若封包需经过 router 传送,每站加 1 ,若在同一网内,为 0 。TRANSACTION IDDHCP REQUEST 时产生的数值,以作 DHCPREPLY 时的依据。SECONDSClient 端启动时间(秒)。FLAGS从 0 到 15 共 16 bits ,最左一 bit 为 1 时表示 server 将以广播方式传送封包给 client ,其余尚未使用。ciaddr要是 client 端想继续使用之前取得之 IP 地址,则列于这里。yiaddr从 server 送回 client 之 DHCP OFFER 与 DHCPACK 封包中,此栏填写分配给 client 的 IP 地址。siaddr若 client 需要透过网络开机,从 server 送出之 DHCP OFFER、DHCPACK、DHCPNACK 封包中,此栏填写开机程序代码所在 server 之地址。giaddr若需跨网域进行 DHCP 发放,此栏为 relay agent 的地址,否则为 0 。chaddrClient 之硬件地址。snameServer 之名称字符串,以 0x00 结尾。file若 client 需要透过网络开机,此栏将指出开机程序名称,稍后以 TFTP 传送。options允许厂商定议选项(Vendor-Specific Area),以提供更多的设定信息(如:Netmask、Gateway、DNS、等等)。其长度可变,同时可携带多个选项,每一选项之第一个 byte 为信息代码,其后一个 byte 为该项数据长度,最后为项目内容。 CODE LEN VALUE 此字段完全兼容 BOOTP ,同时扩充了更多选项。其中,DHCP 封包可利用编码为 0x53 之选项来设定封包类别:项值 类别1 DHCP DISCOVER2 DHCP OFFER3 DHCP REQUEST4 DHCPDECLINE5 DHCPACK6 DHCPNACK7 DHCPRELEASE DHCP 的选项非常多,有空请查阅 RFC 或相关文献,并好好理解,这里不再叙述了。 DHCP 协议之 RFC 文件 RFC-951、RFC-1084、RFC-1123、RFC-1533、RFC-1534、RFC-1497、RFC-1541
      自动分配IP给下面的分机
      DHCP的作用就是动态分配IP的。例如:当一个局域网里才装500台计算机时,如果要人工地去每一台每一台地设置IP,那是挺麻烦的。也挺耗时的。于是就那域里一台计算机来域控制器。然后设好DHCP。至于要分配的IP段,由你个人来定。例:你可以让DHCP从192.168.0.0---192.168.0.255里分给下面的计算机. 如果是Sysgate做代理,那么就不要用专门的DHCP服务器了,它自带有。
      可以安装(客户端IP地址动态指定)也可不装(客户端指定IP地址)! DHCP是可自动将IP位址指派给登入TCP/IP网络的用户端的一种软件,(此种IP位址称为「动态IP位址」)。这种软件通常是在路由器及其他网络设备上执行的。依照预先设定,您的服务器设定为使用DHCP,因此就无须手动指派永久IP位址给网络上的每个设备。建议不要改变这个设置,这样您的个人电脑就可以被分辨为DHCP服务器。Windows默认安装并起用DHCP客户端服务! DHCP的作用就是动态分配IP的。例如:当一个局域网里才装500台计算机时,如果要人工地去每一台每一台地设置IP,那是挺麻烦的。也挺耗时的。于是就那域里一台计算机来域控制器。然后设好DHCP。至于要分配的IP段,由你个人来定。例:你可以让DHCP从192.168.0.0---192.168.0.255里分给下面的计算机
      DHCP服务的作用???

      DHCP功能是什么?有什么用?

      DHCP是动态主机设置协议的简称,主要有两个用途:用于内部网或网络服务供应商自动分配IP地址;给用户用于内部网管理员作为对所有计算机作中央管理的手段。DHCP具有以下功能:1. 保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。2. DHCP应当可以给用户分配永久固定的IP地址。3. DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。4. DHCP服务器应当向现有的BOOTP客户端提供服务。DHCP协议采用客户端/服务器模型,主机地址的动态分配任务由网络主机驱动。当DHCP服务器接收到来自网络主机申请地址的信息时,才会向网络主机发送相关的地址配置等信息,以实现网络主机地址信息的动态配置。扩展资料DHCP属于应用层协议,并且使用的是UDP协议的应用层协议。整个数据包形式为:head(以太网标头) head(ip标头) head(UDP标头) DHCP(dhcp数据包)(1)最前面的"以太网标头",设置发出方(本机)的 MAC 地址和接收方(DHCP 服务器)的 MAC 地址。前者就是本机网卡的 MAC 地址,后者这时不知道,就填入一个广播地址:FF-FF-FF-FF-FF-FF。(2)后面的"IP 标头",设置发出方的 IP 地址和接收方的 IP 地址。这时,对于这两者,本机都不知道。于是,发出方的 IP 地址就设为0.0.0.0,接收方的 IP 地址设为 255.255.255.255。(3)最后的"UDP 标头",设置发出方的端口和接收方的端口。这一部分是 DHCP 协议规定好的,发出方是 68 端口,接收方是 67 端口。参考资料:百度百科-DHCP
      概念上,DHCP是TCP/IP协议簇中的一种,主要是用来给网络客户机分配动态的IP地址。 这些被分配的IP地址都是DHCP服务器预先保留的一个由多个地址组成的地址集,并且它们一般是一段连续的地址。使用DHCP时必须在网络上有一台DHCP服务器,而其他机器执行DHCP客户端。DHCP使服务器能够动态地为网络中的其他服务器提供IP地址,通过使用DHCP,就可以不给Intranet网中除DHCP、DNS和WINS服务器外的任何服务器设置和维护静态IP地址。优点上,当DHCP客户端程序发出一个信息,要求一个动态的IP地址时,DHCP服务器会根据目前已经配置的地址,提供一个可供使用的IP地址和子网掩码给客户端。使用DHCP可以大大简化配置客户机的TCP/IP的工作,尤其是当某些TCP/IP参数改变时,如网络的大规模重建而引起的IP地址和子网掩码的更改。使用方法上,动态分配方法可以解决IP地址不够用的困扰,例如C类网络只能支持254台主机,而网络上的主机有三百多台,但如果网上同一时间最多有200个用户,此时如果使用手工分配或自动分配将不能解决这一问题。而动态分配方式的IP地址并不固定分配给某一客户机,只要有空闲的IP地址,DHCP服务器就可以将它分配给要求地址的客户机;当客户机不再需要IP地址时,就由DHCP服务器重新收回扩展资料:DHCP服务器是运行Microsoft TCP/IP、DHCP服务器软件和Windows NT Server的计算机,DHCP客户机则是请求TCP/IP配置信息的TCP/IP主机。DHCP使用客户机/服务器模型,网络管理员可以创建一个或多个维护TCP/IP配置信息的DHCP服务器,并且将其提供给客户机。参考资料:DHCP百度百科
      DHCP协议的功能为:集中的管理、分配IP地址。DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)通常被应用在大型的局域网络环境中,主要具有以下功能:1.保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。2.DHCP应当可以给用户分配永久固定的IP地址。3.DHCP应当可以同用其他方法获得IP地址的主机共存。4.DHCP服务器应当向现有的BOOTP客户端提供服务。扩展资料:DHCP 避免了因手工设置IP地址及子网掩码所产生的错误,同时也避免了把一个IP地址分配给多台计算机所造成的地址冲突,而客户机也只需将TCP/IP配置全设置为自动获取即可上网。DHCP服务降低了管理IP地址设置的负担,使用DHCP 服务器大大缩短了配置或重新配置网络中工作站所花费的时间,达到了最高效地利用有限的IP地址的目的。由于包含IP地址的相关TCP/IP配置参数是DHCP服务器“临时发放”给客户端使用的,所以当客户机断开与服务器的连接后,旧的IP地址将被释放以便重用。参考资料来源:百度百科—DHCP
      DHCP的功能主要是集中的管理、分配IP地址,使网络环境中的主机动态的获得IP地址、Gateway地址、DNS服务器地址等信息,并能够提升地址的使用率。DHCP协议采用客户端/服务器模型,主机地址的动态分配任务由网络主机驱动。当DHCP服务器接收到来自网络主机申请地址的信息时,才会向网络主机发送相关的地址配置等信息,以实现网络主机地址信息的动态配置。DHCP具有以下功能:1、 保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。2、DHCP应当可以给用户分配永久固定的IP地址。3、DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。扩展资料DHCP协议采用客户端/服务器模型,主机地址的动态分配任务由网络主机驱动。当DHCP服务器接收到来自网络主机申请地址的信息时,才会向网络主机发送相关的地址配置等信息,以实现网络主机地址信息的动态配置。DHCP具有以下功能:1. 保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。2. DHCP应当可以给用户分配永久固定的IP地址。3. DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。4. DHCP服务器应当向现有的BOOTP客户端提供服务。参考资料:百度百科-DHCP
      一、DHCP具有以下功能:1、 保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。2、DHCP应当可以给用户分配永久固定的IP地址。3、DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。4、 DHCP服务器应当向现有的BOOTP客户端提供服务。二、主要有两个用途:1、用于内部网或网络服务供应商自动分配IP地址。2、给用户用于内部网管理员作为对所有计算机作中央管理的手段。扩展资料DHCP有三种机制分配IP地址:1、自动分配方式(Automatic Allocation),DHCP服务器为主机指定一个永久性的IP地址,一旦DHCP客户端第一次成功从DHCP服务器端租用到IP地址后,就可以永久性的使用该地址。2、动态分配方式(Dynamic Allocation),DHCP服务器给主机指定一个具有时间限制的IP地址,时间到期或主机明确表示放弃该地址时,该地址可以被其他主机使用。3、手工分配方式(Manual Allocation),客户端的IP地址是由网络管理员指定的,DHCP服务器只是将指定的IP地址告诉客户端主机。参考资料来源:百度百科—DHCP
      DHCP功能是什么?有什么用?

      [协议]DHCP 协议原理与分析(一)

      Chapter 01 : DHCP(Dynamic Host Configuration Protocol)协议的作用在TCP/IP网络中向Internet主机提供配置信息。它以Bootstrap Protocol(BOOTP)协议为基础发展起来的,并增加了重新使用的网络地址的自动分配能力和附加配置选项(Configuration Options),同时DHCP保留了BOOTP的Relay代理功能。Chapter 02: 协议简介DHCP(Dynamic Host Configuration Protocol)协议是在Bootstrap Protocol (BOOTP)基础上提出的,其作用是在TCP/IP网络中向Internet主机提供配置信息。DHCP采用Client / Server模式,由客户端向服务器提出配置申请(包括分配的IP地址、子网掩码、缺省网关等参数),服务器根据策略返回相应配置信息。DHCP报文采用UDP作为传输层协议进行封装。DHCP 2个部分:1、 DHCP Relay功能,把DHCP Server指定的配置信息传输给Host;2、 Server功能,分配网络地址和其他配置参数给主机。DHCP 分配IP 方式:1、 Automatic Allocation,为首次连接到网络的某些主机分配固定IP地址,该地址将长期由该主机使用。2、 Dynamic Allocation,DHCP Server为Host指定一个IP地址,同时为此地址规定了一个租用期限,如果租用时间到期,Client必须重新申请地址,这是Client申请地址最常用的方法;3、 Manual Allocation,网络管理员为某些少数特定的Host指定固定IP地址。DHCP指定地址的优先级分类:1、 DHCP Server地址池中与Client的MAC地址静态绑定的IP地址。2、 Client曾经使用过的地址。当Client端再次申请地址时,Client发送DHCP Discover报文,其地址选项中会包含上次使用的IP地址,除非此IP地址被分配出去或此地址进行了其他不可用操作(例如:此IP地址被Forbidden等),否则Client端将再次使用此地址。3、 “requested IP address”选项中Client自己指定的IP地址,如果这个地址是地址池里的有效地址,而且没有被分配出去,那么将此地址分配给Client使用。4、 顺序查找DHCP地址池中可供分配的IP地址,最先找到的可用IP地址,优先级高。Chapter 03: DHCP 报文格式报文每个字段的含义“options”域是个可变长度域,DHCP Client必须能够接收包含有312bytes长度的“options”域的DHCP报文,也就是说DHCP Client必须能够接受至少576bytes长度的IP报文。DHCP Client可以通过“Maximum DHCP Message Size”Option来协商DHCP报文的最大长度。flag 格式:B : 最左边的bit,Broadcast flag;MBZ : 剩余的bits为保留位,留作将来使用Chapter 04 : DHCP 报文构造与发送DHCP 使用 UDP 协议的端口号DHCP报文采用UDP作为传输层协议进行封装。Client到Server的DHCP报文发送到DHCP Server的端口号是67,Server到Client的报文发送到DHCP Client的端口号是68DHCP 的选项DHCP报文中需要包含一系列的选项,即,选项列表(Options Lists)。选项列表是以4个字节的魔术字开始,后面跟随一系列的选项,最后以“end”选项结束。Client IDDHCP定义了一个用来标识Client的选项,即,“Client Identifier”Option。Client必须选择一个能够在自己所在的物理网络中唯一标识自己的值来填充Client ID选项的值,一旦该值被初始化,在随后的报文交互中,该值不能改变。推荐使用Client的MAC地址作为Client ID值。Server IDDHCP定义了一个用来标识Server的选项,即,“Server Identifier”Option。Server选择自己的IP地址作为Server ID。如果一个DHCP Server有多个IP地址,它可以任意选择一个作为Server ID,但是,推荐使用Client可达的IP地址。例如,当Server与Client位于同一网段时,最好选择该网段的地址作为Server ID。如果Client向Server发送单播报文,目的地址就使用Server ID值。Client 端发送报文的源 IP 地址在Client端没有获取到IP地址之前,其发送报文的源IP(指IP首部中的源IP字段)必须填0。广播标志Flags,第1bit用作广播标志,后面15bits保留,必须置0。在软件没有对自己IP协议的IP地址进行有效配置时,Client可能无法处理收到的单播报文,这时,Client在发送Discover和Request报文时,必须将广播标志位置1, Server或RelayAgent收到这样的报文,必须回复广播报文给Client。如果Client可以处理广播报文,它就将广播标志位置0,Server或Relay Agent收到这样的Discover和Request报文,可以使用单播报文进行回复,其目的IP地址为Server分配给Client的IP地址,即,报文中yiaddr (You IP Address)字段的值。当然,Server或Relay Agent也可以以广播的方式回复。Server 端对 ciaddr 和 giaddr 字段的处理ciaddr,Client IP Address,只有Client是BOUND、RENEW、REBINDING状态,并且能响应ARP requests时,才能被填充;giaddr,Relay Agent IP Adress;1、 如果Server收到的报文giaddr字段不为0(即,说明该报文是经过Relay Agent进行转发的报文),那么它将以单播的方式进行回复,其目的地址为giaddr字段的值;2、 如果Server收到的报文giaddr字段为0,ciaddr字段不为0(即,说明Client已经有效配置了自己的IP地址),那么它将以单播的方式进行回复,其目的地址为ciaddr字段的值;3、 如果Server收到的报文giaddr字段为0,ciaddr字段为0,广播标志位不为0(即,说明Client没有配置自己的IP地址,并且,此时无法处理单播报文),那么它将以广播的方式进行回复;4、 如果Server收到的报文giaddr字段为0,ciaddr字段为0,广播标志位为0(即,说明Client虽然没有配置自己的IP地址,但是,此时可以处理单播报文),那么它将以单播的方式进行回复(推荐以单播方式回复,当然,也可以以广播方式回复)。Transaction IDXid(Transaction ID),由Client选择的一个随机数,用于Server和Client之间交互报文的匹配。Client必须采用相应的算法来保证其选取的xid值与其他Client选取的xid值尽量不同,即,将相同的概率降到最低。选项过载在DHCP报文头中,sname和file字段都占用较多的字节,如果一个报文中的这两个字段有一个或两个不含信息,空间就浪费了。为此,DHCP可以将选项内容扩充到sname和file字段中。DHCP定义了一个Overload Option(过载选项),如果出现Overload Option,就告诉接收者sname和file字段失去了原来的含义,而表示Option报文类型DHCP在Message Type Option中,定义了报文类型,Message Type Option的格式如下:Option Code:长度为1个字节,其值为53,表示Message Type Option;Option Length:长度为1字节,其值为1,表示Option Value字段长度为1个字节;Option Value:长度为1个字节,其值标识了DHCP的报文类型(Message Type)。在RFC2131中定义了如下8种DHCP报文:Type 描述1 DHCPDISCOVER2 DHCPOFFER3 DHCPREQUEST4 DHCPDECLINE5 DHCPACK6 DHCPNAK7 DHCPRELEASE8 DHCPINFORMDHCP Server可以收到Client的报文为:DHCPDISCOVER、DHCPREQUEST、DHCPDECLINE、DHCPRELEASE和DHCPINFORM;DHCP Client可以收到Server的报文为:DHCPOFFER、DHCPACK和DHCPNAK。DHCPDISCOVER当Server收到来自Client的DHCPDISCOVER报文后,Server会为此Client选择一个网络地址,如果没有可用地址,那么Server会向系统管理员报告;如果有可用地址,那么Server会选择一个可用地址给Client,选择机制为:1、 Server地址池中与Client的MAC地址静态绑定的IP地址;2、 Client先前使用的已经过期或释放掉的地址,如果此地址在地址池里是可用地址,并且没有被分配出去,那么将此地址分配给Client使用;3、 “requested IP address”选项中Client自己指定的IP地址,如果这个地址是地址池里的有效地址,而且没有被分配出去,那么将此地址分配给Client使用;4、 地址池里的有效的未分配出去的新地址,根据一定的选择方法分配给Client使用。租期选择机制:1、 如果Client在DHCPDISCOVER中请求了指定租期,这时不管Client是否已经被指定了网络地址,Server都会指定为请求租期;2、 如果Client没有请求指定租约期限,而Client已经被指定了网络地址,那么Server将把先前此地址使用的租期指定给该地址;3、 如果Client没有请求指定租约期限,而Client也没有被指定网络地址,那么Server将指定本地默认租期。DHCPREQUESTDHCPREQUEST是Client响应来自Server的DHCPOFFER报文、检验先前分配的网络地址或扩展已存在的租约的。如果DHCPREQUEST报文中包含“server identifier”选项,那么这个报文是用来响应DHCPOFFER的,否则,这个报文是用来请求检验和扩展已存在的租约的。如果在DHCPREQUEST中Client使用了“client identifier”选项,那么在以后的所有后续报文中都要使用相同的“client identifier”;如果在DHCPDISCOVER报文中包含需求参数列表,那么在后续的报文中都要包含这个参数列表。DHCPACK中的配置参数不应该和DHCPOFFER报文产生冲突,而Client使用的配置参数就是DHCPACK报文中的配置参数。DHCPDECLINE如果Client发现Server建议使用的网络地址已被使用,那么Client将向Server发送DHCPDECLINE报文,Server必须把这个网络地址标记为不可用,并且应该通报本地系统管理员可能的配置问题。Client检查Server分配的地址是否已经被使用的方法:Client收到Server的ACK报文,在配置自己的IP地址和其他参数之前,发送免费ARP进行检查该IP地址是否在网络中被使用。DHCPRELEASE如果Client不再需要使用它的指定地址,那么Client将向Server发送DHCPRELEASE报文,当收到DHCPRELEASE后,Server会标记此网络地址不再被分配,但Server应该保留Client的初始化参数记录,以备以后响应Client对此地址可能的重使用。DHCPINFORM当Client已经配置了自己的IP地址,但又要配置其他参数时,它将向Server发送DHCPINFORM报文,请求其他参数配置。当收到DHCPINFORM报文,Server直接对报文“ciaddr”域中给出的地址发送DHCPACK报文。Server不必发送租期超出时间,也不应该填充“yiaddr”域。DHCPOFFERServer收到DHCPDISCOVER报文,使用DHCPOFFER报文进行回应。DHCPOFFER报文应该包括“yiaddr”域的可用网络地址和其它DHCP options的配置参数。当分配新的地址时,Server应该确认提供的网络地址没有被其他Client使用(Server可以通过发送指向被分配地址的ICMP echo request来确认被分配地址没有被使用)。DHCPACK&DHCPNAK如果某个Server提供的配置参数是可以接受的,那么Client记录下Server的地址,并且把此地址写入DHCPREQUEST的“server identifier”域,并以广播形式向外发送,如果收到DHCPREQUEST报文里面的配置参数是有效的,Server会响应一个DHCPACK报文。一旦DHCPACK被收到,Client将会被初始化并且进入BOUND状态。如果DHCPREQUEST报文里面的配置参数是无效的,那么Server会响应一个 DHCPNAK报文。
      [协议]DHCP 协议原理与分析(一)

      DHCP是什么?

      DHCP是电脑动态主机设置协议、能够集中管理和自动分配IP网络地址的通信协议。在IP网络中,每个连接Internet的设备都需要分配唯一的IP地址、当某台计算机移到网络中的其它位置时,能自动收到新的IP地址。通常被应用在大型的局域网络环境中,主要作用是集中的管理、分配IP地址,使网络环境中的主机动态的获得IP地址、Gateway地址、DNS服务器地址等信息,并能够提升地址的使用率。扩展资料:DHCP使用了租约的概念,或称为计算机IP地址的有效期、租用时间是不定的,主要取决于用户在某地连接Internet需要多久。在支持DHCP功能的网络设备上将指定的端口作为DHCP Client,通过DHCP协议从DHCP Server动态获取IP地址等信息,来实现设备的集中管理、一般应用于网络设备的网络管理接口上。DHCP客户端可以带来如下好处1、降低了配置和部署设备时间2、降低了发生配置错误的可能性3、可以集中化管理设备的IP地址分配DHCP服务器指的是由服务器控制一段IP地址范围,客户端登录服务器时就可以自动获得服务器分配的IP地址和子网掩码。参考资料来源:百度百科——DHCP
      DHCP是动态主机配置协议,英文全名叫做Dynamic Host Configuration Protocol。动态主机设置协议是一个局域网的网络协议,使用UDP协议工作。该协议允许服务器向客户端动态分配 IP 地址和配置信息。DHCP协议支持C/S结构,主要分为客户端和服务端。扩展资料:DHCP续租的工作流程如下:1、在使用租期过去50%时刻处, 客户端向服务器发送单播DHCP REQUEST报文续延租期。2、如果收到服务器的DHCP ACK报文,则租期相应向前延长,续租成功。如果没有收到DHCP ACK报文,则客户端继续使用这个IP地址。在使用租期过去87.5%时刻处,向服务器发送广播DHCP REQUEST报文续延租期。3、如果收到服务器的DHCP ACK报文,则租期相应向前延长,续租成功。如果没有收到DHCP ACK报文,则客户端继续使用这个IP地址。参考资料:百度百科-动态主机配置协议
      DHCP是Dynamic Host Configuration Protocol的英文缩写,中文名称是:动态主机配置协议,主要作用就是给计算机分配IP地址,运行DHCP服务的网络设备就叫做DHCP服务器。PS:普通的计算机、服务器、路由器等都可以运行DHCP服务。扩展资料:现在的家用路由器都具备提供DHCP服务的能力,可以说现在的家用路由器是DHCP服务器、DNS服务器、NAT服务器的集合体。默认情况下路由器的DHCP服务器都是启动的,并不需要用户进行配置。用户只需要知道DHCP服务器是用来给你连接该路由器上面的计算机分配IP地址、DNS服务器地址和默认网关地址就可以了。参考资料:百度百科DHCP
      DHCP是动态主机配置协议,英文为Dynamic Host Configuration Protocol。DHCP功能:保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。DHCP应当可以给用户分配永久固定的IP地址。DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。DHCP服务器应当向现有的BOOTP客户端提供服务。DHCP有三种机制分配IP地址:自动分配方式(Automatic Allocation),DHCP服务器为主机指定一个永久性的IP地址,一旦DHCP客户端第一次成功从DHCP服务器端租用到IP地址后,就可以永久性的使用该地址。动态分配方式(Dynamic Allocation),DHCP服务器给主机指定一个具有时间限制的IP地址,时间到期或主机明确表示放弃该地址时,该地址可以被其他主机使用。手工分配方式(Manual Allocation),客户端的IP地址是由网络管理员指定的,DHCP服务器只是将指定的IP地址告诉客户端主机。
      DHCP是什么?

      DHCP工作过程包括哪四种报文

      使用DHCP正常获取地址的过程中使用的是以下4种报文:(1)客户端广播DHCP发现(DHCP Discovery)(2)服务器回应DHCP响应(DHCP Offer)(3)客户端广播DHCP请求(DHCP Request)(4)服务器回应DHCP确认(DHCP ACK)其实还有其他类型的报文,客户端发现分配的IP地址已经被占用时,发送DHCP Decline,通知服务器IP地址已被占用,要求重新分配。客户端可以主动释放IP地址,DHCP Release。如果客户端移动到了另一个IP地址不同的网络,并向服务器申请续租时,服务器发现客户端IP地址错误,发送DHCP NAK通知客户端重新申请IP地址。延展阅读:【DHCP简介】DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)是一个局域网的网络协议,使用UDP协议工作, 主要有两个用途:给内部网络或网络服务供应商自动分配IP地址,给用户或者内部网络管理员作为对所有计算机作中央管理的手段,在RFC 2131中有详细的描述。DHCP有3个端口,其中UDP67和UDP68为正常的DHCP服务端口,分别作为DHCP Server和DHCP Client的服务端口;546号端口用于DHCPv6 Client,而不用于DHCPv4,是为DHCP failover服务,这是需要特别开启的服务,DHCP failover是用来做“双机热备”的。【功能概述】DHCP协议采用客户端/服务器模型,主机地址的动态分配任务由网络主机驱动。当DHCP服务器接收到来自网络主机申请地址的信息时,才会向网络主机发送相关的地址配置等信息,以实现网络主机地址信息的动态配置。DHCP具有以下功能:1、 保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。2、DHCP应当可以给用户分配永久固定的IP地址。3、DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。4、DHCP服务器应当向现有的BOOTP客户端提供服务。
      DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)通常被应用在大型的局域网络环境中,主要作用是集中的管理、分配IP地址,使网络环境中的主机动态的获得IP地址、Gateway地址、DNS服务器地址等信息,并能够提升地址的使用率。DHCP协议采用客户端/服务器模型,主机地址的动态分配任务由网络主机驱动。当DHCP服务器接收到来自网络主机申请地址的信息时,才会向网络主机发送相关的地址配置等信息,以实现网络主机地址信息的动态配置。DHCP具有以下功能:1. 保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。2. DHCP应当可以给用户分配永久固定的IP地址。3. DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。4. DHCP服务器应当向现有的BOOTP客户端提供服务。DHCP四种报文数据包一、discover二、offer三、request四、ack
      客户端广播DHCP发现(DHCP Discovery) 服务器回应DHCP响应(DHCP Offer)客户端广播DHCP请求(DHCP Request)服务器回应DHCP确认(DHCP ACK)其实还有其他类型的报文,客户端发现分配的IP地址已经被占用时,发送DHCP Decline,通知服务器IP地址已被占用,要求重新分配。客户端可以主动释放IP地址,DHCP Release。 如果客户端移动到了另一个IP地址不同的网络,并向服务器申请续租时,服务器发现客户端IP地址错误,发送DHCP NAK通知客户端重新申请IP地址。
      使用DHCP正常获取地址的过程中使用的是以下4种报文: DHCP DiscoverDHCP OfferDHCP Request DHCP Ack
      DHCP工作过程包括哪四种报文

      本文由 在线网速测试 整理编辑,转载请注明出处。

          热门文章

          文章分类